Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 20:26
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Problem with TightVNCserver dotpup & Puppy 3.01/ROX 2.6.1
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 22 Aug 2006
Posts: 877
Location: ST862228

PostPosted: Fri 28 Dec 2007, 03:30    Post_subject:  Problem with TightVNCserver dotpup & Puppy 3.01/ROX 2.6.1  

I ran into a problem using rarsa's TighVNCserver 1.2.9-0.4 dotpup under Puppy 3.01. This uses a script called vncserver.

Every time I tried to run vncserver, I got (as part of the normal startup messages that are displayed)
Try `ROX-Filer/AppRun --help' for more information.

Then when I tried to use my TightVNC client to attach to the server, I got the old "grey screen of death".

I checked the usual suspect for this problem (permissions on xstartup) to no avail.
I also went back and checked my working Puppy 2.14 setup to see what was different.
Nothing in any of the files was, but I finally remembered that ROX has been updated and the different Puppys run different versions of ROX.

rarsa's script creates /root/.vnc/xstartup as follows:
if [ ! -f "$xstartup" ]; then
     echo "Creating default startup script $xstartup"
     echo "# This is the default startup script for the vnc server," > "$xstartup"
     echo "# You can modify it to fit your needs" >> "$xstartup"
     echo "" >> "$xstartup"
     echo "#xrdb $HOME/.Xresources" >> "$xstartup"
     echo "xsetroot -solid grey" >> "$xstartup"
     echo "xsetroot -cursor_name top_left_arrow" >> "$xstartup"
     echo -e "#xterm -geometry 80x24+10+10 -ls -title \"$VNCDESKTOP Desktop\" &" >> "$xstartup"
     echo "jwm &" >> "$xstartup"
     echo "rox -op /root/Choices/ROX-Filer/PuppyPin" >> "$xstartup"
     chmod 0755 "$xstartup"
   $xstartup &

Running just the rox line in a console on 3.01 and 2.14 gave different results:
On 2.14 (i.e. ROX v 2.5, GTK 2.8.17, 2.8.17) the display went grey then reset back to normal.
On 3.01 (i.e. ROX v 2.6.1, GTK 2.8.17, 2.10.13) I got the message
Try `ROX-Filer/AppRun --help' for more information.

So I tried just rox -p /root/Choices/ROX-Filer/PuppyPin on the 3.01 system and there were no error messages and the grey screen of death was no more.

I'm guessing that the -o option has been removed from the later version?

Anyhow, the workaround is to delete /root/.vnc/xstartup, and to edit line 243 of /root/my-applications/bin/vncserver so that it reads
echo "rox -p /root/Choices/ROX-Filer/PuppyPin" >> "$xstartup"

Hope this helps someone, and maybe someone could upgrade the dotpup to a dotpet with this correction incorporated.

Back to top
View user's profile Send_private_message 

Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Sun 23 Mar 2008, 13:51    Post_subject:  

After a couple of months I got around updating the VNC server to version 1.3.9 and including your proposed fix.


Thank you,

http://rarsa.blogspot.com Covering my eclectic thoughts
http://www.kwlug.org/blog/48 Covering my Linux How-to
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0596s ][ Queries: 11 (0.0094s) ][ GZIP on ]