Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 05:40
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to install desktop-data-manager from source tarball?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
zuesko

Joined: 01 Apr 2007
Posts: 5

PostPosted: Sun 27 Jan 2008, 23:34    Post subject:  How to install desktop-data-manager from source tarball?
Subject description: Installed devx_300.sfs but get "no C compiler" error
 

I'm a linux noob, but have managed to install the devx_300.sfs (hard disk install) and tried install this desktop-data-manager_0.8.10_src.tar.gz.
However as you can see by my ./config output, error no C# compiler.
Does this mean I cannot use this application or is there something further I can do?

# ./configure
checking build system type... i686-pc-linux
checking host system type... i686-pc-linux
checking target system type... i686-pc-linux
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking for pkg-config... /usr/bin/pkg-config
checking for csc... no
checking for mcs... no
checking for mono... no
configure: error: No C# compiler found

Thanking anyone in advance Laughing
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 28 Jan 2008, 00:23    Post subject:  

The devx_301.sfs has the gcc/g++ compiler, but doesn't contain any c# compiler. I don't know whether anyone has compiled mono for puppy? If not, you might need to compile it first:

http://www.mono-project.com/Main_Page
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 28 Jan 2008, 00:32    Post subject:  

There is a mono linux installer available, at the site above. It might suffice to compile/install the program that you're after, but not all functionality will be available with puppy without gnome library files:

Quote:
The Mono version included in the installer should work in all supported Linux versions, including Debian. The installer contains MonoDevelop, but it requires that you have gtk 2.4 or greater installed, as well as the Gnome libraries.


But I see that wow has just posted some gnome .pet files, for pup3.01, in the additional software forum area:

http://www.murga-linux.com/puppy/viewtopic.php?t=25822
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 28 Jan 2008, 00:56    Post subject:  

John Doe has a mono package, for puppy, in this thread

But I don't know what other library files might be required.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0546s ][ Queries: 11 (0.0132s) ][ GZIP on ]