Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Jun 2018, 12:38
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
remastered cd with xfbdev won't boot on Thinkpad600
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message

Joined: 19 Jul 2005
Posts: 62
Location: germany

PostPosted: Sat 01 Oct 2005, 11:31    Post subject:  remastered cd with xfbdev won't boot on Thinkpad600  

OK, perhaps I'm just to stupid to use the right search words.

What I've done: ion 1.0.5 I ran the 'create custom puppy live-cd'
all I changed was: remove the xvesa package and add the xfbdev package.

And then build the new cd. This was to get puppy working on a IBM Thinkpad600, which don't support the xvesa display manager.

while booting from this new CD I get severall error messages like ths:

'cannot create /new_root/root.0/etc/ramdisksize no such file or dir'
'cannot create /new_root/root.0/etc/ramdiskfssize no such file or dir'
and finally it hangs wich this message:
'cannot create regular file '/tmp/rc.reboot'

So what is my mistake while creating the new live CD?
Back to top
View user's profile Send private message 

PostPosted: Mon 03 Oct 2005, 22:36    Post subject:  

I would also like help with this same problem of creating a new puppy cd with xfbdev instead of xvesa as that's the only way I'll get X to run with Puppy on my older model laptop. I added "modules_fb-k2.4.29" and "xfbdev-4.3.0v2xkd" and removed xvesa from the new cd and burt the iso. When I boot the new cd it fails half way through the boot process when it trys to create a directory:

freeing unused kernel memory:132k freed
mkdir: cannot create directory '/new_root': no space left on device
mount: Mounting tmpfs on /new_root failed no such file or directory
Pausing for 60 seconds

I'm creating the cd on a p3 desktop but the target laptop is a Toshiba p2 400MHz with 192M ram. It runs several other full sized distros very well so it would be a shame not to get Puppy running due to it not liking xvesa as I'm sure there would be a speed advantage in the smaller distro. Any help appreciated.
bill dot christiansen at gmail.com
Back to top

PostPosted: Tue 04 Oct 2005, 06:02    Post subject:  

I tried again, this time using the full Puppy_Unleashed procedure instead of the "Create custom Puppy Livecd" option from the menu. The cd I created booted without errors but when I tested the framebuffer driver I got a garbage screen and system locked up so I had to press and hold the power button to shut it down. So it seems that neither of the xservers work with this laptop, strange though as I have used fbdev in DSL and that worked and with the larger distros the trident driver and xorg works.
Back to top

PostPosted: Mon 10 Oct 2005, 12:27    Post subject: 1.05 and framebuffer  

Hello. I'm running a Thinkpad 600 as well, and would like to run 1.05 (chubby variety, actually, and thanks for building that for the unleashed-disabled among us). It was Bladehunter who made the old framebuffer-enabled iso, and he's retired, so I'm not sure what my chances are. I tried using the puppy unleashed wizard on my modern desktop, but I can't get it to mount the hdb1 linux partition I made for it, and so the wizard will not let me proceed. So if I can't use puppy unleashed to make myself a framebuffer-enabled package, is there some other way?

By the way, 1.05 looks great, and the new unleashed wizard looks like exactly what I was dreaming of, so I am looking forward to getting it runnign some day. For now, though, I need to get my laptop running right again (after trying 1.05 I ended up having to delete my pup001 file and reloading the old framebuffer-enabled version). Now I'm trying to remember how I installed OOo from the self-installing tar.gz files. Stupid memory--where'd I put you again?

Back to top
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0426s ][ Queries: 11 (0.0156s) ][ GZIP on ]