Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 11:08
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Can't load sfs files on boot
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
bdika

Joined: 20 May 2007
Posts: 44
Location: London, Canada

PostPosted: Fri 29 Feb 2008, 19:58    Post subject:  Can't load sfs files on boot  

Hi:

I have a frugal install of puppy 301 on hda2 (hd0,1).

I have downloaded devx_301.sfs and openoffice-2.3.0.sfs.

My menu.lst parameters include:

psubdir=puppy301

I have tried placing the sfs files in /mnt/home, in /mnt/home/puppy301 and in / without any success (ie openoffice does not load nor does devx).

This seems to me to be a simple procedure but I am stumped. Am I missing something very obvious here?

Any help would be much appreciated.

Thanks.
Bill Dika
Back to top
View user's profile Send private message 
JustGreg

Joined: 24 May 2005
Posts: 721
Location: Connecticut USA

PostPosted: Fri 29 Feb 2008, 20:12    Post subject:  

You may have to use the boot manager (under the JWM menu System, item Boot Manager configure bootup). It can be used to control the loading of sqs files at boot. I hope this helps you.
_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 29 Feb 2008, 20:28    Post subject:  

On my system I must put them in "/" of the partition, that has pup_save.2fs.
Even if the pup_301.sfs is in a subfolder.
You also can try to pass in grub the option
pdev1=hda2

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
bdika

Joined: 20 May 2007
Posts: 44
Location: London, Canada

PostPosted: Fri 29 Feb 2008, 21:49    Post subject:  

Thanks for the quick replies Mark and JustGreg.

JustGreg:

I've tried using the boot manager with every alternative that I could think of but without any luck.

Mark:

I put them in "/" of the partition, that has the pup_save.2fs and added the option

pdev1=hda2

to the grub options in menu.lst but it didn't seem to make a difference.

I also downloaded OpenOffice-2.3.1.sfs and checked the md5sum (which was correct, but no luck.

I tried adding _301 to the name of the file, also without any luck.

Thanks again for your replies.

Should I be looking at a script in /etc/rc.d/rc.local to manually mount the files on boot?

1. I'm not sure how to do this.
2. It seems like a poor fix for something that should be relatively easy.

Any other ideas would be much appreciated.

I feel like I am missing something obvious.

Bill Dika
Back to top
View user's profile Send private message 
bdika

Joined: 20 May 2007
Posts: 44
Location: London, Canada

PostPosted: Fri 29 Feb 2008, 22:03    Post subject:  

Hi:

You can ignore my last post as it just worked after my last post. I used all your suggestions in combination with a new file and it just worked!

Thanks again.

Bill Dika
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0451s ][ Queries: 11 (0.0043s) ][ GZIP on ]