Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 12:59
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Another widescreen problem
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 07 Mar 2008
Posts: 12

PostPosted: Fri 07 Mar 2008, 20:50    Post_subject:  Another widescreen problem  


All the following matters are true for both 2.17 and 3.01. I have a widescreen monitor, and I am having trouble getting X to give the screen its proper ratios. Under Windows the monitor operates at 1280x800x32. Neither Xvesa nor Xorg offer me options with similar dimensions, so I am currently running at 1024x768x24.

I have tried to fix the matter in Xvesa, following Barry's advice in this post:
Namely, I went to create a file called /etc/resolutionfix, but found that it already existed and contained the appropriate information. I deleted /etc/videomode (there is no /tmp/videomode), restarted X, but was not given a 1280x800 option. This seems so straightforward, its hard for me to see what I might have missed.

I have tried to fix the matter in Xorg, by inserting an appropriate modeline and modes entry in /etc/X11/xorg.conf, as discussed in several posts and other links. Interestingly, the "Modes" entry for 1280x800 was already present. After adding the modeline, and rebooting Xorg, Xorg continued functioning at 1024x768. I might have made some mistake, so I will append my full xorg.conf at the end of this post.



#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
Section "Module"
Load "synaptics"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension

# This loads the font modules
Load "type1"
Load "freetype"

# This loads the GLX module
Load "glx"

# This loads xtrap extension, used by xrandr
Load "xtrap"


# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R7/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

FontPath "/usr/X11R7/lib/X11/fonts/misc/"
FontPath "/usr/X11R7/lib/X11/fonts/Type1/"
FontPath "/usr/X11R7/lib/X11/fonts/TTF/"


# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

Option "RandR" "on"


#everything past here is auto-generated by Puppy's Xorg Wizard...

Section "ServerLayout"
InputDevice "Synaptics Mouse" "AlwaysCore"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "us" #xkeymap0

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto" #mouse0protocol
Option "Device" "/dev/mouse"
#Option "Emulate3Buttons"
#Option "Emulate3Timeout" "50"
Option "ZAxisMapping" "4 5" #scrollwheel

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "0"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.10"
Option "MaxSpeed" "0.30"
Option "AccelFactor" "0.0030"
Option "SHMConfig" "on"
#Option "Repeater" "/dev/ps2mouse"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30-49
VertRefresh 56-61
Modeline "1280x800" 71.1 1280 1328 1360 1440 800 803 809 823 -Hsync +Vsync
#UseModes "Modes0" #monitor0usemodes

#Section "Modes"
# Identifier "Modes0"

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
#Option "ModeSetClearScreen" # [<bool>]
Identifier "Card0"
Driver "vesa" #card0driver
VendorName "Intel Corporation"
BoardName "Mobile Integrated Graphics Controller"
BusID "PCI:0:2:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1280x800"

Back to top
View user's profile Send_private_message 

Joined: 23 Nov 2006
Posts: 10873

PostPosted: Sat 08 Mar 2008, 13:48    Post_subject:  

Driver "vesa" #card0driver

this to me means xorg is using the generic vesa driver rather than one more specific to the graphics card...this may be what is limiting your resolution options.

just my rough guess


try running xrandr in a console......should list available resolutions....perhaps there is one similar but not exactly as you want...another rough guess.
Back to top
View user's profile Send_private_message 

Joined: 07 Mar 2008
Posts: 12

PostPosted: Sat 08 Mar 2008, 19:41    Post_subject:  

xrandr has nothing useful.
However, I just noticed something that seems relevant. When 915resolution is starting or trying to start it gives this error message.


Intel 800/900 Series VBIOS Hack : version 0.5.3

Intel chipset detected. However, 915resolution was unable to determine the chipset type.
Chipset Id: 2a008086
Please report this problem to stomljen@yahoo.com

I hadnt noticed it until now because it normally flashes by when X is loading.
I have reported this to the email given, including the information on my monitor - a Mobile Intel 965 Express.

I assume that this is a dead-end for now, but if anyone has any ideas on how to work around this, Id certainly appreciate it.
Back to top
View user's profile Send_private_message 

Joined: 23 Nov 2006
Posts: 10873

PostPosted: Sat 08 Mar 2008, 21:05    Post_subject:  


though I haven't dealt with it myself there is definately info/fixes floating arount the forum/wiki in relation to getting this particular grapics card fully working as it is particularily stubborn ...do a search for '915'.

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0628s ][ Queries: 11 (0.0032s) ][ GZIP on ]