Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 18:27
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
hplip and hpliplite packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Sat 26 Mar 2011, 22:18    Post subject:  

Or you could do the easy thing. Scroll down the page and download the foo2xxx_rcrsn-2011.03.16.pet.
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sun 27 Mar 2011, 02:27    Post subject:  

disciple wrote:
Quote:
No but they say they list the printers they work on and the 1215 is not among them.

I don't have a clue what list you're referring to now.
foo2hp is included in the foo2xxx package. That's how the package is 11 MB - it includes all the foo2whatever drivers.



I went to the link you provide, a link I had already found. This is what I found there:

"They are best installed using the foo2xxx driver. The applicable models are listed here."

When I clicked that link I got this:

From http://foo2zjs.rkkda.com/

foo2zjs: a linux printer driver for ZjStream protocol
e.g. Minolta magicolor 2200/2300/2430 DL,
HP LaserJet 1018/1020/1022/P2035,
HP LaserJet Pro CP1025nw,
HP LaserJet Pro P1102/P1102w/P1566/P1606dn

That is it, no 1215.

There were 2 links :

. Patriot's original version is here. See Item #13. This package is now out of date, but it contains all the ICM files for colour printers.

Note it does not say laser printers, I do not know if it makes a difference but it should say that unless this advice is for people who need no advice, just a link.

13. foo2xxx_r220909-0.0 (zjs/xqx/slx/oak/hp/xxx) package (11MB) (Printer List)
foo2zjs: a linux printer driver for ZjStream protocol
e.g. Minolta magicolor 2200/2300/2430 DL,
HP LaserJet 1018/1020/1022/P2035,
HP LaserJet Pro CP1025nw,
HP LaserJet Pro P1102/P1102w/P1566/P1606dn
[download]
Description:
Contains full foo2xxx package (Sep 2009) with hplj-firmware-autoloading.
This preliminary driver package have been verified to be working
by x_XP on hp-1020 (thank you).
(Note: Provided for your convenience)

Obviously we are not communicating, if the driver is for the 1215 how would I know? I can try it again but it says what it says.

Thank you for your time
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Sun 27 Mar 2011, 07:42    Post subject:  

Frank Cox wrote:
Obviously we are not communicating, if the driver is for the 1215 how would I know? I can try it again but it says what it says.

No kidding. If you scroll down to the second screen at http://foo2zjs.rkkda.com/, it says
Quote:
HP Color Laserjet CP1215 supported by my foo2hp driver

Both Patriot, disciple and I know for a fact that the foo2xxx PET contains a driver for the CP1215. That's why we are recommending it to you.

If, in fact, you installed the smaller foo2xxx_rcrsn-2011.03.16.pet and it didn't work because the ICM data is missing, simply post a request and I will supply it. Like I said here.
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sun 27 Mar 2011, 14:42    Post subject:  

Quote:

No kidding. If you scroll down to the second screen at http://foo2zjs.rkkda.com/, it says
Quote:
HP Color Laserjet CP1215 supported by my foo2hp driver

Both Patriot, disciple and I know for a fact that the foo2xxx PET contains a driver for the CP1215. That's why we are recommending it to you.


I have said I understood you told me to use the driver and it would work and told you I would try it again and as soon as I can get access to the machine I will.
But here is what it says , as you just said:

These printers are not supported by this driver:

Unsupported Printers

HP Color LaserJet CP1215 Supported by my foo2hp driver

No where have I seen a pet named foo2hp, the driver you said to install is number 13 on Patriots page which links to the same page you provided a link to that says it won't work. Forgive me but that seems a bit confusing to me. Maybe you could just put a note there that the package contains the foo2hp? I know you are busy but I think it would confuse anyone who did not already know.
Quote:

If, in fact, you installed the smaller foo2xxx_rcrsn-2011.03.16.pet and it didn't work because the ICM data is missing, simply post a request and I will supply it. Like I said here.


I don't know why it did not work. I supplied a link to the driver -foo2hp- that I was going to try and compile when I found out where to get the icm files. Here is the link again :

http://pastebin.com/TnkZ7kEH

I would much rather use on of your pets , should the smaller one work as is?
Maybe I had the wrong cups 1.39 ? Do i have to ditch 431?

Thanks
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Sun 27 Mar 2011, 15:06    Post subject:  

Quote:
Maybe I had the wrong cups 1.39 ? Do i have to ditch 431?

Puppy 4.3.1 doesn't have CUPS 1.3.9 - it has 1.1.23. In any case, the package I recommended came from the page titled "How to Install your printer in Lupu/Quirky/Wary." It does not apply to 4.3.1 and does not work there.

However, Patriot's original foo2xxx package does appear to work in 4.3.1. It has been confirmed to work with your printer by other users.
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sun 27 Mar 2011, 16:19    Post subject:  

rcrsn51 wrote:
Quote:
Maybe I had the wrong cups 1.39 ? Do i have to ditch 431?

Puppy 4.3.1 doesn't have CUPS 1.3.9 - it has 1.1.23. In any case, the package I recommended came from the page titled "How to Install your printer in Lupu/Quirky/Wary." It does not apply to 4.3.1 and does not work there.

However, Patriot's original foo2xxx package does appear to work in 4.3.1. It has been confirmed to work with your printer by other users.


I know , I added it . So I am no longer confused the only hope I have of making this work is the driver at number 13 on Patriots page and do not upgrade cups?
Is that correct?

Thank you
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Sun 27 Mar 2011, 16:46    Post subject:  

If you attempted to upgrade CUPS and did it wrong, nothing will work. You need the original CUPS 1.1.23 and Patriot's foo2xxx package.

BTW, the download link you reference above contains the exact source code for what you are getting in the PETs.
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sun 27 Mar 2011, 20:26    Post subject: Thanks  

rcrsn51 wrote:
If you attempted to upgrade CUPS and did it wrong, nothing will work. You need the original CUPS 1.1.23 and Patriot's foo2xxx package.

BTW, the download link you reference above contains the exact source code for what you are getting in the PETs.


Thanks a million. Hopefully I will have i working tomorrow.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Tue 29 Mar 2011, 04:42    Post subject:  

How'd it go?
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Tue 29 Mar 2011, 07:06    Post subject: Not yet  

Don't know yet. maybe tonight
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Tue 29 Mar 2011, 07:54    Post subject:  

As a counter-example to the accusations that (A) it's hard to install a printer in Puppy and (B) community members are unfriendly to newcomers, you might want to read here. Notice how this user asked the appropriate question - How do I install Printer X in Puppy version Y?
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Tue 29 Mar 2011, 09:02    Post subject:  

rcrsn51 wrote:
As a counter-example to the accusations that (A) it's hard to install a printer in Puppy and (B) community members are unfriendly to newcomers, you might want to read here. Notice how this user asked the appropriate question - How do I install Printer X in Puppy version Y?


I am not going to argue with you, sometimes the printing setup is easy but finding an example to imply that it is always easy as long as the right questions are asked when I know for a fact many very experienced users have pulled their hair out trying to make it work sometimes won't fly.

I don't think Patriot would make that claim. Suit yourself, blame someone if it makes you feel better blame me.
Back to top
View user's profile Send private message 
Frank Cox

Joined: 01 Nov 2009
Posts: 381

PostPosted: Sat 02 Apr 2011, 01:34    Post subject: Here it is  

Well i installed Patriots driver and printed a beautiful black and white page so I configured the printer on the next copy of the same 431 pupsave for color and it said the job requested was too large and failed to work again .When I decided to live with black and white I went back to the first and it was also toast.

Thanks for trying but I think it would be cheaper to set up a windows machine as a print server .
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Sat 02 Apr 2011, 16:07    Post subject: Re: HP 1215 Color Laser jet  

Frank Cox wrote:
Is there a puppy distro that this printer will work from out of the box?

There is at least one report, see http://murga-linux.com/puppy/viewtopic.php?p=449629&search_id=708099047#449629,
stating that the HP 1215 Color Laser jet works with Lupu-510 and the
additional foo2zjs-hp-cp1215-i486.pet package, which contains already the ICM file for HP 1215 Color Laserjet. I have reuploaded it to http://www.datafilehost.com/download-9d73dca1.html, if you will to try it.
It also is recommended to install the hotplug capabilities, included in the attached pet in this message.
Hope that helps.
foo2zjs-hotplug-i486.pet
Description 
pet

 Download 
Filename  foo2zjs-hotplug-i486.pet 
Filesize  2.97 KB 
Downloaded  507 Time(s) 
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Sun 03 Apr 2011, 09:54    Post subject: Re: Here it is  

Frank Cox wrote:
When I decided to live with black and white I went back to the first and it was also toast.

That's strange. Did you try restarting the printer between tests?. It may be that the printer was hung up by the aborted colour job so it wouldn't print the second monochrome job.

Quote:
I configured the printer on the next copy of the same 431 pupsave for color and it said the job requested was too large and failed to work again

Colour laser print jobs need lots of memory. The easiest work-around is to lower the resolution, if the driver allows it.

@lluamco: With all due respect, your download looks like Patriot's foo2xxx package, but compiled in Puppy 5.1. We have already established that it won't work in Frank Cox's Puppy 4.3.1. Also your hotplug PET is not needed here. The CP1215 does not require a firmware download.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0922s ][ Queries: 12 (0.0057s) ][ GZIP on ]