Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Jul 2015, 08:51
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Persistence and editing of /etc/modules.conf
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 04 Aug 2005
Posts: 15
Location: Minneapolis - USA

PostPosted: Sat 08 Oct 2005, 10:24    Post_subject:  Persistence and editing of /etc/modules.conf  

Hi all,

I'm thoroughly stymied by this. I run Puppy 1.0.5 (Chubby) from HD by booting it from FreeDos, copying image.gz, vmlinuz, usr_cram.fs, rather than the full HD install. I need to add one alias to /etc/modules.conf to get my wireless card (which doesn't work with the normal wireless tools) recognized as wlan0.

So can anyone tell me how to go about making a permanent change to /etc/modules.conf in this situation? I have tried adding the line in /etc/modules.conf0 above and below the "Puppy will append stuff here" line, I've tried deleting /etc/modules.conf and rebooting, in hopes that it will be recreated by /etc/modules.conf0 as seems to be implied by the info in that file. In these cases, /etc/modules.conf pops back up like always without the line I need.

Lastly, I have tried deleting /etc/modules.conf from /mnt/ram1 and using save2image, but was not able to boot from that image.gz.

According to the info at the top of modules.conf/modules.conf0, I am permitted to edit the latter. Does this only count for a full hard disk install, and not work for the poor-man's install or flash users?

How and when is /etc/modules.conf created?

Any suggestion would be really appreciated.

Raising puppies since 1.04
Back to top
View user's profile Send_private_message 
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Sun 09 Oct 2005, 00:03    Post_subject:  

From what I can recall, if you edit modules.conf0, it should stay

As a last resort you could edit /etc/rc.d/rc.local,
with some code to append something to /etc/modules.conf, before
doing anything involving wlan0.
Back to top
View user's profile Send_private_message Visit_website 

PostPosted: Sun 09 Oct 2005, 01:13    Post_subject:  

Hi Barry,

Thanks for your reply. While changes to modules.conf0 do persist after a restart, it doesn't seem like they had any effect, as

#modprobe wlan0

was not successful.
For whatever reason that save2image* didn't work for me, I did manage to edit modules.conf and manually unzip and modify image.gz.

I can now load the module without difficulty on my rebuilt image.gz. But are you saying that modules.conf0 is also indexed by modprobe? I had assumed it was just read and used to build modules.conf.

Thanks for giving us Puppy,
Back to top
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sun 09 Oct 2005, 03:53    Post_subject:  

you can put cp -f /etc/modules.conf0 /etc/modules.conf at the top of /etc/rc.d/rc.local0 ... or anywhere in rc.local0 or rc.local ... and it will copy modules.conf0 to modules.conf

i don't know if this will be useful or not ... i think if you copy modules.conf0 to modules.conf first and then modprobe wlan0 (maybe in rc.local), modprobe might use the configuration in modules.conf

anyway, option 1 Puppy does not seem to copy modules.conf0 to modules.conf
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0454s ][ Queries: 11 (0.0036s) ][ GZIP on ]