Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 00:51
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Can't use PupGet pzckage manager in 1.0.5
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
puppian


Joined: 18 Jul 2005
Posts: 538
Location: PuppyLand

PostPosted: Sun 09 Oct 2005, 15:35    Post_subject:  Can't use PupGet pzckage manager in 1.0.5  

I was trying to installed the slmodem pupget package, which had been copied to /root already. When asked where do I want to have the package downloaded, I choosed 'Local'. However no matter which directories I browsed to, there's NOTHING there!

---------------------

I ended up installing it as an alien package, still can't connect thou... Sad
I've followed the instruction in this post. It's an Intel(R) 536EP Modem and below is the information WinXP gives (some words are deleted as they're not in english):

Code:

Intel(R) 536EP Modem
ID   PCI\VEN_8086&DEV_1040&SUBSYS_10008086&REV_00\3&61AAA01&0&50
Internal Modem
COM3
PCI\VEN_8086&DEV_1040&SUBSYS_10008086&REV_00\3&61AAA01&0&50
Intel Corporation
INF path:   oem3.inf
Intels51
X4
X3
%C0+DS=0,0;+DS44=0,0;
%C1+DS=3,0;+DS44=3,0;
+ES=3,2,4;
+ES=1,0,1;
+ES=3,0,2;
&K3

&K0
&K4
DCB:   
<
0
Ring tone:   +MA=V34,V32B,V22B,BELL212,BELL103;
CCITT   +MS=V90,1,0,0,0,0;
AT
P
AT&F<cr>
Intel(R) 536EP Modem::Intel Corporation::Intel Corporation
M1
M0
M2
M3
L3
L0
L2
<cr>
T
0xDFC00000-0xDFFFFFFF
IRQ 18


In fact I don't know whether my modem is a slmodem, ltmodem, HCF modem or HSF modem. All these terms are the same for me Embarassed I've read the Puppy Help files but still has no idea...
Any help appreciated Smile

_________________
Puppylinux.org - Community home page of Puppy Linux hosted by Barry (creator of Puppy), created and maintained by the Puppy Linux Foundation since 2005

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11122
Location: Arizona USA

PostPosted: Sun 09 Oct 2005, 16:14    Post_subject:  

HCF and HSF modems are "softmodems", also known as "Winmodems" because they used to only work in Windows. They are modems in which some or all of their signal processing is implemented in software, in the form of drivers which are proprietary compiled binaries that will only run in Windows. Linux drivers have been developed for some softmodems, but not all.

However, even hardware modems, which appear to the OS as more-or-less stand-alone black boxes, don't always work in Linux. I found out the hard way that Linux has a problem with at least one internal hardware dial-up modem.

From what I can tell, your modem is not a softmodem or you wouldn't get any response from it at all. Beyond that, I'm afraid I can't help you. Sorry.
Back to top
View user's profile Send_private_message 
puppian


Joined: 18 Jul 2005
Posts: 538
Location: PuppyLand

PostPosted: Mon 10 Oct 2005, 01:02    Post_subject: Re: Can't install 'local' PupGet files in 1.0.5  

Then it's probably a slmodem or ltmodem. The modem wizard recognized the modem, but gkdial won't connect no matter which tty* I chose Confused

puppian wrote:
I was trying to installed the slmodem pupget package, which had been copied to /root already. When asked where do I want to have the package downloaded, I choosed 'Local'. However no matter which directories I browsed to, there's NOTHING there!

Is this a bug?

_________________
Puppylinux.org - Community home page of Puppy Linux hosted by Barry (creator of Puppy), created and maintained by the Puppy Linux Foundation since 2005
Back to top
View user's profile Send_private_message Visit_website 
syzygy

Joined: 03 Jul 2005
Posts: 76
Location: wollongong

PostPosted: Mon 10 Oct 2005, 05:43    Post_subject:  

not sure about slmodem, but pup1.05 works fine with ltmodem. the wizard id's my modem & suggests i download ltmodem package, (which i do at net cafe), then install, reboot & sees it perfectly.

my sister's HSF modem also works, & seems to be faster than with XP. there is problem that we have puppy loses it's configuration & we have to rei-install. (jcoder suggested work around for this but haven't tested yet).

have you tried using scanmodem to id your modem? mentioned & linked to in this post:-

http://www.murga.org/~puppy/viewtopic.php?t=2468&highlight=scanmodem

also i'm curious if you have more than one operating system on your hard disc? i've noticed that when i've had windows on 1 partition, & puppy on another, i had to deactivate windows using the winmodem for puppy to see the IRQ, (interrupt request), that the modem was using. this isn't just a windows thing as i've currrently got 2 puppies & only one can use modem.

i think is probly because they're software, but don't see how, when you reboot, this prevents other OS using same port. ( i read somewhere somebody asking linus torvalds about hardware compatibility probs with linux, to which he responded there were none. the interviewer asked again, & torvalds apparently again said there are none. but realising the interviewer was talking about winmodems said that they're software, NOT hardware.
Back to top
View user's profile Send_private_message 
puppian


Joined: 18 Jul 2005
Posts: 538
Location: PuppyLand

PostPosted: Mon 10 Oct 2005, 14:41    Post_subject:  

Thanks syzygy Smile

I can't get scanModem to work. When I run scanModem it says I need "pciutils", so I then downloaded a pciutils debian package and installed it.
However ./scanModem still says "Please install the package: pciutils":

Code:
# ./scanModem
UPDATE=2005_Oct_1
ONLY use scanModem downloaded as: http://linmodems.technion.ac.il/packages/scanModem.gz

./scanModem should ONLY be run within a Linux/UNIX partition.
If within a MicroSoft/DOS partition, abort with Ctrl-C now !!!
Copy scanModem.gz to your Linux partition and restart.

grep: /boot/config*: No such file or directory
./scanModem: line 289: gcc: command not found
+----------------------------------------------+
|    WARNING: lspci not found  - exiting       |
|    Please install the package:  pciutils     |
+----------------------------------------------+


And running lspci gives:
Code:

# lspci
0:0.0 1106:3148
0:1.0 1106:b091
0:10.0 8086:1040
0:16.0 1106:3038 (rev 80)
0:16.1 1106:3038 (rev 80)
0:16.2 1106:3038 (rev 80)
0:16.3 1106:3104 (rev 82)
0:17.0 1106:3177
0:17.1 1106:0571 (rev 06)
0:17.5 1106:3059 (rev 50)
0:18.0 1106:3065 (rev 74)
1:0.0 5333:8d04

I have an Option1 install and Puppy is four files in 2 Fat32 partitions where Win98 is installed. Is that the reason that scanModem won't run?

--------------------------
And Puppy Modem Wizard gives:
Code:
Puppy has found a PCI modem:
  Bus  0, device  10, function  0:
    Communication controller: Intel Corp. 536EP Data Fax Modem (rev 0).
The vendor:chip numbers are (hex): 8086:1040

After I installed the slmodem package:
Gkdial: The connection was lost or a connection being tried was not successful...
wvdial: Modem not detected. Press OK button to quit...
eznet: ...failure....

==================

I was able to get my modem works in Puppy 1.0.3 by installing Intel's driver intel-536ep-4.69-rh9-up.tgz however.
If anyone is interested here is the how-to:

The readme.txt inclueded tells you to make, make install, but I only followed these steps (also in readme) and it works too (no need to compile):
Code:

ATTENTION:  if the driver compiles but the script just wont work for you.
   Here are the bare minimum steps to get your modem to work.

   0.  log in as root.
   1.  insmod -f Intel536.o (Intel536.ko for kernel 2.6)
   2. you can start "hamregistry &" at this point if you wish.
   3.  rm /dev/536ep
   4.  mknod /dev/536ep c 240 1   (note "240" is the default, if it does not
       work see what /proc/devices says 536ep's major number is)
   5.  ln -s /dev/536ep /dev/modem
   6.  start a comm application like minicom and use the modem.
   7.  see section 3 (International Users) for info on setting the correct
       country settings.

I copied all the extracted files to /root and then do the above from the command line and to load the module everytime Puppy boots, I made a script called 'modem' and called it from /root/.xinitrc
Code:

#!/bin/sh
insmod -f Intel536.o
rm /dev/536ep
mknod /dev/536ep c 240 1
ln -s /dev/536ep /dev/modem

--------------------------
This approach works in 1.0.3, but not anymore in 1.0.4 and 1.0.5. Insmod gives:
Code:

# insmod -f Intel536.o
Warning: kernel-module version mismatch
        Intel536.o was compiled for kernel version 2.4.20-8
        while this kernel is version 2.4.29
Warning: loading Intel536.o will taint the kernel: non-GPL license - Proprietary
  See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Warning: loading Intel536.o will taint the kernel: forced load
Module Intel536 loaded, with warnings

And gkdial just stay "Connecting" after I clicked the Connect button (with the yellow light). Will recompiling the driver help?

Log given by eznet:
Code:

This is a diagnostic log of the most recent login attempt by eznet.

  ISP Name: "wharf"
  Call Initiated: Tue Oct 11 00:58:58 2005

The UNIX command used to initiate the connection attempt was:

/usr/sbin/pppd /dev/modem 115200 connect '/usr/bin/eznet chat 0' defaultroute lock modem mtu 552 mru 552 crtscts -detach idle 300 user anonymous remotename wharf

The interaction with the modem was as follows:


The following messages were written to the system log
(in /var/log/messages) by pppd as it attempted to negotiate
a PPP connection.  To see more detail, set the "debug=yes"
property and reattempt the logon.

Oct 11 00:58:58 (none) daemon.notice pppd[1020]: pppd 2.4.1 started by root, uid 0
Oct 11 00:58:58 (none) daemon.notice pppd[1020]: Removed stale lock on modem (pid 998)

--------------------------
syzygy wrote:

also i'm curious if you have more than one operating system on your hard disc? i've noticed that when i've had windows on 1 partition, & puppy on another, i had to deactivate windows using the winmodem for puppy to see the IRQ, (interrupt request), that the modem was using. this isn't just a windows thing as i've currrently got 2 puppies & only one can use modem.

Do you mean deactivate it from the "Device Manager"? When getting the modem work in Puppy 1.0.3, I haven't done anything in windows, it just works with the intel driver. And yes you are right. I have 4 operating systems on two harddisks. One of the harddisks has Win98, it's an old 6GB harddisk which I'll never boot from. It's there just for data storage.

Sorry for the long post... I tried the above because the news page said we'll still be using kernel 2.4.29 in 1.0.6 and I want to have a working 1.0.6 puppy... but I think I'd better give up...

_________________
Puppylinux.org - Community home page of Puppy Linux hosted by Barry (creator of Puppy), created and maintained by the Puppy Linux Foundation since 2005
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0776s ][ Queries: 11 (0.0034s) ][ GZIP on ]