Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 21:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Noteedit and MuseScore
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
Taavi

Joined: 10 Mar 2006
Posts: 146
Location: Suomi, Finland

PostPosted: Sat 19 Apr 2008, 06:53    Post subject:  Noteedit and MuseScore  

MuseScore: http://mscore.sourceforge.net/en/idx.php
NoteEdit: http://noteedit.berlios.de/

I tried to make them work, but didn't manage. But got pretty close. Both had mess with GUI buttons.

That's what it tells me:

# noteedit
kbuildsycoca running...
noteedit: ERROR: Error: standard icon theme "crystalsvg" not found!
LilyPond check: not available.
Setting version to 2.6.3
found version: 2.6.3
TSE3 ALSA MIDI scheduler created
There is no MIDI port 0. I try 0!
TSE3 Copyright information : (c) Pete Goodliffe, 2000-2002. A Trax Software Product. Version: 0.3.1
kded: WARNING: KServiceType::offers : servicetype KDEDModule not found
# mscore
QPainter::begin: Cannot paint on a null pixmap
QPainter::end: Painter not active, aborted
fluidsynth: error: Unable to open file "/usr/piano1.sf2"
fluidsynth: error: Couldn't load soundfont file
fluidsynth: error: Failed to load SoundFont "/usr/piano1.sf2"
ISynth: Failed to load SoundFont "/usr/piano1.sf2"Synti init failed
sequencer init failed
#

I have tried with many packages from many places. One of the Mscore packages didn't give fluidsynth error. I have it installed.

If I remember right this one of NoteEdit packages were from debian and iI took the TSE3 from there too. Maybe Mscore was from ubuntu?

What am I missing?

I was playinrg with them last night and one program to try was LMMS and thanks for muggins there is now pet for it.

Taavi
Back to top
View user's profile Send private message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sat 19 Apr 2008, 19:08    Post subject:  

Dear Taavi,

I also had a problem with compiling 0.9.2 of musescore. First of all, you need QT4 with the dev libs and cmake, all of which I have. Although I didn't seem to get the same errors as you, I did get errors and was too lazy to trace the origins. I think, in semi-desperation, I just grabbed a .deb version of 0.9.1 and installed it. It works OK. I can't say much about noteedit but I recall I had some old version working.

Once I start more serious investigation of the compilation errors in musescore, we should compare notes.

With kind regards,
vovchik

PS. Musescore has the potential of being a very useful scoring program.
Back to top
View user's profile Send private message 
amigo

Joined: 02 Apr 2007
Posts: 2173

PostPosted: Sun 20 Apr 2008, 02:09    Post subject:  

I have Slack packages of noteedit and tse here:

http://distro.ibiblio.org/pub/linux/distributions/amigolinux/download/Extra/KDE-QT/

Sorry I can't be of any help for musescore since I don't usually have Qt/KDE stuff installed...
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 13 Jun 2008, 13:18    Post subject:  

Hi Guys

Well I was building a kde version of bibletime, What a task that was, Anyways I went to kdelook and there was MuseScore once again, So I said what the heck might as well try to compile it one more time.
Well it worked !! everything , all images no errors when starting it via console etc, When I went to package it up, The same thing missing pictures on the buttons.
I tried it on my other testing pc,
They both have puppy 4.0, Plus both testing bibletime/kde
The difference between them are
pc that worked
My dev_x_400.pet
It was compiled in this pc.
here's a screenshot of it,
I spent hours trying to work it out, I even transfered the full qt4 libs over to the other pc and still no go.
well hope that helps you out some,
I think it might be some sort of hidden configure file.
ttuuxxx
mscore.png
 Description   
 Filesize   259.62 KB
 Viewed   516 Time(s)

mscore.png


_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0539s ][ Queries: 12 (0.0053s) ][ GZIP on ]