Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 17:27
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.2.8
Post new topic   Reply to topic View previous topic :: View next topic
Page 91 of 120 [1793 Posts]   Goto page: Previous 1, 2, 3, ..., 89, 90, 91, 92, 93, ..., 118, 119, 120 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Sun 04 Nov 2012, 15:49    Post subject:  

gjuhasz
Thank you for your feedback.
I have edited the pMusic 3 page with links to gtkdialog-0.8.2 for many Puppy distros. Please also note that pMusic-2.9.9 is not a minor update (a complete rewritten core), so it is recommended to (re)move the dir /root/.pmusic to get a fresh start.


Sigmund


Download pMusic 3 - RC here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Sun 04 Nov 2012, 17:06    Post subject:  

pMusic 3 - RC2





Download pMusic 3 - RC2 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 4628
Location: Charleston S.C. USA

PostPosted: Mon 05 Nov 2012, 00:14    Post subject:  

Slacko beta2 k3.2.31 [opera, NO PAE]

Pmusic 2.6.6
Pmusic-> help->Dependency Check

Get this for result of check..
capture11975.png
 Description   
 Filesize   9.65 KB
 Viewed   397 Time(s)

capture11975.png


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Mon 05 Nov 2012, 04:06    Post subject: Pmusic-2.9.10 test  

Slacko-5.3.6.5 with Firefox. Pmusic-2.9.10.
After start Pmusic hangs up inself and it hangs up all system. I run it in terminal and it appears to be that Pmusic's "find" endlessly looking for some of my files links in ./wine directory. It continues even after Pmusic's GUI is killed. It took few minutes to start Screeny to take a snapshot. Maybe "find" has a high priority and all other processes have to wait for it.
capture20604.png
 Description   Pmusic hang up
 Filesize   19.91 KB
 Viewed   389 Time(s)

capture20604.png

Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 06:34    Post subject:  

bigpup
Message will be correct in pMusic 3


Download pMusic 3 - RC2 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 06:38    Post subject:  

rodin.s
Good catch!!!

I am rather sure the reason is a symlink-loop in .wine (used to be there earlier), and pMusic follows symlinks which should NOT be necessary.

Will you please help test it?
Edit 'find -L' to just 'find' in line 13, 17 and 158 in /usr/local/pmusic/func_index.


Thanks a lot
Sigmund




Download pMusic 3 - RC2 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
gjuhasz


Joined: 29 Sep 2008
Posts: 136

PostPosted: Mon 05 Nov 2012, 09:47    Post subject: Playing speed?  

Pmusic plays streams with incorrect speed.
In my case "Ride with me" from Hoovers is played much slower if UI is present (or faster in other cases?).
I attached a screenshot showing response for top command.
See the first couple of process rows causing huge CPU load. Very strange.
top.jpg
Description 
jpg

 Download 
Filename  top.jpg 
Filesize  66.23 KB 
Downloaded  225 Time(s) 
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 10:01    Post subject:  

The consuming processes are related to pMusic's indexing at first run (if not started manually from MyMusic setup).
I wonder if your issue is the same as explained in previous post. You can kill the 2 top pids.


Sigmund


Download pMusic 3 - RC2 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Mon 05 Nov 2012, 10:09    Post subject: "find" hang up  

Yes, this problem is solved by removing '-L' from 'find'. There are some other problems I can hardly describe, like main GUI window becomes unresponsive while playing a song maybe due to some background processes and all buttons disappear from it,,,
When I close pMusic another pEqualizer is started.
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 10:36    Post subject:  

rodin.s
Please make sure you run a fresh install after removed '-L'. You might have a enormous db to handle with. (re)move /root/.pmusic should do it. If you have defined local storage somewhere else, this should also be deleted.

What processes are running when pMusic is running
ps | grep -i pmusic
Any terminal output?
pmusic --debug


Thank you
Sigmund




Download pMusic 3 - RC2 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 15:26    Post subject:  

pMusic 3 - RC3





Download pMusic 3 - RC3 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Mon 05 Nov 2012, 16:20    Post subject:  

Pmusic-3 RC3 (2.9.11) I have only one problem left...

The splash screen pops up for about 1 second, then about 2-3 seconds later Pmusic gui shows, then the splash pops up again, and causes "Ride with Me" to start again. I built the index successfully and I am running wine.

Just a note that 2.9.10 there was no splash screen.

Ick! The splash is popping up on second run too and misbehaving! Oh crap! My index disappeared too!

HTH

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 17:27    Post subject:  

Mick
I am on to it

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 17:43    Post subject:  

Ok, I made to reproduce the bug related to initializing (splash) more than once. Start pmusic first time, and before closing it (it will then save settings are reset first_run variable) I run pmusic again. That could be as simple as sending a signal from the tray app, clicking on a file in Rox ... FIXED.

I could not make it corrupt my index file, but sure, it doesn't sound illogical that it might happen.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5564
Location: Valåmoen, Norway

PostPosted: Mon 05 Nov 2012, 17:46    Post subject:  

pMusic 3 - RC4





Download pMusic 3 - RC4 here

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 91 of 120 [1793 Posts]   Goto page: Previous 1, 2, 3, ..., 89, 90, 91, 92, 93, ..., 118, 119, 120 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0876s ][ Queries: 12 (0.0240s) ][ GZIP on ]