Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 26 Jul 2014, 01:22
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.3.8
Post new topic   Reply to topic View previous topic :: View next topic
Page 103 of 122 [1820 Posts]   Goto page: Previous 1, 2, 3, ..., 101, 102, 103, 104, 105, ..., 120, 121, 122 Next
Author Message
charlie6

Joined: 30 Jun 2008
Posts: 992
Location: South of Belgium

PostPosted: Wed 02 Jan 2013, 04:47    Post subject:  

Hi Sigmund !
zigbert wrote:
Version 3.0.7
See main post

Changelog
- Bugfix: Detection of installed pMusic older than version 3.0.0 (thanks to L18L)


I installed pMusic-3.0.7 on Exprimo-3.6.2.1 which has version 2.6.6 in it + gtk-dialog.0.8.2+ffmpeg version >>0.8.
Result: pEqualizers GUI comes first displayed before the pMusic GUI opens; and when closing pMusic (Menu/Quit), pEqualizers GUI is displayed a second time. So at end, we have pMusic closed with 2 times pEqualizer open.

Does someone else also have this?

*** Best wishes for 2013 ! ***
Charlie
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Thu 10 Jan 2013, 13:39    Post subject:  

Just a quick report about the progress.
I am working slowly towards 3.1. It depends on gtkdialog-0.8.3 which Thunor released the other day. I will wait for a Slacko/Precise platform that includes all dependencies. - It makes it soooo easy for me. Wink

Running several RadioHits grabber could corrupt the MyMusic database (index-file), so I have rewritten that function. I am still refining, but it basically works like this screeny:



The New Export window have settled:



The podcast setup has been rewritten simplified.
It now looks too simple.



Else, I have improved the smartadd dock by adding a 'add all' option without any new bloat



The trackinfo function has got some improvements, but maybe only one that really matters...
You can now set Album tag directly from the discography.



And there has arrived a new playmode. Maybe not the best icon (any suggestions?)


_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Mon 14 Jan 2013, 15:21    Post subject:  

pMusic 3.1.0 will support embedded albumart images in audio files.
This requires ffmpeg 0.11 or newer.


_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Wed 16 Jan 2013, 13:30    Post subject:  

Version 3.1.0
See main post

Changelog
- Updated dependencies
. . . .- gtkdialog 0.8.3
. . . .- ffmpeg 0.11
. . . .- pschedule 1.1.2
- Export
. . . .- Presets for convertion.
. . . .- Disable bitrate/samlerate/channel options when choosing flac. (requires gtkdialog 0.8.3)
. . . .- Removed option to save exported files to m3u.
. . . .- Simplified gtkdialog code.
. . . .- Accept blank settings for channel/bitrate/samplerate.
- Add to playlist
. . . .- Option to Add all from the smartadd dock.
. . . .- Add non-existing file gives option to remove file from db.
. . . .- Bugfix: Add after playing always grabs the first instance of the song (in case of several).
. . . .- Bugfix: Msg: File does not exist: Bold text doesn't work if not valid utf-8 filename.
- Overview -> Most played -> now set to last 30 days instead of 60 (variable RATING_PERIODE in rc).
- Searchresult shows rating of all times instead of using variable RATING_PERIODE in rc.
- Podcast
. . . .- Simplified manager gui.
. . . .- New dialog to delete a pod.
. . . .- Bugfix: Show next run (human readable) in pSchedule.
- New playmode: None --> stop after playing song.
- Improved tooltips for playmode and addmode.
- Trackinfo
. . . .- Album-tag: Option to choose Album from discography.
. . . .- Support embedded image files (albumart) to audio file.
. . . . . . . .- Use as default albumart if exist.
. . . . . . . .- Write embedded image to audio file from albumart tab (save button).
. . . . . . . .- Added as refresh-albumart source.
. . . . . . . .- Also supported by masstagger.
. . . .- Don't reload trackinfo if corresponding info already exist
. . . . . . . .- ie. same album or when moving slider.
. . . . . . . .- This gives a marked reduction of cpu usage.
. . . .- Lyrics: #8217 is set to ' in lyricswiki converter
. . . .- Lyrics: Edit (button) not found lyrics, now makes an empty lyrics file.
. . . .- Message if searching alternativ tags and no web connection.
. . . .- Albumart: default size is set to 400px - click for full size.
. . . .- Save tags: blank tag-icons immediately to show action.
. . . .- By default, suggest an album tag from an album/single instead of various-artist-album.
. . . .- Bugfix: Tracknr-tag is now by default choosen depending on album - next searces for singles or compilations.
. . . .- Bugfix: No internet gave 2 messages when searching for alternative tags.
. . . .- Bugfix: If changing a Artist/Title tag before clicking 'Alternative tags' old tag-info are back after new tags are activated.
. . . .- Bugfix: Read stream info from ffmpeg 0.11 >
. . . .- Bugfix: Saving tags breaks album-pmu-detection.
- Rewritten Radiohits grabber.
. . . .- All streamrippers in one gui.
. . . .- Option to delete a preset.
. . . .- Advanced expander: Allow manual options to streamripper command.
. . . .- Advanced expander: Show streamripper command.
. . . .- Bugfix: Apply several RadioHits grabbers simultaniously could corrupt MyMusic index.
- Gtkdialog
. . . .- Only supported gtkdialog executable is now 'gtkdialog'. (thanks to 01micko)
. . . .- Link to gtkdialog homepage in about dialog.
- Use bash as the interpreter for all scripts.
- Save (playlist)
. . . .- More logical auto-setting of 'save-path' in save dialog.
. . . .- Tooltip for option: Include path.
. . . .- Bugfix: Add more info (1.col of sourcelist) to mymusic index.
- Set 'all time' as default time-periode in most-played dialog.
- Update length-description in db after use of $AUDIO_EDITOR (MhWaveEdit).
- Masstagger
. . . .- Handle embedded albumart.
. . . .- Bugfix: Clear tags.
. . . .- Bugfix: Set genre to Blues from drop-down menu.
- Plugins
. . . .- Icon in Tray app switches Play/Pause. (thanks to 01micko)
. . . .- Cleanup: Remove Trayapp setting in rc.
- Updated About information.
- Nad4: link to new addmode-icon.
- Bugfix: Make /tmp/ dir during install sticky. (thanks to 01micko)
- Bugfix: Moving progress slider halts playing. - Improved, but still not perfect.
- Bugfix: Click on playing track in playlists (replay) hides the play-icon.

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 780
Location: USA

PostPosted: Wed 16 Jan 2013, 13:33    Post subject:  

keep the good work up zigbert.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 780
Location: USA

PostPosted: Wed 16 Jan 2013, 21:49    Post subject:  

pMusic says that one of my songs doesn't exist, but I check if it's there and it is there. But GNOME-Mplayer works fine with the song. Actually it's not just one song, it's all of my songs that fail to work with pMusic.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2056
Location: Ontario Canada

PostPosted: Wed 16 Jan 2013, 23:42    Post subject: Pmusic 3.1.0  

It's working okay in puppy mage 2 once I found out how to add albums to the playlist.
EDIT:the album cover changed in the now playing screen but the song title didn't.
pmusicscrn2.jpg
 Description   
 Filesize   22.36 KB
 Viewed   149 Time(s)

pmusicscrn2.jpg

pmusicscrn.jpg
 Description   
 Filesize   24.02 KB
 Viewed   183 Time(s)

pmusicscrn.jpg


Last edited by Billtoo on Wed 16 Jan 2013, 23:52; edited 1 time in total
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 780
Location: USA

PostPosted: Wed 16 Jan 2013, 23:43    Post subject:  

what 2nd image?
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2056
Location: Ontario Canada

PostPosted: Wed 16 Jan 2013, 23:54    Post subject:  

bark_bark_bark wrote:
what 2nd image?


Puppy Mage 2 puplet, but I've added the newest gtkdialog and updated ffmpeg.
Back to top
View user's profile Send private message 
charlie6

Joined: 30 Jun 2008
Posts: 992
Location: South of Belgium

PostPosted: Thu 17 Jan 2013, 03:56    Post subject: play midi files  

Bonjour Sigmund !
Merci for pMusic3.1.0 !
just wondering if pMusic would play midi files if for instance Timidity was installed?
thanks for any answer
charlie
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 04:42    Post subject:  

bark_bark_bark wrote:
pMusic says that one of my songs doesn't exist, but I check if it's there and it is there. But GNOME-Mplayer works fine with the song. Actually it's not just one song, it's all of my songs that fail to work with pMusic.
Shocked Please give more info.
Did you browse / search ... ?
Did it stop working or did it fail from the beginninig?
Screenshot?


Thank for any report
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 04:44    Post subject: Re: Pmusic 3.1.0  

Billtoo wrote:
It's working okay in puppy mage 2 once I found out how to add albums to the playlist.
Will you please explain what is not logical. I am really interested in giving the best user experience.

Billtoo wrote:
EDIT:the album cover changed in the now playing screen but the song title didn't.
Fixed for 3.1.1


Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5647
Location: Valåmoen, Norway

PostPosted: Thu 17 Jan 2013, 04:54    Post subject: Re: play midi files  

charlie6 wrote:
Bonjour Sigmund !
Merci for pMusic3.1.0 !
just wondering if pMusic would play midi files if for instance Timidity was installed?
thanks for any answer
charlie
There is a possibility for a future midi support. I have not tested it, but theoretically, pMusic could handle midi.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2056
Location: Ontario Canada

PostPosted: Thu 17 Jan 2013, 05:58    Post subject: Re: Pmusic 3.1.0  

zigbert wrote:
Billtoo wrote:
It's working okay in puppy mage 2 once I found out how to add albums to the playlist.
Will you please explain what is not logical. I am really interested in giving the best user experience.

Billtoo wrote:
EDIT:the album cover changed in the now playing screen but the song title didn't.
Fixed for 3.1.1


Thank you
Sigmund

It's logical, I just had to poke around a bit to find out what I needed to do because I'm unfamiliar with pmusic.
I plan to use it more now though Smile
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 780
Location: USA

PostPosted: Thu 17 Jan 2013, 08:47    Post subject:  

zigbert wrote:
bark_bark_bark wrote:
pMusic says that one of my songs doesn't exist, but I check if it's there and it is there. But GNOME-Mplayer works fine with the song. Actually it's not just one song, it's all of my songs that fail to work with pMusic.
Shocked Please give more info.
Did you browse / search ... ?
Did it stop working or did it fail from the beginninig?
Screenshot?


Thank for any report
Sigmund


i think my guess would be that pmusic doesn't like filenames with spaces. I can listen to the radio though. But I don't want change my preference on filenames of Music. Is there a workaround

_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 103 of 122 [1820 Posts]   Goto page: Previous 1, 2, 3, ..., 101, 102, 103, 104, 105, ..., 120, 121, 122 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1183s ][ Queries: 12 (0.0281s) ][ GZIP on ]