Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 19:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.3.9
Post new topic   Reply to topic View previous topic :: View next topic
Page 117 of 123 [1831 Posts]   Goto page: Previous 1, 2, 3, ..., 115, 116, 117, 118, 119, 120, 121, 122, 123 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 10 Aug 2013, 07:00    Post subject:  

Simargl. Could you open Deadbeef how to thread. I would like to know how you download with Deadbeef net radio streams database of thousands of net radios like Pmusic does. And how do you get Deadbeef to show those thousands of net radio stations organized by genre or country ?

It is not always question of absolute speed. It is also question of the improved functionality.

I know that your post was meant to provoke posts....semi-trolling.
Deadbeef is fast for what it does and it is good for what it does. But...that is not the point. Pmusic does something which most of the music apps does not.
Clementine comes closest for what I want from the music app. But even it does not do it the way I want it to do it. Pmusic does. Hmm...the size comparing. I think Pmusic is slightly smaller than Clementine....

Anyway....discussion of Deadbeef and power usage features is definitively worth of separate thread. Waiting for it....
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Sat 10 Aug 2013, 17:12    Post subject:  

pemasu wrote:
I noticed your scripts asked usleep. So...I downloaded busybox and symlinked /bin/usleep into busybox. There might be some other needed binaries or busybox symlinks still missing.
Thank you, I will get rid of those. I don't want to depend on busybox!!!!!


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Sat 10 Aug 2013, 17:24    Post subject:  

simargl wrote:
Plus it can be combined with its infobar plugin so you get artist and song info, lyrics etc.
Awesome
_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
DemostiX

Joined: 24 Apr 2009
Posts: 46

PostPosted: Mon 16 Sep 2013, 03:05    Post subject: Ogg codec settings in PMusic 4.1.1
Subject description: Seems to default to "flac" level of compression
 

1. With Slacko 5.5 and 5.6, at least, the bitrate settings, at least above 124kb, are ignored when I encode with ogg , and the resultant files seem instead to be about the size of flac-encoded ones, roughly half the original size.

2. It is not clear that the "presets" on the left of the "Convert" page specify particular codecs. Which is OK, just not this user's expectation. But, that is NOT the cause of being unable to specify a bitrate for ogg encoding.

3. Once a Preset is chosen, it seems not possible to clear the selection except by going back to the previous screen. Unchecking the "Convert exported tracks" check box results in the whiting out of the selection.

From http://trac.ffmpeg.org/wiki/TheoraVorbisEncodingGuide I find:

Variable Bitrate (VBR)
ffmpeg -i input.mkv -codec:v libtheora -qscale:v 7 -codec:a libvorbis -qscale:a 5 output.ogv

<snip>


Note: if you omit -codec:a libvorbis then ffmpeg will default to the native FFmpeg flac audio encoder for ogg/ogv output container.

So, maybe the last "Note:" above is the explanation for the failure.
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Tue 17 Sep 2013, 14:03    Post subject:  

DemostiX

Quote:
3. Once a Preset is chosen, it seems not possible to clear the selection except by going back to the previous screen. Unchecking the "Convert exported tracks" check box results in the whiting out of the selection.
The preset is just meant as guides for the user. It should be possible to set your own settings. Any manual setting will override the preset.

At the moment, pMusic is not supporting encoding into variable bitrate.

The ogg/flac issue seems related to ffmpeg - not pMusic. (Or am I misunderstanding?)


Thank you for the feedback
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Mon 23 Sep 2013, 12:43    Post subject:  

Version 4.1.2
See main post

Changelog
- Play track from right-click menu.
- Bugfix: Delete a file in the builtin browser doesn't update sourcelist.
- Bugfix: Make doubleclicking in playqueue more sensitive.
- Bugfix: Use sleep (bash) instead of usleep (busybox). (thanks to pemasu)
- Bugfix: Delete (right-click-menu) item containing () doesn't update sourcelist.
- Bugfix: Update preset-list when deleting an radio-hits preset.

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1104

PostPosted: Mon 21 Oct 2013, 00:02    Post subject:  

No radio playback from pMusic 4.1.2 in Precise 5.7.1, dependency check showed newer gtkdialog as only missing package. After updating gtkdialog the problem persists.
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Mon 21 Oct 2013, 12:01    Post subject:  

Hello vicmz,

Do you mean that you have installed gtkdialog and the dependency check in pMusic still shows it as missing? If so you need to make sure (in Precise Puppy) that the gtkdialog binary is in /usr/bin rather than /usr/sbin and you may need to remove older binaries from those locations. I believe the best way is to just have the one latest gtkdialog binary and any gtkdialog3 or gtkdialog4 can be symlinks to it. If these are in /usr/bin I don't think they are also needed in /usr/sbin but you can always add more symlinks just to be sure. Installing the gtkdialog for Precise posted by Zigbert should work though, but you need to make sure it was not another gtkdialog package which installs the binary in /usr/sbin

Or do you mean that the dependency check in pMusic now shows gtkdialog as "OK" but you still have no radio playback?

_________________
Oscar in England

Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1104

PostPosted: Tue 22 Oct 2013, 01:48    Post subject:  

Not only radioplayback is inexistent, now I have no Internet, too. Shocked Posting from mobile right now. I listened to a few MP3s and album art and lyrics downloaded OK. I can usually browse the web OK until I open pMusic and install the radio index, then it takes ages to connect back.
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Tue 22 Oct 2013, 08:55    Post subject:  

So does the dependency check in pMusic now show gtkdialog as "OK" or not?

If you have upgraded pMusic from the original version 2 to version 4.1.2 it might be an idea to try deleting the hidden folder /root/.pmusic and then starting pMusic again.

_________________
Oscar in England

Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1104

PostPosted: Tue 22 Oct 2013, 13:22    Post subject:  

I deleted /root/.pmusic/ and launched again. Installed radio index: no radio playback, no working radio stations, message: no connection. But I do have connection, I'm posting from my computer right now and my ISP is OK, music files get lyrics and albumart when played. Usually after this I reboot and suddenly have no more Internet for the rest of the day. I'll see what happens this time.
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Thu 24 Oct 2013, 06:11    Post subject:  

vicmz
I don´t see the clear answer, and I am at an internet cafe, so not much I can test until I am home again (3 weeks).

Please post any info you fetch. If this is related to pMusic, I really want to fix it.

Has pMusic worked for you before? Another pMusic version? - another Puppy release?


Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1104

PostPosted: Thu 24 Oct 2013, 18:00    Post subject: pmusic 3.3.0
Subject description: test
 

Removed latest Pmusic
Installed Pmusic 3.3.0 on Precise 5.7.1
Song files played OK
Lyrics and album art OK
Installed radio index
Click country: UK, had to click > button to display radio list
Launched BBC Radio 1: no playback
Launched other radio stations: no playback
Re-launched former stations: playback OK (slow-responsive?)
Launched Argentinian stations: mostly no playback (weird radio links?)

This time I have radio playback, but it takes one or two minutes to start (how is that for broadband? does linux-firewall have something to do?). I'll try v2.6.7 later. Maybe I can try the latest in a RAM-only session. (v4.1.2 response to ALL radio stations: no connection - and Internet does work)

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Mon 11 Nov 2013, 15:06    Post subject:  

Version 4.2.0
See main post


Changelog
- Trackinfo:
. . . .- Splash when loading trackinfo window.
. . . .- Faster updating of data in already loaded trackinfo-window.
. . . .- Album:
. . . . . . . .- Right-click-menu
. . . . . . . . . . . .- Add to playque.
. . . . . . . . . . . .- Edit albumlist in text-editor.
. . . . . . . . . . . .- Set track source.
. . . . . . . . . . . .- Export info to masstagger.
. . . . . . . .- Multiple selction and doubleclick
. . . . . . . .- Bugfix: Press refresh-button should delete content of list at once to give a response.
. . . . . . . .- Bugfix: Always clean up source-field from last track.
. . . . . . . .- Bugfix: Don't try musicbrainz if connetion is false.
. . . . . . . .- Bugfix: Doesn't work if missing connection to internet.
. . . .- Albumart:
. . . . . . . .- Delete now also optionally remove local image file.
. . . . . . . .- Bugfix: Info-icon uses font (i), and is buggy if font is. Replaced with pure vector graphics.
. . . .- Metatags:
. . . . . . . .- Bugfix: Info about missing metatags (red arrows) failed if no internet connection.
. . . . . . . .- Bugfix: Check connection for 'Search alternative metatags'.
. . . . . . . .- Bugfix: Add msg when searching alternative tags and no connection to web.
. . . . . . . .- Bugfix: Save tags should update corresponding info in sourcelist.
. . . . . . . .- Bugfix: Clear Artist/title tag removes info in db. Column 2 should be using filename.
. . . .- Add gain value (used by normalize) into stream info.
. . . .- Bugfix: 'Missing meta info' showed up in wrong column in Artist tab.
. . . .- Bugfix: Album list and album-art contains info for previous track if current track misses album tag
. . . .- Bugfix: Preferences stated 'Track info when browsing'. This is not true.
. . . .- Bugfix: Open the trackinfo window for playing track failed when the track starts playing/buffering.
. . . .- Bugfix: Clean up audio-format in stream info tab.
- Sourcelist:
. . . .- Go back to single-click to play track. Doubleclick has been troblesome on my system.
. . . .- Right-click option for non-exsisting files: Fix corrupted file in db.
. . . .- Right-click option to edit the file containing Favorites Marks.
. . . .- Bugfix: Right-click menu: Fix pmu could corrupt 'Artist - Title' in pmu.
. . . .- Bugfix: Export only valid files when 'Send to masstagger'.
. . . .- Bugfix: Update sourcelist when renaming source file.
. . . .- Bugfix: Expand *.pmd when path is not found in db.
. . . .- Bugfix: Remove expanded favorite list when other lists are expanded too corrupts sourcelist.
- Masstagger:
. . . .- More accurate progressbar during tagging.
. . . .- Bugfix: Lock index file when updating db.
. . . .- Bugfix: Send to masstagger, and masstagger window is NOT already open.
. . . .- Bugfix: Clear tags removes info in db. Column 2 should be using filename.
- My music:
. . . .- Update info in pMusic storage when moving your collection to another location.
. . . . . . . .- Update content of 'Album/Favorite lists' added to MyMysic setup.
. . . . . . . .- Check/fix playlists when expanding and adding to playqueue.
. . . .- Editor:
. . . . . . . .- Search inside editor.
. . . . . . . .- Faster loading of gui and snapier in use.
. . . . . . . .- Don't add to playqueue from editor.
. . . .- Always open Setup with indexer tab by default.
. . . .- Bugfix: Use file-locking of db when renaming file and in func_progressbar.
. . . .- Bugfix: If file does not exist and is not moved, open the fix_db dialog.
. . . .- Bugfix: Cancel 'building db' failed when function run 'remove non-existing items'.
. . . .- Bugfix: Cancel 'building db' if user closes dialog via wm.
. . . .- Bugfix: Search alternative source for playing track failed for filename with '(some text)'.
. . . .- Bugfix: Update gui (trackinfo) when playing alternative source without length description.
. . . .- Bugfix: Playlist get corrupted when playing alternative source for a track with & in filename.
- Add:
. . . .- Bugfix: Add a favorite list when path is no longer valid.
. . . .- Bugfix: Directory gets added when smartadd by sort order.
. . . .- Bugfix: Smartadd doesn't take min_rating when adding from db.
- Menu-item for 'Clear playqueue' and 'Show/hide docks' didn't use pmusic-spesific icon.
- Func_progressbar is now running with LC_ALL=C (no utf) for speed/resource usage.
- Show icon (audio_url) for radio stations when browsing genre/country.
- Use -m switch for pBurn - go straight to burn-options dialog (pBurn-4.3.0).
- Save playqueue as plain txt file - only path-list.
- 'Show location' in builtin browser if Rox is not present.
- New icon for playlist setup/repair.
- Use pSchedule-icon for button in podcast setup.
- Updated Nad theme (New icon for playlist setup/repair).
- Remove func-file Box_progress - not in use.
- FAQ: Can I get bigger font in the lyrics window?
- Bugfix: Use file-locking when writing to playqueue to prevent collapsing of que.
- Bugfix: Rename source file: if name in playlist is not meta-tags, name-column should be updated too.
- Bugfix: Playqueue corrupts when removing a track from queue when track exists more than once in queue.
- Bugfix: Use progress slider stops the audio playing.

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
sheldonisaac

Joined: 21 Jun 2009
Posts: 398
Location: Philadelphia, PA

PostPosted: Mon 11 Nov 2013, 20:35    Post subject:  

zigbert wrote:
Version 4.2.0
See main post


The info in the Changelog is dizzying.
I just installed it, works fine.

Thanks,
Sheldon

_________________
Dell D610: Windows XP, Puppy Linux 5.2, 'lina-lite
Intel D865GBF: Windows XP, Puppy Linux 5.2
Acer Aspire One: Windows XP, Puppy Linux 5.2
ASUS P5A: MS-Windows 98SE, Puppy Linux 2.14X
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 117 of 123 [1831 Posts]   Goto page: Previous 1, 2, 3, ..., 115, 116, 117, 118, 119, 120, 121, 122, 123 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1276s ][ Queries: 12 (0.0286s) ][ GZIP on ]