Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 12:57
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Localizing scripts
Moderators: Lobster, MU, raffy
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 9 [132 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
droope


Joined: 31 Jul 2008
Posts: 814
Location: Uruguay, Mercedes

PostPosted: Fri 13 Feb 2009, 19:23    Post subject:  

Thanks, that solved line 110 Smile

But now, after i go through the screenshot's window, i get a weird thing:

Code:
Xdialog v2.3.1 by Thierry Godefroy <xdialog@free.fr> (v1.0 was
written by Alfred at Cyberone Internet <alfred@cyberone.com.au>).
Xdialog home page available at: http://xdialog.dyns.net/

Usage: Xdialog [<common options>] [<transient options>] <box option> ...

Common options:
  --wmclass <name>
  --rc-file <gtkrc filename>
  --backtitle <backtitle>
  --title <title>
  --allow-close | --no-close
  --screen-center | --under-mouse | --auto-placement
  --center | --right | --left | --fill
  --no-wrap | --wrap
  --cr-wrap | --no-cr-wrap
  --stderr | --stdout
  --separator <character> | --separate-output
  --buttons-style default|icon|text

Transient options:
  --fixed-font
  --password (may be repeated 2 or 3 times before --2inputsbox or --3inputsbox)
  --password=1|2 (for --2inputsbox or --3inputsbox)
  --editable
  --time-stamp | --date-stamp
  --reverse
  --keep-colors
  --interval <timeout>
  --timeout <timeout> (in seconds)
  --no-tags
  --item-help (if used, the {...} parameters are needed in menus/lists widgets)
  --default-item <tag>
  --icon <xpm filename>
  --no-ok


And it goes on and on..


Console tells me that:
Code:
/tmp/asd/remasterpup2: line 49: kill: (1660) - No such process
SIZETOTALM=443
WKGPART=sda1


(the number of the process changes)
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 13 Feb 2009, 19:43    Post subject:  

hm, for me, it works here.
I run it like this
cd /root/tests/xwin-localized
./remasterpup2


Maybe you must not run it from /tmp/.

What you can do, is to add echo statements (debug-messages), so that you see, where in the code the script currently is.

Like for example around line 33:
Code:

#choose where to create isolinux-builds/ directory...
Xdialog --wrap --left --title "${L_WELCOMET}" --msgbox "${L_WELCOME}" 0 0


Code:
 echo "------------------TEST 1"
#choose where to create isolinux-builds/ directory...
Xdialog --wrap --left --title "${L_WELCOMET}" --msgbox "${L_WELCOME}" 0 0
 echo "------------------TEST 2"


Like this you will find out, where the script stopped.
If the Xdialog (line 35) would have an error, the last thing you would see would be:

------------------TEST 1

So you know, that the error is in line 35.


The long error you got, shows, that a line with "Xdialog" is working wrong.
Certainly again a " instead of \".
This is a very common mistake, that also often happens to me.

Mak

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
droope


Joined: 31 Jul 2008
Posts: 814
Location: Uruguay, Mercedes

PostPosted: Fri 13 Feb 2009, 20:57    Post subject:  

No, mine isn't working. Sad It's a really weird mistake, it happens after selecting the drive.


I'll give further effort to it tomorrow.

Cheers, and thanks a lot
MU
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Sat 14 Feb 2009, 14:22    Post subject:  

Bonjour,
@droope,
Here is the remasterpup script localized almost finished.
But there is one large issue with the "custom-puppy" variable (line 478).

All is OK until the iso file creation.
I don't know how to resolve it.
Maybe someone can help?

@ MU,
I have modified script as you said and uploaded the new one (in this post), but still issue when creating iso file.
Seems the line 478 below has no effect

Quote:
rxvt -bg orange -title "${L_WELCOMET}" -e mkisofs -D -R -o $WKGMNTPT/custom-puppy-$PUPPYVERSION.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table $WKGMNTPT/puppylivecdbuild/


Cordialement Wink

updated remasterpup2_420_LOC.tar.gz on feb 17. Needs ntfs fix.
remasterpup2_420_LOC.tar.gz
Description 
gz

 Download 
Filename  remasterpup2_420_LOC.tar.gz 
Filesize  13.28 KB 
Downloaded  763 Time(s) 

_________________
Toutou Linux - Pets francisés

Last edited by esmourguit on Tue 17 Feb 2009, 03:49; edited 2 times in total
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 15 Feb 2009, 03:32    Post subject:  

esmourguit

at first look I see nothing problematic, except line 475:
Code:
 Xdialog --wrap --left --title "${L_WELCOMET}" --yesno "${L_CLICKYES} 'custom-puppy-${PUPPYVERSION}.iso' ${L_CLICKYES1} ${WKGMNTPT}/ ${L_CLICKYES2} ${WKGMNTPT}/${L_PLCDB}/ ${L_CLICKYES3}" 0 0



Here you use ' instead of ".

So it should be:
Code:
 Xdialog --wrap --left --title "${L_WELCOMET}" --yesno "${L_CLICKYES} "custom-puppy-${PUPPYVERSION}.iso" ${L_CLICKYES1} ${WKGMNTPT}/ ${L_CLICKYES2} ${WKGMNTPT}/${L_PLCDB}/ ${L_CLICKYES3}" 0 0


Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Sun 15 Feb 2009, 07:17    Post subject:  

Bonjour,
@ MU,
I have modified script as you said and uploaded the new one (previous post), but still issue when creating iso file.
Seems the line 478 below has no effect

Quote:
rxvt -bg orange -title "${L_WELCOMET}" -e mkisofs -D -R -o $WKGMNTPT/custom-puppy-$PUPPYVERSION.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table $WKGMNTPT/puppylivecdbuild/


Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Sun 15 Feb 2009, 08:14    Post subject:  

Bonjour,

@Mu
When i test on Puppy 420 alpha and beta1, i choose to create the puppylivecdbuild on NTFS partition, and the remasterpup2 localized script couldn't create iso file.
When i changed the target partition to ext2, there is no more issue.
So, it's OK for creating iso file on linux partition, but not on ntfs partition (with Puppy 420 beta1).
Maybe we can test on others versions.

Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 15 Feb 2009, 08:40    Post subject:  

in Newyearspup it works, but it is different:
-other windowmanager
-urxvt

You might try 2 things:

1.) do not use a translation for the rxvt title, so use the old code:

Code:
  rxvt -bg orange -title "Puppy simple remaster CD" -e mkisofs -D -R -o $WKGMNTPT/custom-puppy-$PUPPYVERSION.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table $WKGMNTPT/puppylivecdbuild/


2.) if this still fails, set a "safe" locale:

Code:
#echo $LANG
#echo $LC_ALL
OLDLANG=$LANG
OLDLC=$LC_ALL
export LANG=C
export LC_ALL=C
 rxvt -bg orange -title "Puppy simple remaster CD" -e mkisofs -D -R -o $WKGMNTPT/custom-puppy-$PUPPYVERSION.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table $WKGMNTPT/puppylivecdbuild/
export LANG=$OLDLANG
export LC_ALL=$OLDLC


Note that you should run remasterpup2 from a consolewindow, to see possible errors.
I get this message from urxvt, but it works nevertheless (LANG is set to "fr"):
urxvt: default locale unavailable, check LC_* and LANG variables. Continuing.

Mark

_________________
my recommended links

Last edited by MU on Sun 15 Feb 2009, 08:56; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 15 Feb 2009, 08:52    Post subject:  

concerning ntfs please check, if you can mount such partitions read/write with pmount.

remasterpup2 has a check for the partitiontype and should mount using the option "-t ntfs".
Maybe the beta versions had bugs in "mount".
In newyearspup, it works using a NTFS drive (based on Puppy 4.1.1).
It just must not have been mounted before with Muppyquickmount, as that mounted read only (solved by servicepack 2).

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Mon 16 Feb 2009, 10:46    Post subject:  

Bonjour,

@ MU,
It remains one issue now, but essential: create custom-$PUPPYVERSION.iso on ntfs partition.
I checked on 4.1.2 and the custom-$PUPPYVERSION.iso on ntfs failed.
I changed ' by " on lines 70 and 77 (as you said) and now, the status of partitions appear in the popup about selection of partition in which create puppylivecdbuild.
But creation of custom-$PUPPYVERSION.iso file still failed on ntfs partition.
Tried partition mounted first then not mounted, but each failed.
I think it lacks the option ("-t ntfs") you told in previous post in the remasterpup2 script.
Mounting read/write ntfs partition by Pmount is OK.

Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 16 Feb 2009, 17:21    Post subject:  

yes, Puppys "mount" expects the option "-t ntfs", or it will not mount read/write.
I'd suggest to incorporate this little bugfix.

Mark.

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
droope


Joined: 31 Jul 2008
Posts: 814
Location: Uruguay, Mercedes

PostPosted: Mon 16 Feb 2009, 18:39    Post subject:  

I'm so confused, did you fix it? Surprised

I' am the most unorganized person in the world, but still i am trying to organize the troops back in the spanish forum to work together. We are going to move forward, i'm starting to finish. I wish someone would organize me here, and tell me what to translate, because i don't know what should be done here.

Edit: Besides, i don't think we are getting any attention... i'm starting to get angry, since we are not in the beta, i think Sad I'll download and check.
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Tue 17 Feb 2009, 03:45    Post subject:  

Bonjour,

@Mu,
Thanks for your reply,
Quote:
yes, Puppys "mount" expects the option "-t ntfs", or it will not mount read/write.
I'd suggest to incorporate this little bugfix.

But as you know i'm not a coder. Please tell us where include this ntfs fix.

@Droope,
remasterpup2 is almost completed (it can't create the custom iso on ntfs partition), it needs the ntfs fix by Mark Uhlrich.
I'm going to beguin puppyinstaller script soon.

Updated in previous post remasterpup2 archive

Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Tue 17 Feb 2009, 06:04    Post subject:  

Bonjour;

@Droope,
Here is a list of script to be localized. They are in /usr/sbin :
alsaconf, bootmanager, burniso2cd, cdburner-wizard, chooselocale, connectwizard : already localized, countrywizard, cups_shell, delayedrun,
deskshortcut.sh, didiwiki-gui, dotpuprox.sh, eventmanager, filemnt, firewall_install.sh, firewallinstallshell, floppy-format.sh, gparted_shell, grubconfig, icon_switcher, input-wizard, modemprobe, modemprobe_erase, modemtest, modem-wizard, ndiswrapperGUI.sh, net-setup.sh : already localized, pcdripper, pdict, Pdisk, pdvdrsab, petget, pmetatagger, pmount, pppconnect, pppdisconnect, Pudd, pupdial, puppyhelp, puppyinstaller : current localazing, puppypdf, pupscan, Pwireless, remasterpup2 : already localized, resizepfile.sh, run-pureftpd, save2flash, save2image, savesession-dvd, scannerwizard.sh, securetelnetshell, set-time-for-puppy, set-xftdpi.glade, set-xftdpi.sh, snapmergepuppy, timezone-set, video-wizard, wag-profiles.sh, wakepup2, wirelesswizard, wizardwizard, xf86svga336wizard, xorgwizard : already localized, xrandrshell, xserverwizard.
What about that?
Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Tue 17 Feb 2009, 06:04    Post subject:  

Double post supprimé
_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 9 [132 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0914s ][ Queries: 12 (0.0150s) ][ GZIP on ]