Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 01:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Puppy 4.2 Alpha4 Seamonkey Bugs & Fixes
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 14 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 5754
Location: Valåmoen, Norway

PostPosted: Fri 13 Feb 2009, 16:54    Post_subject:  

Warren
I have updated the Ptray package. Version 0.4 also handles the show/hide of left/right-tray. The package contains fixmenus and globicons. These should be included by hand to their original packages.

If you want the new close-button on top of tray instead of bottom, it is just to switch those lines in /root/.jwmrc-tray-add_icon(.bak) and /root/.jwmrc-tray-add_widget(.bak)


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Fri 13 Feb 2009, 17:24    Post_subject: Re: mounting a vfat partition on a usb connected HDD.  

WhoDo wrote:
Béèm wrote:
With alpha 4.20, I can address all partitions except the vfat one.
A very annoying fact. (In fact I realize now, that the same problem was there already from alpha one on)
No problems with 4.1.2

Is there hope for a solution?

There is always "hope" Béèm. I'll look into it.
Thanks WhoDo.
I knew you would say that. Wink
There is no hurry, as it's still alpha time.
Altho I'll be abroad for the next 5 weeks, I'll look at this interesting thread.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Fri 13 Feb 2009, 18:34    Post_subject:  

ttuuxxx wrote:
Network Printing also works, I set the printer as a server and went to my other pc on the LAN and selected file print, and I printed the google homepage. Now thats the first time I've printed over my home network which is cat5 with a adsl2+modem 4 port router. Since xp like 4 yrs ago. really cool, too bad my wife uses xp, hmmmmm.
anyways glad its working. tomorrow I'll try to reduce the size.
ttuuxxx


Well it's now a lot better for me too! My experience is this :-

1. My (network attached) printer was discovered straight away. Smile
2. Selecting the suggested protocol of socket://192.168.0.11 didn't work with the closest included driver. Sad
3. Selecting the suggested protocol did work with a specific ppd file downloaded from linuxprinting.org. Smile
4. Manually selecting socket://192.168.0.11:9100 didn't work with the closest included driver, but did work with the specific downloaded .ppd file. Smile

Conclusion: as long as the specific ppd file is used the CUPS setup now works. Very Happy

In case it is relevant the printer is an HP Photosmart 2575. The closest included driver is HP PhotoSmart 2700 Foomatic, and the one that works is HP-PhotoSmart_2570-hpijs.ppd.

_________________
Nick
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Fri 13 Feb 2009, 21:11    Post_subject:  

ttuuxxx ,

Installed your new printer .pets, unfortunately they didn't work with my HP Photosmart C5280. It doesn't provide an option for usb printers.

Thanks for working this CUPS problem,
Jim
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10831
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 13 Feb 2009, 22:06    Post_subject:  

Jim1911 wrote:
ttuuxxx ,

Installed your new printer .pets, unfortunately they didn't work with my HP Photosmart C5280. It doesn't provide an option for usb printers.

Thanks for working this CUPS problem,
Jim


Hi jim did you try the usb plugin ?
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=15011
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Fri 13 Feb 2009, 22:41    Post_subject:  

ttuuxxx,

It worked by adding that usb plugin. It recognized my C5280 printer and was able to print a test page with an old 1315 driver. I installed the hpijs-2.8.10.pet which has the correct driver for the C5200 series but couldn't get that driver to work.

Thanks,
Jim
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Fri 13 Feb 2009, 22:41    Post_subject:  

ttuuxxx,

It worked by adding that usb plugin. It recognized my C52080 printer and was able to print a test page with an old 1315 driver. I installed the hpijs-2.8.10.pet which has the correct driver for the C5200 series but couldn't get that driver to work.

Thanks,
Jim
Back to top
View user's profile Send_private_message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Fri 13 Feb 2009, 23:15    Post_subject:  

JMX wrote:
2) When I use "Open Terminal Here" that opened location should automatically be in the PATH for that opened terminal session.
No, it should not. Standard *nix behavior is to not include the local directory in the path. Changing it would make things even more confusing, because then we wouldn't be standard anymore. If we start messing around with things that are that fundamental, we eliminate the new user's ability to trust generic Linux guides found on the web. How we have it now may be a little odd at first, but it is more consistent.

I do agree that /usr/local/sbin should be in the path. Also, /usr/local/lib should be in the LD_LIBRARY_PATH (or /etc/ld.so.conf) if it isn't already in 4.2 (I forget).

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10831
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 13 Feb 2009, 23:30    Post_subject:  

Jim1911 wrote:
ttuuxxx,

It worked by adding that usb plugin. It recognized my C52080 printer and was able to print a test page with an old 1315 driver. I installed the hpijs-2.8.10.pet which has the correct driver for the C5200 series but couldn't get that driver to work.

Thanks,
Jim

jim can I have the link to that pet for that driver please? I want to look at the package.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 14 Feb 2009, 00:10    Post_subject:  

zigbert wrote:
Warren
I have updated the Ptray package. Version 0.4 also handles the show/hide of left/right-tray. The package contains fixmenus and globicons. These should be included by hand to their original packages.

Thanks, Sigmund. Included for Puppy-4.2Beta1. Wink

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 14 Feb 2009, 00:13    Post_subject:  

Pizzasgood wrote:
JMX wrote:
2) When I use "Open Terminal Here" that opened location should automatically be in the PATH for that opened terminal session.
No, it should not. Standard *nix behavior is to not include the local directory in the path. Changing it would make things even more confusing, because then we wouldn't be standard anymore.

Cool, PG! Cool I hadn't worked out what to do with that request and now I know.

@JMX - I guess you'll have to continue amending this one by hand. Sorry.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 14 Feb 2009, 00:15    Post_subject:  

@ttuuxxx - it looks like all the hard work on CUPS may have paid dividends. I'll include these files in Puppy-4.2Beta1 in the hope that there are no more major problems related to CUPS. Thanks, mate! Very Happy
_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10831
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 14 Feb 2009, 00:34    Post_subject:  

Hey WhoDo

-how long do I have before you need the finals for the beta ?
-Do you know which plugins for things like abiword did you remove? If not I could figure it out, but it'll take more time.

I still have a bit to do on icewm and Cups, right now the Cups package is very large, I'll be able to remove a good size chunk but it will need more testing. I'll keep backups for somethings to fall back on in case something goes wrong. Plus do you know what parts will be going in like gutenprint? or is that a repo item.
thanks
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
cthisbear

Joined: 29 Jan 2006
Posts: 3437
Location: Sydney Australia

PostPosted: Sat 14 Feb 2009, 02:46    Post_subject:  

Well most things seem nice and smooth.

But the drive icons.
This has to be addressed as well as unmounting.

2 quick tests.

Old IBM Pentium 111 1 gig chip 512 ram
Must have had 8 extra drives show up.
Triangular icons obviously faulty....removed them.
The hard drive would not unmount at all.
I did not know you could right click to unmount.
Used xorg...as only 1 meg video card on this computer.

Interesting..I booted my 2.8 celeron 512 ram.
Used xvesa.
Now....all these drive icons started to appear.
Selected my screen size 1024x 768.
Saved it.
Spare drives disappeared.

After cleaning my XP install out....my usual way,
the drives refused to unmount.
I then tried right click on the drives to unmount them.
Success.

So maybe this has been already raised, but is it a
joint Pmount and Xorg setting making it worse?
Just strange the extra icons started to appear
and then vanish.

Not a criticism as such.
Highly annoying and mischievous.
So much good work and this piddly bug.
To me this must be fixed soonest.

Oh! well that's why you have Alphas.

I shall try and look more tonight.

Hooroo to all....and regards.............Chris.
Back to top
View user's profile Send_private_message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 14 Feb 2009, 03:53    Post_subject:  

ttuuxxx wrote:
-how long do I have before you need the finals for the beta ?

I planned on uploading within 2 hours, but if you can reduce the size significantly that's worth waiting for. I have the Beta running on my machine and it's (choke) almost flawless! Hope I don't come to regret that rash statement! Razz

ttuuxxx wrote:
-Do you know which plugins for things like abiword did you remove? If not I could figure it out, but it'll take more time.

As far as I'm aware I didn't remove ANY plug-ins for Abiword. Confused

ttuuxxx wrote:
I still have a bit to do on icewm and Cups, right now the Cups package is very large, I'll be able to remove a good size chunk but it will need more testing.

If you can get me 3Mb, we'll be all but ready for the RC! Wink Sorry but I had to leave Murrina out because of size problems. Clearlooks is still in of course. I'll give you back Murrina if you can get me the 3 meg! Laughing

ttuuxxx wrote:
I'll keep backups for somethings to fall back on in case something goes wrong. Plus do you know what parts will be going in like gutenprint? or is that a repo item.

Gutenprint is in. I have installed ALL of the CUPS pet files you mentioned so CUPS should be complete and epdf viewer now works again. Foomatic is also back in. Current size is 102Mb, even including CUPS, CUPS docs, Gutenprint etc. Smile

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 14 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1230s ][ Queries: 12 (0.0315s) ][ GZIP on ]