Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 17:48
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Why does Firefox 3.06 keep crashing on Puppy Linux 4.1?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 02 Apr 2009, 13:19    Post subject:  

big_bass wrote:
Quote:
HyerMan
At least have a fatpuppy version that has a rock solid browsing experience.




My main focus is stability
I don't care about new version numbers I stick to what works
I can't aford to lose time and work caused by a browser crash
since the browser gets heavily abused by me everyday


don't upgrade to firefox 3.00 when it asks for an update


I built this one
http://puppylinux.ca/tpp/big_bass/firefox-2.0.0.14-flash-9.0.124.0.pet


just a note: even on Slackware (with full lib packages )firefox 3+ has problems after it upgrades


there are other options
pick the one that works

big_bass


Yes I agree with that fully, Smile
Like FirePup on series 4.0+ Smile
or ff3 on Dpup
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Thu 02 Apr 2009, 14:30    Post subject:  

ttuuxxx

good to hear that firefox3+
works on a Debian base

I am working on a "build" so I'll be busy for quite ahwile
*won't have time to mess with the latest firefox 3+*
and like I said above I only care to have a solid system
at this point in time I don't even care about the final size
of the ISO

just want it solid

that means there is something on the Debiian base that is needed
for puppy and slackware

the bad part is when firefox version 3+
crashes it does a total lock up frozen solid
which makes it more difficult to debug


big_bass
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 03 Apr 2009, 03:21    Post subject:  

FF3 runs just as fast as FirePup on Debian/Dpup, very responsive. Thats the real reason why I'm working with Dpup now, because Firefox is the most sought after browser, and not to be able to offer the latest version is somewhat DSL job,lol not puppy Smile But I still like Firepup the best Smile
But at least I'll be able to make a new version for Dpup Smile Thats the best part where as with series 4 I was really stick with 1.5 or 2 series which are basically the same minus spellcheck, but I managed to get that working in 1.5 Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1513

PostPosted: Fri 03 Apr 2009, 10:21    Post subject:  

This probably needs a new thread, but has anyone tried using Flock in Puppy? It's based on Firefox but with a few extras built in to make blogging, sharing photos online etc. easier. Looks quite attractive too IMO.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 03 Apr 2009, 10:40    Post subject:  

Colonel Panic wrote:
This probably needs a new thread, but has anyone tried using Flock in Puppy? It's based on Firefox but with a few extras built in to make blogging, sharing photos online etc. easier. Looks quite attractive too IMO.


Yes I've tried flock in the past, same with icecat, iceweasel. etc Its just that puppy is missing something or there's a bug in a library it was also a gradual thing, The first firepup I built was on 1.0 and then the regular based on 1.5, when series 2.0 came out everybody noticed a bit of a slowdown, then with each FF release it was slower and slower and slower, Finally series 3 was released and even when I compiled on puppy a couple of times, even tried the latest glib,gtk, cario, pango, and then compiled it, and it still was the slowest version yet. Thats when I gave up on compiling it, until dpup happened and I tried Iceweasel which is FF 3.0.6 that ran perfect. I then tried it on puppy, it said not missing anything and I also had that update from this thread installed, and once again it was a crap version, Its just series 4.0 just doesn't work right with FF3.
ttuuxxx
PS now back to Dpup Smile

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
drummachine

Joined: 13 Feb 2009
Posts: 15

PostPosted: Fri 03 Apr 2009, 11:38    Post subject:  

Hey ttuuxxx,

Quote:
still runs slow with FF 3.0.6 with 4,2 using your latest package. Sorry
try this page and move your scrollbars up and down
https://addons.mozilla.org/en-US/firefox
works perfect in dpup.


Did some tests with Firefox 3:

PIII Notebook with 4MB Trident Card - xorg-driver=trident:
Puppy 4.12 with gtk core Update --> sloooow but stable
dpup: slooooow but stable

Core2Duo Notebook with NV GeForce 8400M - xorg-driver=NV:
Puppy 4.12 with gtk core Update --> stable but slooow (simply UNUSABLE)
dpup: stable and much more faster

Core2Duo Notebook with NV GeForce 8400M - xorg-driver=NVidia (proprietary driver):
Puppy 4.12 with gtk core Update --> stable and fast as lightning !!!

Seems that the slowness is not a gtk-problem.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 03 Apr 2009, 12:55    Post subject:  

drummachine wrote:
Hey ttuuxxx,

Quote:
still runs slow with FF 3.0.6 with 4,2 using your latest package. Sorry
try this page and move your scrollbars up and down
https://addons.mozilla.org/en-US/firefox
works perfect in dpup.


Did some tests with Firefox 3:

PIII Notebook with 4MB Trident Card - xorg-driver=trident:
Puppy 4.12 with gtk core Update --> sloooow but stable
dpup: slooooow but stable

Core2Duo Notebook with NV GeForce 8400M - xorg-driver=NV:
Puppy 4.12 with gtk core Update --> stable but slooow (simply UNUSABLE)
dpup: stable and much more faster

Core2Duo Notebook with NV GeForce 8400M - xorg-driver=NVidia (proprietary driver):
Puppy 4.12 with gtk core Update --> stable and fast as lightning !!!

Seems that the slowness is not a gtk-problem.


Tronkel also mention that it could be xorg, but it does make sense to a point, dpup is fast out of the box and its only 101MB, I don't think its using a Nvidia driver either. Now thats what we need to figure out:) hows it doing it?
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sat 04 Apr 2009, 21:09    Post subject:  

ttuuxxx I am using 3.08

firefox and its looking good


no crashes yet and fast
mozilla-firefox-3.0.8-i686-1.tgz

I dont even care to package it Laughing
big_bass

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 05 Apr 2009, 01:54    Post subject:  

big_bass wrote:
ttuuxxx I am using 3.08

firefox and its looking good


no crashes yet and fast
mozilla-firefox-3.0.8-i686-1.tgz

I dont even care to package it Laughing
big_bass


Isn't that with your own custom Slackware 12.1 base your using?
You lucky Guy you, lol maybe a link to the iso??? Wink
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
lightheaded1

Joined: 07 Jun 2008
Posts: 14

PostPosted: Sun 05 Apr 2009, 08:30    Post subject:  

Quote:
don't upgrade to firefox 3.00 when it asks for an update
hope this is relevent
I installed the new puppy 4.2 (I like ++good) and was usuing seamonkey
yesterday I notisted that it crashed for no reason so i loaded firepup 4.3 which has always proved more stable than any firefox version I have tried(good stuff
tuxx ,kudos) didn't use it till this morning when I clicked the browse button and it became the default browser without me even selecting it as such(pushy eh?)
The very first thing it displayed was the upgrade page so rather than take their word that it was the best i randomly checked the forum to see if anyone had had isues and I see big bass comment .Thank you . note I am not a geek i barely understand geekspeake but I like to surf .and since I am an old (pre Thatcher) ex pat living in Canada when I see anthing free well who can resist
I have crashed quite a few opperatind syistems by putting too many free programs into the mix so now I am wary.It seems I am becoming more expert than I ever wanted to be and all because I like porn.Funny eh???

thanks again to all the puppy community you have saved me from a life behind closed Gates
Back to top
View user's profile Send private message 
hursh

Joined: 06 Jan 2009
Posts: 3

PostPosted: Mon 06 Apr 2009, 06:22    Post subject:  

my firefox 3.0.8 on puppy 4.2 always crashes whenever I close any of the open tabs. So I dont close any tabs !!!!

it used to crash in puppy 4.1.2 as well but not so frequently. mostly on my company's specialised portal.
Back to top
View user's profile Send private message 
AndrewG

Joined: 02 Feb 2010
Posts: 36

PostPosted: Tue 22 Jun 2010, 03:41    Post subject:  

Hi. Does anyone have these files from drummachine's post?
I need them to run Transmission 2.0 on Puppy 4.1
thank's

drummachine wrote:
@ tazoc

tried my.yahoo.com and had also crashes.
Had to update complete gtk-core to stop it crashing.
You can try this:

For Puppy 4.1x:
gtk-core-update

For Puppy 4.2 (without libjasper dependency):
gtk-core-update-p42

ONLY FOR TESTING PURPOSES!!

(contains glib-2.18.4, pango-1.22.4, pixman-0.14.0, cairo-1.8.6, gtk+-2.14.7)

UPDATE 26. March 2009: smaller pet (dropped the large unnecessary locales folder)

UPDATE 02. April 2009: updated libpangocairo was missing

And the development part (for the sake of completeness):
gtk-core-update-dev

I use this update on a full install since 2 weeks without any problems!!!!
Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 22 Jun 2010, 12:59    Post subject:  

Here's most of the original pet. Let me know if you need the locales. I couldn't find libpangocairo for this.

http://lhpup.org/pet/4/Gtk-core-update.pet

I didn't know that Transmission 2.0 was out, will have to add it to Lighthouse Pup.

-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 4 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0904s ][ Queries: 12 (0.0067s) ][ GZIP on ]