Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 22:18
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Dialup
How to install HUAWEI USB CDC MODEM (C300)?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
rajesh009

Joined: 05 Mar 2009
Posts: 4

PostPosted: Thu 05 Mar 2009, 03:23    Post subject:  How to install HUAWEI USB CDC MODEM (C300)?  

Hello everyone,

I am a new user of Puppy Linux. I downloaded Puppy Linux 4.1.2 and loaded yesterday on my PC from live cd.Everything is so far so good.

I have a Huawei CDMA Mobile C5320 which supports three modes:

1. USB Disk
2. Data
3. PC Sync

Windows XP detects it as HUAWEI USB CDC C300 modem in data mode and dial to the internet. Problem is that I cannot install my HUAWEI USB CDC MODEM (C300) on Puppy Linux. I tried the Connect panel on the Puppy Linux desktop, through dial-up,lan and wireless options. But my modem remains undetected. I put my mobile in data mode many times and restart PC many times but Puppy Linux cannot detect it. I clicked the Probe button many times, but Puppy Linux cannot detect it. As a result I cannot connect to the internet.

How will I set up the network connection with the aforesaid modem? Is there any other alternative way out? I am hopeful with Puppy Linux and I want to switch with it from Windows XP I am currently having. One thing to mention that I am novice in coding in Linux.

I would be grateful if you dedicated Puppy Linux users help me out for solving this problem with simple easy steps. I am yet to understand the confusing coding used to deliver commands in Linux overall.Then again I will try if coding has to be done. Please help me.

Thank You
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1536
Location: Maine, USA

PostPosted: Mon 03 Aug 2009, 11:46    Post subject:  

Sorry to have overlooked your posting. If you are still interested, please install a dotpet from the 3G-wireless-modem project thread here: http://www.murga-linux.com/puppy/viewtopic.php?p=266979#266979
You probably need only the file: 3G_pupdial-wireless-11.pet.

After downloading and clicking on the file in the file manager, reboot with the modem plugged in and it should be detected and shown in the connect wizard as ttyACM0. Then use only the "Internet by analog modem" option, which takes you to pupdial for connection.

That's how it is expected to work, but I see there will be a problem: That device is not associated with a driver in Puppy, so more work is needed for it. You could try forcing loading of the cdc_acm module in the BootManager (and rebooting). If you are lucky, that is all that is needed. But the fact that it is represented by three devices, suggests that its "mode" must be switched to activate the modem. Currently, the mode-switch utility does not recognize that device, but that can be remedied with a tool running under Windows. Working this out may not seem simple, but it would probably help many people with that modem, if we were to pursue it.
Richard
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0421s ][ Queries: 11 (0.0036s) ][ GZIP on ]