Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 18 Jan 2020, 15:52
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Opera 11.11 pet +portable +WebM +locales +flash-adblock
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 17 [245 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Author Message
technosaurus


Joined: 18 May 2008
Posts: 4872
Location: Blue Springs, MO

PostPosted: Tue 19 Oct 2010, 00:52    Post subject:  

the wrapper script for opera looks for java in many places, maybe your java install is in an unexpected location... try matching those up if you can (add the location to the script or use the opera command line switch to specify the java location)
_________________
Check out my github repositories. I may eventually get around to updating my blogspot.
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Tue 19 Oct 2010, 01:09    Post subject: Please remove, sent in error  

--
Last edited by Henry on Fri 22 Oct 2010, 12:18; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Tue 19 Oct 2010, 10:07    Post subject:  

Type the next or copy-paste it in the opera adress bar:
opera:config#UserPrefs|PluginPath

And add the java path, usually on puppy is located at:
/opt/jre******/lib/i386/

Of course you have to know were java is installed. I've added the path in the customized version but it lokates only the 6.21, so for every java version update must correct it.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Tue 19 Oct 2010, 12:43    Post subject:  

Michalis wrote:
Type the next or copy-paste it in the opera adress bar:
opera:config#UserPrefs|PluginPath

And add the java path, usually on puppy is located at:
/opt/jre******/lib/i386/

Of course you have to know were java is installed. I've added the path in the customized version but it lokates only the 6.21, so for every java version update must correct it.


Thanks very much, Michalis,

I'm still wrestling with it. Based on your example I should be changing to something like /usr/lib/jre1.6.0_18/plugin/i386/ but I cannot seem to get it in. Some kind of editing bug? Looks like I will have to do without java for a while . . .
Back to top
View user's profile Send private message Visit poster's website 
xman


Joined: 24 Sep 2009
Posts: 144

PostPosted: Tue 19 Oct 2010, 13:18    Post subject:  

I have relative link from /usr/java/jre1.6.0_22/lib/i386/libnpjp2.so to /usr/lib/mozilla/plugins, and Java webpage is detecting Java in Opera 10.63, if plugins are enabled.

New Java 6u22 by Nikukyu: http://www.murga-linux.com/puppy/viewtopic.php?t=45244&start=30.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Tue 19 Oct 2010, 15:16    Post subject: Opera 10.63 java now works for me (SOLVED)
Subject description: THANK YOU, XMAN, Also see EDIT
 

xman wrote:
I have relative link from /usr/java/jre1.6.0_22/lib/i386/libnpjp2.so to /usr/lib/mozilla/plugins, and Java webpage is detecting Java in Opera 10.63, if plugins are enabled.

New Java 6u22 by Nikukyu: http://www.murga-linux.com/puppy/viewtopic.php?t=45244&start=30.


Thanks. The symlink fixed it.

I used this:

ln -s /usr/lib/jre1.6.0_18/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins

EDIT: Another solution has since been pointed out to me as on:

http://puppylinux.org/wikka/JavaRuntimeEnvironment

that
]jre-1.6.0.22.pet has these advantages:
* updated version
*installs in /mnthome
*automatically applies symlinks

This works too.
Back to top
View user's profile Send private message Visit poster's website 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Thu 16 Dec 2010, 13:47    Post subject: Opera updated to version 11.00  

Opera updated to version 11.00

Opera 11.00 for UNIX changelog
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Thu 16 Dec 2010, 14:48    Post subject: Opera 11 final
Subject description: Linux version?
 

Quite anxious to download the Linux version. I looked far and wide but could only find the windows download.

Where is it? Thanks.
Back to top
View user's profile Send private message Visit poster's website 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Thu 16 Dec 2010, 15:39    Post subject: Re: Opera 11 final
Subject description: Linux version?
 

Henry wrote:
Quite anxious to download the Linux version. I looked far and wide but could only find the windows download.

Where is it? Thanks.


Look in the first post
Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 461
Location: Somewhere in Blighty.

PostPosted: Sun 19 Dec 2010, 21:41    Post subject: Opera 11 install problem  

Hi. I've tried to install this version of Opera 11 and so far have failed to get a working installation. The pet says it installs OK, but no menu entries are created and when I set it as Default Browser nothing happens. In addition, when I try to launch it via the Console, it gives the following message:-

bash: opera: command not found

Puppy versions it's failed to work on are: Luci-246 (LiveCD), Lupu-511 (LiveCD) and Lupu-515 (LiveCD) and the machines are listed in my signature below.

Could it be that the pet file is corrupt or missing some files?

_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Core i5-4590, 8GB RAM, Radeon R9 270X. Slacko 5.7.0
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Sun 19 Dec 2010, 22:25    Post subject:  

Jades wrote:
Quote:
Hi. I've tried to install this version of Opera 11 and so far have failed to get a working installation. The pet says it installs OK, but no menu entries are created and when I set it as Default Browser nothing happens. In addition, when I try to launch it via the Console, it gives the following message:-

bash: opera: command not found

Puppy versions it's failed to work on are: Luci-246 (LiveCD), Lupu-511 (LiveCD) and Lupu-515 (LiveCD) and the machines are listed in my signature below.

Could it be that the pet file is corrupt or missing some files?


I've been installing Opera to /mnt/home/opera/program/opera for the past several versions, which desirably keeps it out of the pupsave file. This last version seems a little different in that in that it wants to go to /mnt/home/opera/opera, which is fine but the default browser definition, the .desktop file, and any desktop or panel shortcuts have to agree with this. It was easy to make the adjustments in my QirkyNop 1.2.

You used the pet and I used the the "portable," but it probably amounts to the same situation. I too got "command not found" until I made the change.
Back to top
View user's profile Send private message Visit poster's website 
ruario

Joined: 20 Dec 2010
Posts: 1

PostPosted: Mon 20 Dec 2010, 10:33    Post subject: Opera installation and repackaging  

I suspect some of you may find one or both of the following useful:

Selecting a Linux or FreeBSD package and installing it

Repackaging Opera for Linux (or FreeBSD and variants)

P.S. Thanks to all of you for using Opera! Very Happy
Back to top
View user's profile Send private message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 407

PostPosted: Mon 20 Dec 2010, 15:46    Post subject: Re: Opera 11 install problem  

Jades wrote:
Hi. I've tried to install this version of Opera 11 and so far have failed to get a working installation. The pet says it installs OK, but no menu entries are created and when I set it as Default Browser nothing happens. In addition, when I try to launch it via the Console, it gives the following message:-

bash: opera: command not found

Puppy versions it's failed to work on are: Luci-246 (LiveCD), Lupu-511 (LiveCD) and Lupu-515 (LiveCD) and the machines are listed in my signature below.

Could it be that the pet file is corrupt or missing some files?

It seemed that way to me (one or two missing files) when I took apart the dot-pet, but I at least got a menu entry, just one that didn't work. I tried tweaking it and it seems to work nicely now.
I went ahead and uploaded it:
EDIT: Michalis seems to have fixed the package in the first post, so I'm removing mine now that it's redundant.

Last edited by TheAsterisk! on Tue 21 Dec 2010, 01:19; edited 1 time in total
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Mon 20 Dec 2010, 16:15    Post subject: Opera pet reuploaded  

In the previous pet I neglect to include the bin folder that's why it wasn't working.

Anyway I've updated the Opera.pet in the first post. This mistake doesn't have any effect to the rest packages.
Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 461
Location: Somewhere in Blighty.

PostPosted: Mon 20 Dec 2010, 18:18    Post subject: Re: Opera pet reuploaded  

Michalis wrote:
In the previous pet I neglect to include the bin folder that's why it wasn't working.

Anyway I've updated the Opera.pet in the first post. This mistake doesn't have any effect to the rest packages.


Thanks, I've successfully installed it on both machines and it seems to be working properly.

_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Core i5-4590, 8GB RAM, Radeon R9 270X. Slacko 5.7.0
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 14 of 17 [245 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0732s ][ Queries: 12 (0.0231s) ][ GZIP on ]