Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 11:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Opera 11.11 pet +portable +WebM +locales +flash-adblock
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 16 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17 Next
Author Message
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 10 Feb 2011, 03:27    Post_subject:  

have been getting a lot of opera freezing in 11.01-1190. seems to be an accumulation of something that is causing it, because when i re-extract the bz2 and overwrite my existing opera it doesnt freeze again for quite a while. profile stays intact and so still in the same place as before the extraction.
anyone else getting freezing? it may also be from my frequent flat battery crashes.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Thu 10 Feb 2011, 08:29    Post_subject:  

am using the portable version on lucid 5.2 all working ok here, no crashes.
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Thu 10 Feb 2011, 14:34    Post_subject:  

Using my .sfs in Puppy Studio 3.3, I have seen only one freeze, and that was when I tried to load
/usr/share/opera/styles/webfeeds.html
into Opera itself.

I do have

Ctrl-F12 -> Advanced -> History -> Disk cache Empty on exit

checked.
Back to top
View user's profile Send_private_message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Thu 10 Feb 2011, 15:50    Post_subject:  

Opera 11.00 was freezing frequently to me but with 11.01 I haven't got any crash so far. I'm using quirky 1.40.

Usually the solution to these kind of problems is to delete the profile folder and start all over again. Do you use any extensions? Have you checked whether any plugin is using to much your cpu and/or memory?
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Fri 11 Feb 2011, 12:27    Post_subject:  

Michalis: my install is straight out of the bz2 with no additions on my part. flashplayer is there. as for chewing memory and cpu, when viewed with lxtask in puppeee4.4-08, one program called operaplugincleaner seemed like a likely candidate as it appeared often during the freeing near the top of the cpu and memory % list. i would sometimes kill operaplugincleaner and not a great deal would happen immediately, the freeze would continue past the kill.

other things that seemed to be related sometimes was the stuff stored in /root/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/ and
/root/.macromedia/Flash_Player/#SharedObjects/XXXXXXX/

one particular website would nearly always be there when freezing happened.
i would clean these folders out and freezing would after a while improve for a while.

decided to see if it was opera specific, but
have now frozen firefox and similarly the particulr website from above was there in flashplayer sub-folder too. the firefox freeze was not as prolonged as the opera freezes though.
in the past installs i did a new profie each time but still had freezes,

Sit Heel Speak:Ctrl-F12 -> Advanced -> History -> Disk cache Empty on exit
now checked.but i think it is something else as profile doesnt affect it.

strange .mht files that were executables also were begining to appear after i saved a file. changing the properties by unchecking the execute boxes didnt change the permissions. reminded me of virus that appear in windows. just deleted them. peraps 6 total now. only recently and only in this current opera.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 11 Feb 2011, 13:15    Post_subject:  

aarf wrote:
...Sit Heel Speak:Ctrl-F12 -> Advanced -> History -> Disk cache Empty on exit now checked.but i think it is something else as profile doesnt affect it.

When you run the installer, is it running to completion? When I tried the installer straight from the .bz it failed, giving an error message about missing two locale files. Tried it twice from two sources and it failed the same way both times. That is the reason why I chose to build my 11.01-1190 .sfs and .pet packages from the Ubuntu .deb, not from the installer .bz.
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Fri 11 Feb 2011, 14:16    Post_subject:  

Yes sometimes there are errors from extracting the bz2. Sometimes it takes 10 minutes to overwrite or extract. If it fails once then next time it may not fail. there doesnt seem to be a pattern. Mostly i dont look at the errors just go to opera and see if it starts. Mostly it does start some times it doesnt. My internal SD cardreader is known not to be perfect. fsck is often not clean.
_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 11 Feb 2011, 17:52    Post_subject:  

aarf wrote:
...sometimes there are errors from extracting the bz2...my internal SD cardreader is known not to be perfect...
Well, I can't help you with the hardware problem(s), because I don't own an eeePC, so I wouldn't know where to begin.

Are you running Puppeee (thread), the puplet specifically designed for the eeePC?

Try either my or Michalis's Opera 11.01 .pet instead of the .bz. But first shift into / in rox, open an rxvt window by pressing the left-apostrophe (`) key, and issue
Code:
find | grep opera | grep -v initrd
and use the output as a guide, in order to delete all traces of the pre-existing (broken) opera, especially the profile subdirectory
/root/.opera.

If the .pet installs faster than the .bz installer does, then the .bz is probably not installing correctly due to its broken (incomplete) state. This is not surprising, since the vast majority of users are installing Opera from one of the major distro's and so do not use the .bz installer--so, fixing it will not be a high-priority item on the Opera developers' agenda. I found what appears to be an error in the official .deb, too, of Opera, see item 2 in the first message here.

In earlier versions of Opera's .bz installer, all of which did not give errors here, the .bz installer took just a few seconds to install.

HTH, SHS
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Mon 14 Feb 2011, 08:00    Post_subject:  

SHS: i have know about my hardware problem for sometime but they are not significant enough for me to take decisive or even aversion remedial action. i point things out mainly for the benefit or information of others and developers.
yes, am using latest puppeees.
nothing goes into /root/.opera with my install everything opera stays on its own separate partition.
am fairly certain that it is the flashplayer related .sol file located as above from http://www.nationmultimedia.com/home/index.php that is causing the freezing. i am also suspecting that the .tar and .bz2 output files may also be being corrupted by the extractor in conjunction with my faulty sdcard-reader. so will be doing fsck before an after extractions when i remember.
thanks for taking an extended look at this issue.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 31 Mar 2011, 01:07    Post_subject:  

have been using the latest opera snapshots as they come from http://my.opera.com/desktopteam/blog/
just using the code on the downloand page to unzip the bz2
Code:
# tar xf opera-11.10-2067.i386.linux.tar.bz2
and clicking the extracted opera.
also "deleting cache on exit" as suggested by SHS.
no problems at all, no freezing. no crashing.no corrupted files.
haven't been brave enough to go to www.nationmultimedia.com though since it turned my sdcard into a rubble folder.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Mon 04 Apr 2011, 04:21    Post_subject:  

yawn same as all the others. works fine FOR A WHILE then the freezing and corrupt files start and just gets worse until you do a new extraction discarding everything but keep only the profile folder ,.
_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
Artie


Joined: 04 Oct 2005
Posts: 446
Location: Norway

PostPosted: Tue 12 Apr 2011, 09:25    Post_subject:  

Hi Michalis could you make a portable customized version of 11.10 please?

Artie
Back to top
View user's profile Send_private_message Visit_website YIM MSNM 
ICQ 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sat 16 Apr 2011, 16:54    Post_subject: Updating Opera to 11.10
Sub_title: How I did it.
 

I have used Opera since the first one appeared. Nowadays I keep it installed in /mnt/sda2/opera (ext2).
(But it need not be ext2. You can just as well put it in /mnt/home/opera(fat32) - with corresponding changes below.)

Update procedure:
Download opera-11.10-2092.i386.linux.tar.bz2 from the Opera site and click to unzip its folder wherever convenient.
Copy /lib and /share over the old, but keep the existing /profile and /blank.htm (your custom home page if any) and /opera.
Delete /opera-widget-manager(if you don't want it) and delete /install (you don't need it).

If you haven't already done this,
Open /usr/bin/defaultbrowser in the editor and change exec to exec /mnt/sda2/opera/opera "$@"

and this,
Open /usr/share/applications/opera in the editor and change exec to Exec=defaultbrowser.

If you don't use widgets the menu item can be removed. (I dislike them):
Close Opera and open standard_menu.ini in the editor. Find and delete the following entry:
Submenu, M_WIDGET_MENU, Browser Widgets Menu (or similar).

Everything worked beautifully - I had a new faster browser with my old configuration but better. The bookmarks no longer have those trailing characters in parentheses. Just that would have made my day Smile
Back to top
View user's profile Send_private_message Visit_website 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Wed 01 Jun 2011, 16:02    Post_subject: Opera updated to version 11.11  

Opera updated to version 11.11
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Wed 01 Jun 2011, 16:17    Post_subject: Re: Opera updated to version 11.11  

Michalis wrote:
Opera updated to version 11.11

Thanks, Michalis,

I'm very pleased with it. Have been using since it came out on May 18. Just copied the changed parts over what I had per my last post.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 16 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0874s ][ Queries: 12 (0.0086s) ][ GZIP on ]