Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 13:38
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
CUPS won't accept HPLJ 1020
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
eowens22

Joined: 16 Mar 2009
Posts: 4

PostPosted: Mon 16 Mar 2009, 16:37    Post subject:  CUPS won't accept HPLJ 1020  

Hello, newbie here.

I am running Puppy 4.1.2 from an 8GB USB stick, on an Eee PC 1000HA, 1.6 GHz Atom processor, 1 GB RAM.

I need some help getting a printer up and going.

The printer is an HP Laserjet 1020, and it is not included as an option in the HP section of the CUPS printer selection window.

I am aware that the HPLJ 1020 is in the foo2zjs group, and have downloaded and executed foo2zjs-0.75-i686.pet, and have verefied that HPLJ_1020.ppd is in /usr/share/cups/model (there is also a symlink in there, "foomatic.ppds" [how can you tell where a symlink links to?]).

In the default CUPS v 1.1.23, there is no option or dialogue window where you can type in or browse to and select a .ppd file, and of course there is no option to select something like "HP Laserjet/foomatic + Gutenprint 5.0" in the main printer selection window, as there is for many other printers. Is there some .config file somewhere, where I could place the HPLJ_1020.ppd file, to make this thing work?

In view of the fact that CUPS v 1.1.23 is missing a part, I looked in PET package manager, hoping to find another version of CUPS, and found CUPS v 1.3.3, which I added to Puppy 4.1.2.

CUPS v 1.3.3 on the printer-selection page, DOES have the option to browse to and select a .ppd file. However when I browse to /usr/share/cups/model and select "HPLJ_1020.ppd", then click on "Add Printer", I am taken back to the CUPS home page. I am not informed that I have successfully added a printer, I am not taken to the username/password diaglogue. And on re-booting, HPLJ_1020 is not there.

I did it again, and the same thing happened (I am not led thru the entire process and HPLJ_1020 had not been added as a printer).

My HPLJ is attached by USB to a windows XP desktop as a share via SAMBA. I know that this part of the system is working because I have added an Epson printer (also attached to the XP desktop via USB and reached thru SAMBA) to Puppy, and it prints out without problem (this printer was listed in the main printer dialogue window).

I seem to be going around in circles.

Can anyone shed any light on this?

Thank you.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9362
Location: Stratford, Ontario

PostPosted: Mon 16 Mar 2009, 19:46    Post subject:  

I tried the i686 package you mention above but it did not contain any PPD files. I then found
this one which did the job. It actually makes two sets of PPD files - in /usr/share/cups/model and in /usr/share/ppd. Your printer is now listed (twice) in CUPS as Foomatic/foo2zjs.

I don't own this printer, so I can't test it, but I don't think that there is anything missing from the version of CUPS in 4.1.2.

FYI: If you manually add a PPD file to /usr/share/cups/model, you must restart the CUPS daemon in order to make it visible. You can do this by running the Puppy CUPS Printer Wizard or from the console with:
Code:
/etc/init.d/cups restart


Depending on your version of CUPS, you may also need to do the following:

Locate the file /usr/bin/foomatic-rip
If it has a PERL icon, open it in a text editor
Change the top line to: #!/usr/bin/perl -U

Then repeat the procedure for the file /usr/bin/foomatic-gswrapper.

Last edited by rcrsn51 on Wed 01 Apr 2009, 08:15; edited 4 times in total
Back to top
View user's profile Send private message 
eowens22

Joined: 16 Mar 2009
Posts: 4

PostPosted: Tue 17 Mar 2009, 14:44    Post subject:  

rcrsn51 - thank you for a quick reply!

O.K. I started over. I removed the foo2zjs-0.75-i686.pet. I removed the CUPS v1.3.3, and reverted to the CUPS v1.1.23 that is native to Puppy 4.1.2. I removed the printers listed in /usr/share/cups/model and made sure there were none in /usr/share/ppd.

I downloaded and ran foo2zjs-i486.pet. ls /usr/share/cups/model/ reveals
Brother-HL-2040-hl1250.ppd epson9.ppd okidat24.ppd stcolor.ppd deskjet2.ppd foomatic-ppds okidata9.ppd tphoto2.ppd
deskjet.ppd ghostpdf.ppd pxlcolor.ppd stphoto.ppd dymo.ppd gutenprint pxlmono.ppd zebra.ppd epson24.ppd laserjet.ppd stcolor2.ppd

without my HPLJ_1020 being listed. The entry "foomatic-ppds" is very light blue in color (is it a symlink?)...if it is a directory there is nothing in it.

There is a /usr/share/ppd directory, but it is empty.

O.K., now to CUPS v1.1.23. Click on Administration/Add Printer.

On "Add New Printer/Name:", entered "HPLJ_1020". Left Location: and Description: blank. Click Continue.

On page "Device for HPLJ_1020", click on "Windows Printer via SAMBA" and Continue.

On "Device URI for HPLJ_1020" enter "smb://MSHOME/ELO-STUDY/Printer3" and Continue. (note-I have added an Epson share here with this URI, no problem - obviously a different printer #).

On the "Model/Driver for HPLJ_1020" page is where the problem starts. There is a single dialogue window, with "Apollo,Apple,Brother, etc" printer brands listed, and when one clicks on "HP" and Continue, the list changes to specific Hewlett-Packard printers, but HPLJ_1020 is not in the list.

And so "Add Printer" (for me and the HPLJ_1020) effectively and unsuccessfully ends there (as noted in earlier post an Epson R200 was added without problem).

As noted in my first post, using CUPS v1.3.3, at least the "Model/Driver for HPLJ_1020" page has a second dialogue box for entering a .ppd file, with a Browse button, so that you can map out a path to the .ppd file. But after entering the .ppd file, you hit a brick wall and the printer is not added.

What am I doing wrong?

Thank you.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9362
Location: Stratford, Ontario

PostPosted: Tue 17 Mar 2009, 15:55    Post subject:  

I just set up a new frugal install of 4.1.2 with a pristine pup_save file. I downloaded and installed foo2zjs-i486.pet.

I then checked /usr/share/ppd. It contained the subfolder foo2zjs which was fully populated with ppd files (compressed as .gz).

I then checked /usr/share/cups/model which contained duplicates of all the foo2zjs PPD's. When I clicked on the foomatic-ppds symlink, it led back to /usr/share/ppd/foo2zjs where all the PPD's showed again.

I then ran the Puppy Printer Wizard. Under the HP group, your printer was listed twice, as it should be. In other words, everything worked correctly for me.

The package also installs some files in /usr/bin named foo2xxx. Do you have those?

I notice from your first post that you are working off a flash drive. The layered filesystem is different on a flash drive. I wonder if the Puppy package manager is not installing this package correctly.

[Edit] I just tried this on a flash drive and the package installed correctly there too. My only other suggestion is to delete your current pup_save and start fresh.
Back to top
View user's profile Send private message 
eowens22

Joined: 16 Mar 2009
Posts: 4

PostPosted: Tue 17 Mar 2009, 19:12    Post subject:  

rcrsn51 - I just deleted my pup-save and started over, re-installed foo2zjs-i486.pet.

My /usr/bin/ has 7 foo-related files.

My /usr/share/cups/model/ still does not have my specific printer.

My /usr/share/ still does not have a /ppd sub-directory populated with .ppd files.

When I click on the symlink foomatic-ppds in /usr/share/cups/model I get the error "File doesn't exist, or I can't access it".

And going thru Cups "Add Printer" dialogue, my printer still doesnt appear.

I'm wondering if computers might not eventually make me lose my mind!
Back to top
View user's profile Send private message 
NickelZ

Joined: 18 Mar 2009
Posts: 5
Location: Christchurch, New Zealand

PostPosted: Wed 18 Mar 2009, 22:56    Post subject: CUPS won't accept HPLJ 1020-on my Eee  

Hi,
I have an Eee 901 PC running puppy 4.12. On boot up it loads the OS in to RAM off a 2.6Gig ext3 partition on the largest of the internal USB drives in my Eee. Puppy is running really nicely like this andi really enjoy the operating system. I read your posts with interest as the one and only printer in my house is a HP1020. (I have managed to get it going by downloading the foo2zjs on the lounge computer that runs SUSE I might add).
I have today installed the foo2zjs-i486.pet /usr/share/cups/model/
and /usr/share/foo2zjs/ both have the HP-LaserJet_1020.ppd.gz with a file size of 4103. As do the same directorys trees on initrd/pup_rw which I think is is the saved files on the flash drives for when I shut down. Anyway my point is I can not understand either why eowens22 doesn't appear to have ppd files on his system.
I can not actually get my printer to print from this Eee PC yet. I can run cups setup and install everything reportadly correctly but get "/usr/lib/cups/filter/foomatic-rip failed" error. Hmm ... But checking the log I see this: E [19/Mar/2009:13:24:56 +1300] [cups-driverd] Unable to open PPD directory "/usr/local/share/ppd": No such file or directory
E [19/Mar/2009:13:24:56 +1300] [cups-driverd] Unable to open PPD directory "/opt/share/ppd": No such file or directory
Hmm I wonder if I should move/copy the PPD folder to where cups is looking?
Back to top
View user's profile Send private message 
eowens22

Joined: 16 Mar 2009
Posts: 4

PostPosted: Thu 19 Mar 2009, 15:48    Post subject:  

rcrscn51 - The saga continues. SUCCESS at last.

I chose a different USB drive, a 2 GB PNY that I had used for
other things, and prepped it with "dd if=/dev/zero of=/dev/sdx bs=4096", partitioned it with GParted, gave it an ext2 FS and made
it bootable.

Installed Puppy 4.1.2 on the fresh USB stick with the Live CD installation disk.

On the fresh install, there is NO ppd sub-directory in /usr/share.

In /usr/share/cups/model there is a gutenprint directory, there are 17 .ppd files (none of them HPLJ_1020), and a symlink to a nonexistent (!!!) /usr/share/ppd.

In /usr/bin there is foomatic-gswrapper and foomatic-rap.

O.K., I download a fresh foo2zjs-i486.pet and run it. Reboot Puppy.

Things are starting to look better already!

/usr/bin/ had 12 new foo files in it.

/usr/share now has a /ppd with foo2zjs in it.

/usr/share/cups/menu/ has an HP-Laserjet_1020.ppd.gz

CUPS v1.1.23 has the HPLJ_1020 option X2 in the dialogue window on the "Model/Driver" page, and CUPS successfully adds the printer, and a test page prints out perfectly on the SAMBA share!

I think I probably had a defective foo2zjs-i486.pet.

Thanks for your help!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9362
Location: Stratford, Ontario

PostPosted: Thu 19 Mar 2009, 16:01    Post subject:  

You're welcome.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0706s ][ Queries: 11 (0.0034s) ][ GZIP on ]