Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 14:47
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Common UNIX Printing System (CUPS) v1.3.11
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [65 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Tue 29 Dec 2009, 00:11    Post subject:  

Will any version of Cups work on SPUP 451 . I have tried a few versions and cannot get to the manager on Localhost:631, Tried the startups mentioned on Slackware sites still no go .I like the puppy version but it is no use if you cannot print.
Regards Dennis
I know just enough about this stuff to know how much I dont know.!!!!!!
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 29 Dec 2009, 00:48    Post subject:  

dalderton wrote:
Will any version of Cups work on SPUP 451 . I have tried a few versions and cannot get to the manager on Localhost:631, Tried the startups mentioned on Slackware sites still no go .I like the puppy version but it is no use if you cannot print.
Regards Dennis
I know just enough about this stuff to know how much I dont know.!!!!!!

cups is really just a bloated gui, the real workhorse is gutenprint, what you probably need is a updated version of guten print or some printer driver compiled for your pc, in some cases. You would probably be better to ask in the Spup forum thread just in case the developer overlooks this thread.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Tue 29 Dec 2009, 03:38    Post subject:  

Tuuxxx
Thanks for the reply, I posted on the Spup thread a couple of days ago but I think that "Plaguedogs has moved on .Also it does seem that Cups is a bit of a specialist game.I have had a look at Patriots Unix epistle and tried his modular version but the same problem occurs .Looking at the Slackware stuff it seems to have its own problems and maybe the combination of Puppy and Slackware and Cups is not so easy to operate.
Its all interesting stuff. I wish I understood it better.
Regards Dennis
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 29 Dec 2009, 06:00    Post subject:  

dalderton wrote:
Tuuxxx
Thanks for the reply, I posted on the Spup thread a couple of days ago but I think that "Plaguedogs has moved on .Also it does seem that Cups is a bit of a specialist game.I have had a look at Patriots Unix epistle and tried his modular version but the same problem occurs .Looking at the Slackware stuff it seems to have its own problems and maybe the combination of Puppy and Slackware and Cups is not so easy to operate.
Its all interesting stuff. I wish I understood it better.
Regards Dennis


whats the make and model of your printer and did your printer work on other puppies like 2.14X which has cups from 5 series I think I went with.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
mikeb


Joined: 23 Nov 2006
Posts: 8253

PostPosted: Tue 29 Dec 2009, 06:44    Post subject:  

The older version might need localhost:631/admin or even your (machine ip):631/admin...version 1.1.13 that is....is cupsd running if you look at htop/top...not all puppies start cups automatically....
/etc/rc.d/rc.cups start
or
/etc/init.d/cups start

With the newer cups (1.3 like from this thread ) usually the interface comes up fine but it is more fussy when it comes to permissions.

mike
Back to top
View user's profile Send private message 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Tue 29 Dec 2009, 18:48    Post subject:  

Thanks again for the replies.My printer is HP5550 usb printer and I have had no problems with using it on any Puppy version in the last year or two until I tried Spup . Even Gutenprint drivers are working at a respectable speed these days.I have tried the various cups start codes from these threads and also Slackware printing info without success Interestingly the process does not get to the normal Purple Box that when clicked leads to the Cups screen at http://localhost:631/ Very strange business. Also for some reason the ePDF viewer does not work on Spup. Still a work in progress I think. Dpup is OK ,most things work alright but it suffers from periodic freeze ups which require rebooting twice to get it going again.A bit of a pain in the bum.
Ah well,back to the stock model for a while and monitor developments.
regards Dennis
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 29 Dec 2009, 19:20    Post subject:  

maybe try
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/cups-1.1.23-patched1-1-pup4.pet
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/gutenprint-5.2.3.99.1-pup4.pet
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/ghostscript-8.15.2-4cups1123.pet

when testing things like this you should first boot up puppy with
puppy pfix=ram
so you don't mess up your current settings
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Tue 29 Dec 2009, 22:08    Post subject:  

Tuuxxx
I will have a look at those.I dont use puppy from the CD.I have several hard disks in trays and swap them around. The one I am on now has a 4.3.1 standard pup 2* dpups and currently 1 spup. I use opera on all of them so I can move the profile folder between partitions and all other stuff in a Stuff Folder that I can shift easily as well. It is so easy to install Puppy that I do it rather than using the frugal option.One of the partitions always has stuff that I want to hold on to and the others are to play with.
Strangely I put one of your Puppy versions on an hour or so ago with your modified Cups setup and it would not see the HP5550. Odd .
Incidentally for ebook downloads on Adobe Digital Editions I had to install Windows XP on one of my Hard Disks and had forgotten what a pain it is.I took over an hour to get it done.YUK! Waste of Disk space but I could not get ADE to work on Linux.
Regards Dennis.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 29 Dec 2009, 22:24    Post subject:  

dalderton wrote:
Tuuxxx
I will have a look at those.I dont use puppy from the CD.I have several hard disks in trays and swap them around. The one I am on now has a 4.3.1 standard pup 2* dpups and currently 1 spup. I use opera on all of them so I can move the profile folder between partitions and all other stuff in a Stuff Folder that I can shift easily as well. It is so easy to install Puppy that I do it rather than using the frugal option.One of the partitions always has stuff that I want to hold on to and the others are to play with.
Strangely I put one of your Puppy versions on an hour or so ago with your modified Cups setup and it would not see the HP5550. Odd .
Incidentally for ebook downloads on Adobe Digital Editions I had to install Windows XP on one of my Hard Disks and had forgotten what a pain it is.I took over an hour to get it done.YUK! Waste of Disk space but I could not get ADE to work on Linux.
Regards Dennis.


Here's a tip for next time you want ADE Ubuntu/linux way, should also work on puppy Smile
http://ubuntuforums.org/showthread.php?t=701191
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 30 Dec 2009, 00:43    Post subject:  

Hmmm .....

dalderton wrote:
Will any version of Cups work on SPUP 451 . I have tried a few versions and cannot get to the manager on Localhost:631, .....


Only did a brief peek at spup451 ... cups is in there and I believe it's a slax's cups-1.3.9 ... the web docs are probably not installed along with several cups utils ... but it should still be working from cli ...

To have web gui access, you'll need the web docs ... get it below (or strip it from the cups-1.3.9 pet) ... btw, the reason why cups pets on this thread doesn't seem to work on spup is due to the missing unzip util in spup (only needed during installs) ... It has zip but no unzip .....


Rgds
cups-doc-139-i486.pet
Description 
pet

 Download 
Filename  cups-doc-139-i486.pet 
Filesize  453.13 KB 
Downloaded  629 Time(s) 
Back to top
View user's profile Send private message 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Wed 30 Dec 2009, 00:54    Post subject:  

Patriot I assume that by web gui you mean the Printer manager at http://localhost:631
I will reinstall Spup and try your pet.
I just loaded installed Slaxer and everything I have tried so far worked without problems.
I will post result at a later time.
Regards Denis.
Back to top
View user's profile Send private message 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Wed 30 Dec 2009, 01:20    Post subject:  

Patriot RULES the world of CUPS.
Bingo I downloaded the pet and installed it and it works like a charm .I had to use the Password setup but I remembered them from other posts and all is well.
I wonder how it got missed in the Spup setup. Thanks to all who contributed to the solution to the problem,Patriot for the solution and the others for taking the time to help a geriatric trier.
Regards Dennis.
Back to top
View user's profile Send private message 
dalderton

Joined: 22 Apr 2007
Posts: 145

PostPosted: Wed 30 Dec 2009, 01:27    Post subject:  

Patriot RULES the world of CUPS.
Bingo I downloaded the pet and installed it and it works like a charm .I had to use the Password setup but I remembered them from other posts and all is well.
I wonder how it got missed in the Spup setup. Thanks to all who contributed to the solution to the problem,Patriot for the solution and the others for taking the time to help a geriatric trier.
Regards Dennis.
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8253

PostPosted: Wed 30 Dec 2009, 08:44    Post subject:  

Should the maker of SPUP be told there are bits miissing?

mike
Back to top
View user's profile Send private message 
matthewm1970

Joined: 28 Aug 2008
Posts: 10

PostPosted: Thu 01 Apr 2010, 13:46    Post subject:  CUPS installed, but no printouts
Subject description: Jobs go to the completed queue, but never get to the printer
 

Patriot, thank you for the excellent instructions and packaging. You rock for sharing such detailed work with the community!

I now have a reasonably functioning CUPS installation (at least, it lets me administer, add printers, etc. via the web interface!) which is more than I've had before. I've installed CUPS, ghostscript, the libtif package, and foomatic-rip (which is required by my driver).

Unfortunately, although jobs go through CUPS ok, they end up immediately on the "completed" queue, but nothing ever happens on the printer (Dell 1100, via USB). No printout, no lights flash, nothing. at all. I've tried with both the Samsung ML 1000 and Samsung ML 1510 drivers, which are specified for this printer in other forums around the net.

I used to have this working under another variant of Puppy, and still do have it working on this machine under the OS X boot, so I know it's not hardware. This is Browserlinux, a variant of Puppy 4.31.

Any suggestions? I'm stumped at this point. Thanks in advance for any pointers!
-Matthew
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 5 [65 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0847s ][ Queries: 12 (0.0045s) ][ GZIP on ]