Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 08:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
How to use the microphone on eeePC 900A?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
NewB

Joined: 31 Mar 2009
Posts: 3

PostPosted: Tue 31 Mar 2009, 12:40    Post subject:  How to use the microphone on eeePC 900A?  

(I meant to post this in the "Extra drivers for Puppy 4.1 with 2.6.25.16 kernel" thread. Don't know how to delete this post, but I'm posting there as well.)

Hello everyone. This is my first post, so let me begin by thanking all of the Puppy developers, and especially tempestuous for making all the pets available in this forum. I bought an eeePC 900A as a dedicated skype device for my mom. After loading the pets in this forum I've got almost all the hardware working. The internal microphone, however, does not work. If I plug an external mic into the side it works fine. ALSA has a setting for input source of Mic or Front Mic, but changing this has no effect. I already tried the tempestuous patch to snd-hda-intel in eee-snd-hda-intel-patched-k2.6.25.16.pet, and I added "options snd-hda-intel model=auto" to modprobe.conf.

I believe the problem is that the 900A uses the realtek ALC269, which I don't think is supported in the 1.0.16 version of ALSA. This is the same chip used in the 901, and I found a patch to the 1.0.16 version of ALSA which is supposed to fix the microphone issue on the 901. [https://bugs.launchpad.net/ubuntu/+source/linux/+bug/259878] With only a few changes I think this could support the 900A as well. Unfortunately, I'm a Puppy newbie, and after looking at some of the unleashed documentation I think trying to compile this is way beyond my level. If anyone could help me with this me and my mom would really appreciate it. I suppose she could live with using an external mic, but knowing her it would get lost behind the couch and I'd be stuck trying to explain how to reattach it without being able to hear her! Confused

Thanks again!!!!
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 536

PostPosted: Wed 01 Apr 2009, 03:52    Post subject: it is the hardware not puppy
Subject description: the Eee900 just has a lousy build-in microphone
 

The subject + description of this post says it all. Just use the external mic...
Back to top
View user's profile Send private message 
superattilius

Joined: 13 Mar 2009
Posts: 17

PostPosted: Thu 09 Apr 2009, 09:59    Post subject:  

hello
sorry for my bad english
900a work with fatdog 111

http://puppylinux.asia/tpp/kirk/Fatdog/iso/111/

skype work
webcam work

bye
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5245
Location: Australia

PostPosted: Fri 10 Apr 2009, 01:26    Post subject:  

NewB wrote:
I believe the problem is that the 900A uses the realtek ALC269, which I don't think is supported in the 1.0.16 version of ALSA.

snd-hda-intel ALSA driver now updated to support newer Eee models with ALC269 variants of the Intel audio chip, here
http://www.murga-linux.com/puppy/viewtopic.php?p=237741#237741
Back to top
View user's profile Send private message 
superattilius

Joined: 13 Mar 2009
Posts: 17

PostPosted: Fri 10 Apr 2009, 05:24    Post subject:  

sorry for my english
i installed eee-snd-hda-intel-patched-k2.6.25.16.pet then reboot but my mic with skype don't work
my mic work with fatdog 111 with the kernel 2.6.28.6

thanks
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5245
Location: Australia

PostPosted: Fri 10 Apr 2009, 07:38    Post subject:  

superattilius wrote:
my mic work with fatdog 111 with the kernel 2.6.28.6

Yes, of course newer versions of ALSA should work better.

Once the updated driver is installed, apparently some alsamixer settings need to be adjusted -
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/259878/comments/15
Back to top
View user's profile Send private message 
NewB

Joined: 31 Mar 2009
Posts: 3

PostPosted: Thu 16 Apr 2009, 09:39    Post subject: Thanks Tempestuous!  

tempestuous wrote:
snd-hda-intel ALSA driver now updated to support newer Eee models with ALC269 variants of the Intel audio chip, here
http://www.murga-linux.com/puppy/viewtopic.php?p=237741#237741


Thanks tempestuous, this is exactly what I was looking for. Unfortunately, I already gave the 900A to my mom, so I won't be able to test this out until I make another trip to see her. Makes me think I should buy another netbook (with Puppy, of course) just for me. Cool
Back to top
View user's profile Send private message 
azstew

Joined: 23 Jul 2008
Posts: 70
Location: Apache Junction, Arizona

PostPosted: Wed 06 May 2009, 13:59    Post subject:  

If you still have Zandros on the SSD, and are running Puppy from another device, there's no need to install Skype in Puppy.

I run Puppee 4.2 from an SDHC card in the card reader slot.

Mount sda1 on the Zandros and find the Skype file that starts Skype.

Drag it to the Puppee desktop, and create a link.

It took some futzing with alsamixer to get the whole ball of wax working.

When you restart Puppee, the Skype icon will be the triangle w/!.

Mount sda1, and the icon changes to the one you use.

Click and Viola! Wink
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Wed 06 May 2009, 15:15    Post subject: Puppy using Xandros Skype  

azstew wrote:
If you still have Zandros on the SSD, and are running Puppy from another device, there's no need to install Skype in Puppy.

I run Puppee 4.2 from an SDHC card in the card reader slot.

Mount sda1 on the Zandros and find the Skype file that starts Skype.

Drag it to the Puppee desktop, and create a link.

It took some futzing with alsamixer to get the whole ball of wax working.

When you restart Puppee, the Skype icon will be the triangle w/!.

Mount sda1, and the icon changes to the one you use.

Click and Viola! Wink


Briliate idea. I have a EeePC901 with Puppy (actually several) as a frugal installation on the bigger SSD. So I will try your trick.
Rgds
Mike
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0626s ][ Queries: 11 (0.0033s) ][ GZIP on ]