Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 02:38
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Unable to open files on Windows' drive
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
doug333x

Joined: 07 Apr 2009
Posts: 2

PostPosted: Tue 07 Apr 2009, 00:17    Post subject:  Unable to open files on Windows' drive
Subject description: Can play in Gxine after unmounting, remounting in Pmount
 

I know there must be an easy answer to this. I have tried several Puppy distros and on all of them, i can't seem to get to the windows drives in file manager. I have mounted all the disks. I know they are hda1 and hda5 but when I manage to browse my way to them in file manager-it always says it can't open them. When I try to navigate to the media files I want in Gxine-I can't even get to the drives. The only way I've been able to play these files in Puppy is to use Pmount to unmount then mount the drives-that brings up a window with the drives and then I drag and drop a media file into Gxine. What am I doing wrong?
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6378
Location: Auckland, New Zealand

PostPosted: Tue 07 Apr 2009, 02:35    Post subject:  

Puppy does not mount your disks automatically when you turn the computer on.
If you want to, you can put a script to do so in /root/Startup

1. Unmount your disks and try running the code to mount them in a terminal, just to make sure you can do it (N.B. you can paste text into and from rxvt by pressing the middle mouse button).
The code is something like
Code:
mount -t vfat /dev/hda1 /mnt/hda1
mount -t vfat /dev/hda5 /mnt/hda5

Hopefully I haven't made a mistake; I'm not home at the moment.

2. Make a new file and put the code in it, with this line at the top of the file:
Code:
#!/bin/sh

3. Right click on the file and choose the option to set permissions, to make the file executable.

Next time you boot Puppy should run that script automatically.

There are also ways to automatically mount whatever drives happen to be plugged in, so if you add drives they will also be mounted. e.g. http://www.murga-linux.com/puppy/viewtopic.php?p=126028&search_id=566045936#126028

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
doug333x

Joined: 07 Apr 2009
Posts: 2

PostPosted: Wed 08 Apr 2009, 04:34    Post subject:
Subject description: Thanks
 

Thanks-your advice works!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0402s ][ Queries: 11 (0.0034s) ][ GZIP on ]