Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 10:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Infrared Printing w/ 4.1.2 and Canon BJC50
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
jakfish

Joined: 18 Jul 2008
Posts: 756

PostPosted: Mon 20 Apr 2009, 09:14    Post_subject:  Infrared Printing w/ 4.1.2 and Canon BJC50
Sub_title: Connects, Prints, but No More than One Word
 

There must be at least eight people in the world who still use infrared and I'm hoping one or more of them is running it with puppy linux.

Using a Kingsun959 usb-infrared adapter, I have successfully installed infrared in 4.1.2. I can connect to an Ericsson T39m cell phone and send files, via IROBEX, back and forth with my Psion handheld.

My trouble is with getting a Canon BJC50 printer to print more than one word.

Using either the Gutenprint stp-bjc-50.5.0.ppd driver or the older Canon-BJC-50-bjc600.ppd, I can connect to the BJC50 and print exactly one word, "test" Anything more than that gives an "input/output error" in CUPS. I can not print a test page in CUPS.

In printers.conf, I have tried:

serial:/dev/ircomm0
serial:/dev/irplt0
parallel:/dev/irlpt0

All three configurations successfully connect to the BJC50, and all three only print one word. It's a beautiful word, Arial font, bold 12pt, so the connection can perform RTF-quality, but eventually, I'll need to print more than "test"

There's so little information on infrared/Linux, but I have found evidence of successful printing (more than one word) when users use "raw." But choosing "raw queue" in CUPS, rather than the Canon drivers, produces no connection to the BJC50. The users who can print have played with the printcap and seem to be able to use a combination of the Canon driver and raw input:

bj80|IrDA BubbleJet|lp|bj80ps|GS-Cannon BubbleJet 80:\
:sh:\
:xo:\
:lp=/dev/ircomm0:\
:ms=115200,raw:\
:mx#8000:\
:pl#80:pw#90:Rl#56:PS:Rw#100:\
:sd=/usr/spool/lpd/bj80:\
:if=/usr/local/lib/lpd/ps2bj80:\
:lf=/usr/spool/lpd/bj80/bj80-log:

But these printcap tweaks are for very old CUPS versions, and the present printcap in CUPS 1.2.1 doesn't appear to have the ability to tweak. If it does, could someone show me how to insert the command :ms=115200,raw:\


This is best site: http://www.windclimber.net/linux/bjc-80.pcgi (the BJC50 is similar to the BJC80) but as you'll see, he's working with an old version of CUPS.

Sorry for the long post, but I wanted to show what I've done, and that I've done my homework, and I have fingers crossed that somebody out there still connects with an infrared printer.

Jake
Back to top
View user's profile Send_private_message 
jakfish

Joined: 18 Jul 2008
Posts: 756

PostPosted: Wed 22 Apr 2009, 19:03    Post_subject:  

As an update, it appears that it may be a problem in the ks959-sir.ko.

When I ran puppy linux 4.1.2 in a Dell Inspiron 600m (w/ built-in infrared port), the BJC-50 worked. It also worked in XP Pro w/ the KS-959 infrared adapter. So my findings tell me it's the ko. The distributor of the adapter says it works with Linux so I've written him for more information, and I'll post back if I get any.

Jake
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0404s ][ Queries: 11 (0.0026s) ][ GZIP on ]