Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 17:40
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Amarok 1.4.10 - Powerfull music player SFS
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 7 [95 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Fri 07 Jan 2011, 12:30    Post subject:  

Once again, great work dejan! Cool

I am setting up PC using a NOP 4.0 (based on Puppy 4.0) for a family that has teenagers, thus they needed an iTunes alternative also, and I love Amarok so I wanted it to run it on this.

Download dejan's amarok sfs, change the name to amarok.sfs, load it via the bootmanager like any other sfs.

It needed libsqlite3.so.0 which I got and have packaged for those that want it, see attached.

Runs great looks great. Cool
amarok-xtralibs-pup40.pet
Description 
pet

 Download 
Filename  amarok-xtralibs-pup40.pet 
Filesize  440.85 KB 
Downloaded  330 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Fri 07 Jan 2011, 15:02    Post subject:  

That's cool Steve, just to let you know people Iguleder has newer amarok sfs's that are maybe more suitable for 5.x series based puppies.
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Fri 07 Jan 2011, 21:32    Post subject:  

Cool, but I need this for 4.0.

Anyway, question: is it possible to change Amarok's temp folder location, 'cause it appears that it is using something within the standard filesystem, like something in /usr or /root or something like that so it's affecting my save space.

Can I change it to something in /mnt/home/ that way it won't affect my save file? Confused

NEVERMIND: it seems it was a symlink issue that xfce pulled on my...I thought something was just a link but it was instead filling up the save file...
Back to top
View user's profile Send private message Visit poster's website 
Lord_Solrac2

Joined: 22 Dec 2010
Posts: 35
Location: Gurabo, Puerto Rico

PostPosted: Mon 24 Jan 2011, 06:50    Post subject:  

D: Dead Links
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Mon 24 Jan 2011, 07:48    Post subject:  

Sorry Sad Links for 4.1 sfs and dpup 484 work for me so I guess you were trying to download for 430? I'll see if I have this specific sfs and re-upload I think it's actually 410 sfs converted to sfs version 4
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
charlie6

Joined: 30 Jun 2008
Posts: 994
Location: South of Belgium

PostPosted: Wed 26 Jan 2011, 11:16    Post subject:
Subject description: amarok.sfs on wary-500 multilingual
 

Hi Dejan,
many thanks for all these sfs !
amarok.sfs works nice on lupq-Quickset !
it also really has enough KDE dependencies so that some KDE applications works without adding extra dependencies !!
Amarok's mini icons installs in the menu and start from the menu.

Now trying to get it running on wary-500, it does not start from menu (only Amarok text present - no mini-icon);
Have renamed the archive to amarok_w5-sfs4. (49M) before load it in the bootmanager.
Starting in a console results in:
the Amarok screen disappears as soon as it appears; and here are the comments:
Code:
# amarok
X Error: BadDevice, invalid or uninitialized input device 172
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 172
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: error while loading shared libraries: libpcreposix.so.3: cannot open shared object file: No such file or directory
#


Did I something wrong?
Thanks for any answer

Charlie

ps: links for amarok_430.sfs4.sfs seems to be broken - could not download since about 1 week ago.
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Wed 26 Jan 2011, 11:40    Post subject:  

Seems like you loaded sfs ok but wary has bit different kernel and core base. Also that lib that it reports missing in last line of output there's pet for it in first post of this thread "libpcre-something" install it and try if it runs...

Amarok is in quickpet? Didn't know... probably one of iguleder's sfs.
EDIT: Oh it's "Quickset" my bad sorry Razz


EDIT: Totally forgot about dead links someone already reported that... I'll try to remember to reupload later.

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Mmmm

Joined: 15 Jun 2010
Posts: 22

PostPosted: Wed 26 Jan 2011, 12:59    Post subject:  

dejan555 wrote:
That's cool Steve, just to let you know people Iguleder has newer amarok sfs's that are maybe more suitable for 5.x series based puppies.

How do I get hold of these?
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Wed 26 Jan 2011, 13:51    Post subject:  

Um, I guess here http://brainwavedesigncentral.net/dima/kdebase-3.5.12/

You probably need kdebase and amarok sfs's but not sure take a look at this thread:
http://www.murga-linux.com/puppy/viewtopic.php?t=58921

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
DM was on fire!


Joined: 12 Sep 2009
Posts: 149
Location: N.E. Georgia Mountains, USA

PostPosted: Sat 29 Jan 2011, 16:02    Post subject:  

Hey Dejan. c: I've been running this on JWM, and OpenBox, without issues; but for some reason I can't run it in KDE 3.5 Trinity without being informed libxine is broken? I've had this happen on two occasions, both while running KDE; but both times have also been on Lupu official release (which is really ironic considering I'm running 5.11 on here, although I am going to reinstall, and it works fine). So I'm not entirely sure which is to blame?
Back to top
View user's profile Send private message MSN Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Sat 29 Jan 2011, 16:05    Post subject:  

You are saying that you're using my sfs with trinity or iguleder's sfs with trinity? Trinity (3.5.12) is newer then kde 3.5.10 so it might have different library versions but if you're using Iguleder's amarok sfs that is packaged for trinity I don't think there should be issue.
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
DM was on fire!


Joined: 12 Sep 2009
Posts: 149
Location: N.E. Georgia Mountains, USA

PostPosted: Sat 29 Jan 2011, 16:07    Post subject:  

I had to look actually; because quite frankly I couldn't remember! lol
It's iguleder's, actually. It informs me that libxine is broken or doesn't exist, or something to that effect; and when I decided to take the libxine.so that I had on my previous Linux install, it still informs me it's broken.
I plan on experimenting tonight so if you would like, I will give you a screenshot. Smile
Back to top
View user's profile Send private message MSN Messenger 
charlie6

Joined: 30 Jun 2008
Posts: 994
Location: South of Belgium

PostPosted: Mon 07 Feb 2011, 12:33    Post subject:
Subject description: amarok 1.4.10 on wary-500 full iso
 

Hi dejan555,
thanX
dejan555 wrote:
Seems like you loaded sfs ok but wary has bit different kernel and core base. Also that lib that it reports missing in last line of output there's pet for it in first post of this thread "libpcre-something" install it and try if it runs...

Got it to run on wary500 full iso!
- sfs4 converted and renamed the amarok_410.sfs to amarok_w5-sfs4.sfs
Just needed to install:
- libpcre3_7.6-2.1_i386.pet see p1 this thread
- (see warning below !) amarok-xtralibs-pup40.pet see above post (missing libsqlite3.so.0) thankX to steve_s Wink
- libxine.so.1 got after installing ttuuxxx's xine-lib-1.1.19-i386.pet
http://www.smokey01.com/ttuuxxx/Wary/Software/xine-lib-1.1.19-i386.pet

Now let's just test some mp3's.

- last edited: also installed libssl0.9.8_0.9.8o-4_i386.deb from debian packages (contains missing libssl.so.0.9.8 and libcrypto.so.0.9.8 )

edited 11feb2011: WARNING! have got these problems:
1. Seamonkey don't start anymore
2. GFtp client cannot connect to a server (it freezes)
So I had to reinstall SQlite from PPM to get Seamonkey working; but GFtp client no longer works. So I suspect the above procedure to have corrupted some files. I believe the better would not to install the amarok-extralibs-pup40.pet as this seems to be specific to puppy4 series, and also as wary has already the libsqlite in it. So be carefull



Cheers
Charlie

Last edited by charlie6 on Sun 13 Feb 2011, 14:49; edited 3 times in total
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2646
Location: Montenegro

PostPosted: Mon 07 Feb 2011, 14:10    Post subject:  

That's cool charlie6, rock on! Very Happy
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
bwh1969

Joined: 25 Oct 2010
Posts: 129
Location: Allentown, PA

PostPosted: Thu 24 Feb 2011, 23:06    Post subject:  

Thanks for this. I missed amarok 1.4.... I can't say I dislike the Kde 4 version (2.x) but it just seems to have lost some of its functionality.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 7 [95 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0824s ][ Queries: 12 (0.0052s) ][ GZIP on ]