Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 14:09
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to set up an HP 5510 printer? (solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sat 09 May 2009, 18:11    Post subject:  How to set up an HP 5510 printer? (solved)  

I am trying out Puppy Linux 4.2 -v2. The only problem I have encountered so far is that I cannot get a printer setup to print, specifically my HP 5510. Cups sees it but I cannot print to it.

I have installed the hpijs-2.8.2_static-1 pkg.

I am running puppy on a dell machine with 2GB ram, 2Mhz processor.

thx in advance for your help.

Last edited by wah fun on Mon 11 May 2009, 19:31; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sat 09 May 2009, 18:19    Post subject:  

Go to the folder /usr/lib/cups/filter
Locate the file foomatic-rip-hplip and open it in a text editor
Change the top line to #!/usr/bin/perl -U
Run CUPS again
Back to top
View user's profile Send private message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sat 09 May 2009, 20:46    Post subject:  

Thanks. I have done that but alas, still the problem.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sat 09 May 2009, 23:07    Post subject:  

Go to the CUPS web interface and print a test page. What error message is displayed?
Back to top
View user's profile Send private message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sun 10 May 2009, 10:11    Post subject: HP 5510  

Cups shows the print job completed but the following error is displayed:
"/usr/lib/cups/filter/foomatic-rip-hplip failed".

thx
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 16:22    Post subject:  

Did you use an upper-case U in the patch above?
Back to top
View user's profile Send private message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Mon 11 May 2009, 17:46    Post subject:  

Yes.
Back to top
View user's profile Send private message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Mon 11 May 2009, 19:30    Post subject: (Solved)  

Hey all. I just downloaded and install CUPS 1.3.10 with HPIJS Drivers per rcrsn51's instructions and everything works great with my HP 5510.

Thx rcrsn51!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9039
Location: Stratford, Ontario

PostPosted: Tue 12 May 2009, 08:21    Post subject:  

Glad to help. When Puppy 4.2.1Final comes out, it will have CUPS 1.3.10 included. So you will just need to install the hpijs-3.9.4-dynppds.pet to get your printer working.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0453s ][ Queries: 11 (0.0032s) ][ GZIP on ]