Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Dec 2014, 17:26
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
No Audio with Retro 4.2 (Solved!)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
wmichaelb


Joined: 16 Apr 2009
Posts: 49
Location: Cincinnati, OH

PostPosted: Wed 20 May 2009, 22:32    Post_subject:  No Audio with Retro 4.2 (Solved!)
Sub_title: Unless I reinstall the Alsa driver
 

Hi, I'm running Puppy 4.2 retro on an old HP Vectra VL, 350 MHz PII, 190 MB of RAM, and a 20 GB HD. The system has sound built into the mobo, and when I run alsaconf, it finds an AZT 1008 PNP sound device. If I hit enter, it then says:

Configuring snd-azt2320
PLEASE ANSWER YES HERE SO PUPPY WILL USE DRIVER ON NEXT BOOT
Do you want to modify /etc/modprobe.conf?

I hit enter for yes, and get:

OK, sound driver is configured.

ALSA WIZARD will prepare the card for playing now.

Technical: "/etc/rc.d/rc alsa start" will be used to initialize Alsa, amixer used to raise volume.

You can change the volume later via a mixer program such as sGmixer (Multimedia menu), or click on speaker icon in tray for volume slider.

I get a nice bark out of the speakers, and everything plays nicely. Except...there is no speaker control in the tray, and when I reboot, I have to reload the ALSA driver all over again. Is there something missing from the install in the ALSA files that I should look for?

Thanks in advance!
- Michael B. in Cincinnati

Edited_time_total
Back to top
View user's profile Send_private_message 
wmichaelb


Joined: 16 Apr 2009
Posts: 49
Location: Cincinnati, OH

PostPosted: Wed 03 Jun 2009, 14:06    Post_subject: No Audio with Retro 4.2 (Solved!)
Sub_title: Can we implement this bug fix in the ISO?
 

In the middle of all this, the original Vectra sound card died. I got lucky and scored an ISA Soundblaster card on Amazon.com of all places, for $10. After installation, it played just fine. But when I rebooted, it wouldn't play until I reinstalled the driver.

I looked at the modprobe.conf file, but the correct driver reference was there, so I figured that it had to be an alsa problem. After some searching, I found:

http://www.murga-linux.com/puppy/viewtopic.php?t=37800

which recommended this:

"Add the command listed below and put this line in your /etc/rc.d/rc.local file.
Code:
/etc/rc.d/rc.alsa start"

I rebooted, and immediately played music with no other problems. Thanks, conra!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0428s ][ Queries: 11 (0.0065s) ][ GZIP on ]