Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 14:40
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon MP/MX/MG Scanner Drivers - Updated 2014
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 6 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
marada2

Joined: 19 Oct 2013
Posts: 64

PostPosted: Wed 06 Nov 2013, 13:02    Post_subject:  

Thanks very much for putting all this info up. With the pixma_backend_5xx-1 I have managed to get my scanner working over wifi on my Canon Pixma MP560.

I am able to scan fine from the Sane program on the computer, however I am unable to use the control pad on the printer itself to scan to the computer. The control pad on the printer simply does not list the puppy computer as a destination to scan to. When using the printer control pad with windows I am able to see the windows computer, tell it to scan multi page, build PDF etc and upon scanning the Canon scan program pops up with my scanned files. Do you know if it is possible to get a similar function working in Puppy?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Wed 06 Nov 2013, 13:34    Post_subject:  

marada2 wrote:
however I am unable to use the control pad on the printer itself to scan to the computer. The control pad on the printer simply does not list the puppy computer as a destination to scan to. When using the printer control pad with windows I am able to see the windows computer, tell it to scan multi page, build PDF etc and upon scanning the Canon scan program pops up with my scanned files. Do you know if it is possible to get a similar function working in Puppy?

No it is not. You must start the scanning job from the Puppy machine.

However, you may find some operations easier to do with Peasyscan than with Xsane.
Back to top
View user's profile Send_private_message 
marada2

Joined: 19 Oct 2013
Posts: 64

PostPosted: Wed 06 Nov 2013, 15:33    Post_subject:  

Ok thanks for letting me know. It's a pity scanning from the control pad of the printer won't work, but never mind.

Thanks for your help
Back to top
View user's profile Send_private_message 
nic007

Joined: 13 Nov 2011
Posts: 786

PostPosted: Wed 20 Nov 2013, 10:25    Post_subject:  

Still nothing available for Canon Isensys MF-3220. Sad
Back to top
View user's profile Send_private_message 
fixit

Joined: 16 Mar 2013
Posts: 930
Location: El Lago, Texas

PostPosted: Wed 20 Nov 2013, 22:54    Post_subject: Canon mg 2220 scanner drivers  

Code:

MP490 needs the scangearmp_490series-1.40.pet and the matching scangearmp_common-1.40.pet. Older Puppies also need libusb-1.0.


I can't find these for a Canon MG 2220.

The printer is working fine, but not the scanner part.

Thanks.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Wed 20 Nov 2013, 23:37    Post_subject:  

Here is the scangearmp_mg2200series-2.00.pet.

Use the smaller grey DOWNLOAD button on the left.

It also requires the scangearmp_common-2.0.pet from the previous page.

Edited_time_total
Back to top
View user's profile Send_private_message 
fixit

Joined: 16 Mar 2013
Posts: 930
Location: El Lago, Texas

PostPosted: Thu 21 Nov 2013, 01:51    Post_subject:  

I installed it.

When I click scangeargetmp, nothing happens.

Take care,
Andy
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Thu 21 Nov 2013, 08:32    Post_subject:  

fixit wrote:
I installed it. When I click scangeargetmp, nothing happens

????

What Puppy version are you using?

If you installed the two PETs correctly, you will get a menu entry under Graphic called Canon Scangearmp Scanner. Do you see it?

If you click it, you will either get a window with the scanner program running or a message that no scanner was detected.

Run the Puppy Package Manager and check that both PETs are installed - scangearmp_common-2.0 and scangearmp_mg2200series-2.0.

Open a terminal and run the command: scangearmp
Back to top
View user's profile Send_private_message 
fixit

Joined: 16 Mar 2013
Posts: 930
Location: El Lago, Texas

PostPosted: Fri 22 Nov 2013, 06:05    Post_subject:  

Code:
Run the Puppy Package Manager and check that both PETs are installed - scangearmp_common-2.0 and scangearmp_mg2200series-2.0.


I don't understand how to tell which are installed ?
Code:

Open a terminal and run the command: scangearmp


scangearmp: error while loading shared libraries: libgimp-2.0.so.0: shared object file: No such file or directory

I can not figure out how to copy text from a Konsole window. Smile

Andy
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Fri 22 Nov 2013, 08:28    Post_subject:  

You have installed the wrong PETs. The MG2220 packages do NOT give you the error about Gimp. I would download and install them again.

The common package can be downloaded here.
Back to top
View user's profile Send_private_message 
fixit

Joined: 16 Mar 2013
Posts: 930
Location: El Lago, Texas

PostPosted: Sat 23 Nov 2013, 19:19    Post_subject: Thanks - Canon Scanner problemo solved :-)  

Thanks it's working.

I used mtPaint and told it to print it, but nothing happened. ?

It printed ok from LibreOfficeDraw.

What is the easiest way to put icons on the desktop.

It's hard to tell which files are the "executables" and I think some are in different directories also.

Thanks,
Andy
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Sat 23 Nov 2013, 19:44    Post_subject: Re: Thanks - Canon Scanner problemo solved :-)  

fixit wrote:
I used mtPaint and told it to print it, but nothing happened. ?

In mtPaint, go to File > Actions > Configure > Print image

Change the command to: peasyprint %f

If your Puppy version does not have PeasyPrint, get it here.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Mon 16 Dec 2013, 14:02    Post_subject:  

Here is the scangearmp_e510series-2.00.pet.

Use the smaller grey DOWNLOAD button on the left.

It also requires the scangearmp_common-2.0.pet from the previous page.

This driver does NOT work with Xsane or Peasyscan. Use the Scangearmp program instead.
Back to top
View user's profile Send_private_message 
larski

Joined: 22 Dec 2013
Posts: 5

PostPosted: Sun 22 Dec 2013, 08:15    Post_subject: slacko 560, pixma mx452
Sub_title: printer will not produce a page
 

hi.
i have fujitsu lifebook running slacko 5.6.0. kernel 3.10.5 with a canon pixma MX452. new to puppy, but have used linux quite a lot over the years - never have been a guru though.
ive read this entire thread (and its predecessor), and have tried several things, including getting the canon 3.90 driver source from japan. i get the same behavior whether connected via USB cable or wirelessly. CUPS 1.4.8 finds the printer (with the firewall properly informed) ive tried a couple of different drivers, two of which supposedly were for mx450 series. everything appears happy. however when i request it, a test page is not produced. no indication that the printer is reacting in any way (no sounds, status panel indications)
i even got the 30 day turboprint trial, but could not produce any output using that either.
i would appreciate any guidance you might provide

thanks in advance.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9370
Location: Stratford, Ontario

PostPosted: Sun 22 Dec 2013, 08:44    Post_subject:  

This is the thread for Canon scanner drivers. I have posted a printer driver for the MX450 series here. Click the grey Download button on the left.

This is a new Canon driver series, so please report back with your success or failure. Once you have the printer working, we can look at the scanner driver.

Quote:
I've tried a couple of different drivers, two of which supposedly were for mx450 series

It helps me if you identify exactly what those drivers were.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 6 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0801s ][ Queries: 12 (0.0045s) ][ GZIP on ]