Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Apr 2017, 12:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Gxine crashes xwin after playing each music file [OPENED]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
ocpaul20

Joined: 31 Jan 2008
Posts: 241
Location: PRC

PostPosted: Tue 23 Jun 2009, 23:00    Post subject:  Gxine crashes xwin after playing each music file [OPENED]
Subject description: Not really solved
 

Frugal harddisk install Puppy 421

Gxine crashes on me everytime it finishes playing a file. It kills xwin and drops me back to the console screen.

I then have to restart xwin and off we go again. I have obviously got something wrong somewhere. Where can I start looking please?

/tmp/xerrs.log has this to say....not really a lot of help.

DEBUG: XError: BadWindow (invalid Window parameter)
DEBUG: Request Code: 12 (X_ConfigureWindow)
DEBUG: Minor Code: 0
DEBUG: Resource ID: 0x600fbf
DEBUG: Error Serial: 33115DEBUG: XError: BadWindow (invalid Window parameter)
DEBUG: Request Code: 20 (X_GetProperty)
DEBUG: Minor Code: 0
DEBUG: Resource ID: 0x600fbf
DEBUG: Error Serial: 33116
DEBUG: XError: BadWindow (invalid Window parameter)
DEBUG: Request Code: 20 (X_GetProperty)
DEBUG: Minor Code: 0
DEBUG: Resource ID: 0x600fbf
DEBUG: Error Serial: 33117
DEBUG: XError: BadWindow (invalid Window parameter)
DEBUG: Request Code: 3 (X_GetWindowAttributes)
DEBUG: Minor Code: 0
DEBUG: Resource ID: 0x600fbf
DEBUG: Error Serial: 33120
DEBUG: XError: BadWindow (invalid Window parameter)
DEBUG: Request Code: 8 (X_MapWindow)
DEBUG: Minor Code: 0
DEBUG: Resource ID: 0x600fbf
DEBUG: Error Serial: 33122

Last edited by ocpaul20 on Tue 30 Jun 2009, 02:16; edited 2 times in total
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4713

PostPosted: Sat 27 Jun 2009, 09:33    Post subject:  

try running from the command line
Code:
gxine somefile

it should give you a better idea

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
ocpaul20

Joined: 31 Jan 2008
Posts: 241
Location: PRC

PostPosted: Sun 28 Jun 2009, 01:08    Post subject:  

Thanks for the reply technosaurus.

ok, I tried that and I got this... Looks as if it needs a configuration file somewhere and missing a library. I have looked in .gxine in my home directory and there is only a socket file and an 'accels.scm' file in there. Should there be a config file too?

Today I dragged this .ogg file to the open gxine window and it started playing OK. Then I went to close another app and the whole of xwin crashed back to the console. xwin started it again, but I lost the other minor stuff I was doing.

------------------------------------

# gxine ciw.ogg
warning: configuration item media.capture.save_dir points to a non-existent location
warning: configuration item media.dvd.raw_device points to a non-existent location /dev/rdvd
warning: configuration item media.dvd.css_cache_path points to a non-existent location /root/.dvdcss/
warning: configuration item media.vcd.device points to a non-existent location
warning: configuration item media.video4linux.radio_device points to a non-existent location /dev/v4l/radio0
warning: configuration item media.video4linux.video_device points to a non-existent location /dev/v4l/video0
warning: configuration item media.wintv_pvr.device points to a non-existent location /dev/video0
libgnomevfs-2.so.0: cannot open shared object file: No such file or directory.
AFD changed from -2 to -1

(gxine:10723): Gtk-CRITICAL **: gtk_tree_model_iter_nth_child: assertion `n >= 0' failed

(gxine:10723): Gtk-CRITICAL **: gtk_list_store_get_value: assertion `VALID_ITER (iter, list_store)' failed

(gxine:10723): GLib-GObject-WARNING **: gtype.c:3339: type id `0' is invalid

(gxine:10723): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
gxine has suffered a fatal internal error.
To get a backtrace, run gxine in a debugger such as gdb.
Then, when the error occurs:
(gdb) thread apply all bt
gxine: error: Fatal error: Segmentation fault
^C
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6740
Location: Auckland, New Zealand

PostPosted: Sun 28 Jun 2009, 05:34    Post subject:  

I'm afraid I can't really help solve the problem with gxine, but if you just want to play some media files you can always install mplayer or something and use it instead... or I guess start with a fresh Puppy setup - I presume it used to work for you?
Have you installed anything to do with ffmpeg or some sort of media program lately?
Any gtk or glib packages or anything?

_________________
If you have or know of a good gtkdialog application, please post a link here

Classic Puppy quotes

ROOT FOREVER
Back to top
View user's profile Send private message 
ocpaul20

Joined: 31 Jan 2008
Posts: 241
Location: PRC

PostPosted: Sun 28 Jun 2009, 05:47    Post subject:  

I have been messing about trying to get SCIM working and finally managed it. The might have added/deleted something I suppose. I have resorted to using mplayer instead as you suggest.

I might have to start from a clean-ish system. I have a pup-save with just scim working on it so I can start from there perhaps. The other things I need are mostly in sfs files. My pup-save is getting too big anyway, so now might be a good time to clear out all the rubbish because I am starting to have odd small things come up.

Thanks for the help..
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4713

PostPosted: Sun 28 Jun 2009, 23:01    Post subject:  

it seems like your version of gxine is not compiled for puppy (like it is repackaged from another distro)... If in fact it is a Puppy gxine I would report it as a bug - it should have been compiled with something like --disable-gnome or --disable-gnome-vfs
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
ocpaul20

Joined: 31 Jan 2008
Posts: 241
Location: PRC

PostPosted: Mon 29 Jun 2009, 02:32    Post subject:  

How odd. OK, It is bound to be something I have done while messing about.

Thank you all for your thoughts and advice.
Back to top
View user's profile Send private message 
ocpaul20

Joined: 31 Jan 2008
Posts: 241
Location: PRC

PostPosted: Tue 30 Jun 2009, 02:15    Post subject:  

So today I spend a couple of hours trying to find out what is causing the problem, and I have not got much further. I tried the standard + scim only and it appeared to be working, then I started installing packages and it went wrong. So I tested with the standard + scim-only version some more & eventually I got that to crash too.

I did even get it to do the same thing even when booting from Puppy 421 CD with puppy pfix=ram - I understand thats as standard as you can get.

The music I have been playing is mainly .ogg files but there were some mp3 files as well. The circumstances it requires to get the crash back to the console screen are different most times (ie it is a tricky bug), so I suspect after all this that there is a bug in gxine somewhere as it exists in Puppy.

Doing a search on Google for 'gxine crashes' also throws up a fair number of problems.

It seems that getting more and more applications to work together becomes more and more tricky, so maybe this idea of having various flavours of a distro is a good one or maybe the bigger distros have a larger user base and have ironed out a lot of their problems.

I am not going to spend any further time on it, but maybe it will hasten the search for a different gxine-like player for future versions of Puppy.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0504s ][ Queries: 11 (0.0107s) ][ GZIP on ]