Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 10:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
SMPlayer 0.6.7 - Complete and portable mplayer front-end
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Fri 26 Jun 2009, 00:46    Post subject:  SMPlayer 0.6.7 - Complete and portable mplayer front-end  

Hi everybody, I am pleased to present SMPlayer 0.6.7 for Puppy.

Updated link 2010-09-18

http://www.filefront.com/17299526/smplayer-0.6.7-i386.pet/

"SMPlayer intends to be a complete front-end for MPlayer, from basic features like playing videos, DVDs, and VCDs to more advanced features like support for MPlayer filters and more". See additional information in: http://smplayer.sourceforge.net/

Includes:
- mplayer from mplayer-1.0rc2-071007.pet
- Translations for ENG and ESP.
- Help files for ENG and ESP.
- Skins.

Removed:
- Some documents.
- Another Translations.
- Another help files.

It needs Qt, this can be downloaded from:

ftp://ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/qt4-4.3.2.pet

Puppy 4 series

Not additional files are needed for 4.12, after Qt is installed.


Puppy 2 series

I tested SMPlayer with Puppy 2.14x (ttuuxxx release) it works flawless but some additional libraries need to be installed.


Instructions:

1. Install Qt (tested with qt4-4.3.2.pet), then edit /etc/profile.locale file and add /opt/qt4/lib to LD_LIBRARY_PATH.

2. Restart X server.

3. Copy smplayer_files_for_puppy2.zip in /usr/lib

3.a. Create symbolic links for libraries:

Code:
   
        cd /usr/lib
   ln -s libavutil.so.49.5.0 libavutil.so.49
   ln -s libavcodec.so.51.44.0 libavcodec.so.51
   ln -s libavformat.so.51.14.0 libavformat.so.51
   ln -s libpostproc.so.51.1.0 libpostproc.so.51



4. Install Smplayer.

5. Enjoy.

I tested it with a wide range of formats: Mkv, AVI, MPG, MOV, etc.

I hope you like it. Any feedback is welcome
smplayer_files_for_puppy2.zip
Description  Additional libraries for Puppy 2 series
zip

 Download 
Filename  smplayer_files_for_puppy2.zip 
Filesize  1.49 MB 
Downloaded  830 Time(s) 

Last edited by clarf on Sat 18 Sep 2010, 11:23; edited 1 time in total
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 26 Jun 2009, 01:14    Post subject:  

I think thats a great Idea, thanks Smile I might be also replacing the ffmpeg library in 2.14.1X to series 4 so It could just be a matter of installing the qt package to get it working, I was going to do this near the end, so that the vlc 8.6h package would also work on it. Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Fri 26 Jun 2009, 04:51    Post subject:  

ttuuxxx,

have you tried PupFF in 2.14x to see if it works...

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 26 Jun 2009, 06:50    Post subject:  

gposil wrote:
ttuuxxx,

have you tried PupFF in 2.14x to see if it works...

Ok I will next time I'm on 2.14.1X, I also removed the help/info documents and locals and reduced the size of the pet by almost 700kb compressed:) here's the english only version
ttuuxxx
pupff-1.01.pet
Description 
pet

 Download 
Filename  pupff-1.01.pet 
Filesize  1.06 MB 
Downloaded  624 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Fri 26 Jun 2009, 09:39    Post subject:  

ttuuxxx wrote:
I think thats a great Idea, thanks Smile I might be also replacing the ffmpeg library in 2.14.1X to series 4 so It could just be a matter of installing the qt package to get it working, I was going to do this near the end, so that the vlc 8.6h package would also work on it. Smile
ttuuxxx


Thanks for your support ttuuxxx.

You are right, It´ll be a good update for Puppy 2.14.1X... just don´t forget to create all symbolic links needed by GXine or any other player, you could breake something... Wink

Last edited by clarf on Fri 26 Jun 2009, 09:47; edited 1 time in total
Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Fri 26 Jun 2009, 09:43    Post subject:  

ttuuxxx wrote:
gposil wrote:
ttuuxxx,

have you tried PupFF in 2.14x to see if it works...

Ok I will next time I'm on 2.14.1X, I also removed the help/info documents and locals and reduced the size of the pet by almost 700kb compressed:) here's the english only version
ttuuxxx

Hey, are you hijacking my post? Laughing

I´ll test PupFF too... Wink
Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Fri 26 Jun 2009, 09:45    Post subject:  

.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 26 Jun 2009, 17:54    Post subject:  

clarf wrote:

Hey, are you hijacking my post? Laughing

I´ll test PupFF too... Wink


Hey we Hijack anything we want around here, its Open Source, lol
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 26 Jun 2009, 17:57    Post subject:  

clarf wrote:
just don´t forget to create all symbolic links needed by GXine or any other player, you could breake something... Wink


LOL you didn't just tell me to do that did you,lol Man I feel like such a newbeeeeeeeee to read something like that,lol Thats funny, Actually no I wouldn't be system linking anything,lol I'll ditch gxine, libxine and install 4 series ones Smile Sometimes when you system, link older gxine parts to newer ffmpeg parts you run into issues, its best just to replace the whole thing.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Diamond

Joined: 11 Dec 2007
Posts: 141

PostPosted: Wed 16 Sep 2009, 16:01    Post subject:  

/usr/bin/mplayer: error while loading shared libraries: libavformat.so.51: cannot open shared object file: No such file or directory

Please help!
Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 17 Sep 2009, 15:35    Post subject:  

Diamond wrote:
/usr/bin/mplayer: error while loading shared libraries: libavformat.so.51: cannot open shared object file: No such file or directory

Please help!

You must create the related symbolic links as they appear in my first post. Which Puppy version?. Is Qt installed and the variable LD_LIBRARY_PATH is correct?
Back to top
View user's profile Send private message 
Diamond

Joined: 11 Dec 2007
Posts: 141

PostPosted: Thu 17 Sep 2009, 15:40    Post subject:  

qt4-4.3.2.pet is installed,version 4.1.2 Lighthouse.
Back to top
View user's profile Send private message Visit poster's website 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 17 Sep 2009, 17:18    Post subject:  

I don´t have Lighthouse installed and could not test it. tazoc could removed some needed libraries by smplayer. Please download smplayer_files_for_puppy2.zip from my first post and follow instructions for installation in Puppy 2.

Also do:

Code:
ldd smplayer


The ldd utility lists the dynamic dependencies installed and missed for smplayer.

Post the content of LD_LIBRARY_PATH variables, using command set.

Finally run smplayer from terminal and look for any error shown.
Back to top
View user's profile Send private message 
Diamond

Joined: 11 Dec 2007
Posts: 141

PostPosted: Sun 20 Sep 2009, 15:16    Post subject:  

There is a solution,"a little" workaround...
I've installed mplayer-post-1.0rc2-svn-29110-i486.pet,and then everything worked except message that version of mplayer is old.
Then I uninstalled mplayer-post-1.0rc2-svn-29110-i486.pet,and everything now works fine,every file that I open is displayed correctly (mp4,flv,mpg,avi)
Just to mention, "try to autodedect" option in subtitles does not working very well,so when it comes to serbian subtitles,I have turn it off.
Thanx again for this fabulous frontend,much,much better than mplayer frontend!
And with less bugs.Especially when it comes to subtitles.
Any chance of some new options in new relases of SMplayer ?
Actually I need some option to adjust "extra stereo" option,just like similar option in mplayer.
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Sat 14 Nov 2009, 12:17    Post subject:  

Please, If you can face it. Could you update Smplayer?
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0823s ][ Queries: 12 (0.0043s) ][ GZIP on ]