Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 07 Dec 2019, 00:37
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Misc
Looky here
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
Mr Doolie

Joined: 28 Jun 2005
Posts: 143

PostPosted: Wed 07 Dec 2005, 04:01    Post subject:  Looky here  

http://www.xpde.com/index.php

This looks interesting? How do you get it to work in Puppy?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 07 Dec 2005, 04:45    Post subject:  

Download the current .tar.gz (0.5.1).

Extract it to /usr/share

Create a new textfile /usr/local/bin/startxpde


Code:
!/bin/sh
/usr/share/xpde/bin/startxpde


Make it executable (right-click in Rox, "Permissions").

Exit JWM (hit CTRL-ALT-Backspace).
Type
xwin startxpde

Voila!
On my system it works immedeatly.
If on your system something is missing, type
xwin jwm
and tell us about it.

Mark
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15550
Location: Paradox Realm

PostPosted: Wed 07 Dec 2005, 06:54    Post subject:  

Also edit the hidden file (view hidden files by right clicking rox)

.xinitrc and put this (about 3 lines down after the existing "usr/shar . . . etc"
Code:
 /usr/share/xpde/bin/startxpde
 -Start X


Is that right MU? - My browser would not work so came out . . .

It comes up but the menus will have to be set - where is rarsa and his amazing XDG program?

Looks fantastic incidently - if you like XP (and I do - yep I am a sucker for a pretty face) Cool

_________________
Puppy on Raspberry Pi Release Candidate Cool
Puppy Links Page http://www.smokey01.com/bruceb/puppy.html Very Happy
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 07 Dec 2005, 07:40    Post subject:  

Lobster, this is basically the same as the thing I described.

Difference:
with your solution, "xwin jwm" does not work any more Wink

Xpde is in an early state, there is no filemanager yet (or does it not launch on my system only?).

Still lots of beta, I prefer working environments.
And with Themes you can make look icewm or fluxbox like Xpde.

See here for a fluxbox-theme (though it could be optimized):
http://www.murga.org/~puppy/viewtopic.php?t=4002&start=15&postdays=0&postorder=asc&highlight=

and here for icons:
http://www.murga.org/~puppy/viewtopic.php?t=4040

Mark
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15550
Location: Paradox Realm

PostPosted: Wed 07 Dec 2005, 08:29    Post subject:  

Confused Well I had to put in that line for xpde to work (it is in the documentation)

Now I always come into xpde
and the .xintrc seems to have changed

- oh gosh maybe have made things unusable - ah well
easy enough to remedy

to get jwm to work
enter prompt and type xwin jwm
(xpde still comes up)
and right click in xpde and select exit

_________________
Puppy on Raspberry Pi Release Candidate Cool
Puppy Links Page http://www.smokey01.com/bruceb/puppy.html Very Happy
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 07 Dec 2005, 08:35    Post subject:  

hm, i think you just have to remove the lines you added.
Just tried it myself, removed the lines - can start fluxbox again.

Mark
Back to top
View user's profile Send private message Visit poster's website 
mayakovski


Joined: 19 Nov 2005
Posts: 124
Location: Comox, BC, CANADA

PostPosted: Thu 15 Dec 2005, 16:15    Post subject:  

MU wrote:


Xpde is in an early state, there is no filemanager yet (or does it not launch on my system only?).

Still lots of beta, I prefer working environments.
And with Themes you can make look icewm or fluxbox like Xpde.

Mark


Not just early state, how about immobile state.

On August 21st 2004, the XPde Team released XPde 0.5.1, the release that includes a Start Menu and completes the desktop paradigm. Go to the downloads section to get binaries and sources.

Last update was over a year ago.

_________________
Mayakovski
**********************
Puppy Linux | Barking Up The Right Tree

Compaq Armada 1580DMT | P150, 49MB RAM - 3.2 GB HD, Puppy 1.0.6
Compaq Deskpro EN | P3-733, 384 MB RAM - 80GB HD, Puppy 1.0.7
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Misc
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0375s ][ Queries: 11 (0.0077s) ][ GZIP on ]