Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 17:41
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Pstreamvid v 1.3 - Streaming Video Controller
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 9 [126 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 04:10    Post subject:  

Sylvander,

Please use standard puppy to test, 421, 412, etc or 4.3 pre beta .. I can't cope with many versions of puppy, also different Window Managers

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 04:48    Post subject:  

rjbrewer,

I test again, playing all 10 channels back and forth...still ok, .. then quit..again ok... the problem is only if you quit by clicking "x" on the window and not the "quit" button. the flush will not take affect. I f you want to test how to command mplayer just do this from terminal:

Code:
mplayer -fs mms://media1.lsops.net/bbcworld_en


It's the same command that pupTV and pstreamvid uses.

Please if anybody can confirm about the test, I need another opinion, pstreamvid-1.2-2 + mplayer (any mplayer)...in puppy 430pre beta or any other standard puppy (421,412, etc) and not puplets..Micko?

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
tasmod


Joined: 04 Dec 2008
Posts: 1461
Location: North Lincolnshire. UK

PostPosted: Tue 04 Aug 2009, 06:03    Post subject:  

OK, loaded the latest pet into 421.

Tested OK, worked first time with Gxine and played channels.

Checked all memory and processes, apart from load increasing as it should, all was well. Exit produced no problems and cpu and mem returned to previous percentages.

I use a small app from time to time to free memory, it was written by tuuxxx. I'll add it below.
cleanup_memory.tar.gz
Description  memory cleaner.
gz

 Download 
Filename  cleanup_memory.tar.gz 
Filesize  284 Bytes 
Downloaded  286 Time(s) 

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 06:09    Post subject:  

tasmod wrote:
OK, loaded the latest pet into 421.

Tested OK, worked first time with Gxine and played channels.

Checked all memory and processes, apart from load increasing as it should, all was well. Exit produced no problems and cpu and mem returned to previous percentages.

I use a small app from time to time to free memory, it was written by tuuxxx. I'll add it below.


Thanks Rob,

Did you try with mplayer? fyi, I use the same method to flush memory, got it from "google"

Updated to v 1.2-3 - basically the same as 1.2-2, but a few "&" at the end of commands, and i changed the way pstreamvid gui quits. Let's see if this one resolves what rjbrewer is experiencing problems with mplayer

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
tasmod


Joined: 04 Dec 2008
Posts: 1461
Location: North Lincolnshire. UK

PostPosted: Tue 04 Aug 2009, 06:22    Post subject:  

Ah, what would we do without Google or the Forum search Laughing

Get frustrated, that's what. Cool

I recently spent some time without a net connection whilst still trying to write a couple of apps.

Scenario:-

"Ah a programming question, right, Google for answer, oh shoot, no tinternet, now what? "

Read a book, that's what! The library proved to be my best friend for a while, just took longer to get answer. Rolling Eyes

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7801
Location: qld

PostPosted: Tue 04 Aug 2009, 06:36    Post subject:  

Hello Bro

Tried with mplayer, ppa-422, Pstreamvid v 1.2-3. No problems. I was running "top" to monitor processes. The only thing, that when quiting Pstreamvid (BK calls it PstreamTV Laughing ) was that cpu usage increased to 64% for about 2 seconds, nothing to do with mplayer. So there may be a minor issue with how gtk is quitting? I would not have known it if I wasn't running "top". No memory issues.

Hope this helps... and nice work!

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 06:43    Post subject:  

01micko wrote:
Hello Bro

Tried with mplayer, ppa-422. No problems. I was running "top" to monitor processes. The only thing, that when quiting Pstreamvid (BK calls it PstreamTV Laughing ) was that cpu usage increased to 64% for about 2 seconds, nothing to do with mplayer. So there may be a minor issue with how gtk is quitting? I would not have known it if I wasn't running "top". No memory issues.

Hope this helps... and nice work!

Cheers


version 1.2-3? good. The jump of cpu usage maybe caused by gtkdialog, that's why I changed a bit how it quits in the latest version, plus that jump maybe also caused by the memory flush when quitting, I also tried from terminal (the same way as tasmod's attached pet). it will use cpu a second or two, but really useful to flush the RAM that was used by mplayer for a few channels (not all), usually BBC makes that RAM jump

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 09:20    Post subject:  

Hmm.. interesting... at the office where the internet is fast, I have no problem with mplayer, even he RAM flush seems to be working good, but when I got home, and tried he sam pstreamvid version, it happens again, The RAM jumps, and even by using the fulsh command it won't go down..key word "internet connection"
_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 04 Aug 2009, 14:13    Post subject:  

Still the same problem, no matter what method or sequence of
quitting the player.
Tried on my pc, which has 1/2 the ram and cpu speed and the
situation was worse. Ram and cpu climbed after quitting and
led to hard drive thrashing and windows freezing, had to restart x.

This does not happen with pup-tv. I can start and stop a channel
as many times as I want without ram or cpu increasing....using
either gxine or mplayer.

Incidentally: Using the same channel on pup-tv and pstream,
pup-tv uses 44/503 ram and pstream uses 74/503 at start.

My wireless connections are good according to different
speed tests.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 19:21    Post subject:  

Rjbrewer,

I think I lknow now, puptv harcoded every commands, pstreamvid uses many conditionals, fullscreen on off, mplayer, gxine, etc. All auto-detect. I have to make major reconstruction. - need time. Thks for making me think again.

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 04 Aug 2009, 21:02    Post subject:  

Pstreamvid, like Pup-tv before it, are great ideas; I'm in no hurry
and will gladly wait however long it takes to sort out any problems.

Edit:

With pup-tv, I don't use the gui. I have the usr/local/pup-tv folder on
the desktop (with suitable icon). One click and all the exe files are
right there to use. Simpler, easier, faster.

Thanks
rjb

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 21:56    Post subject:  

Updated to v 1.2-4 - Same functions, reconstructed conditonal commands - thanks rjbrewer

See main post

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 22:22    Post subject:  

Updated to v 1.2-5 - seperate kill player for off & quit button - gives a little sleep when quit - prevent jump of cpu usage when quitting

see main post

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 04 Aug 2009, 23:09    Post subject:  

again I altered the quitting process, please test which one is better 1.2-5 (main post) or 1.2-6

thanks guys
pstreamvid-1.2-6.pet
Description 
pet

 Download 
Filename  pstreamvid-1.2-6.pet 
Filesize  2.98 KB 
Downloaded  240 Time(s) 

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Tue 04 Aug 2009, 23:15    Post subject:  

No significant difference yet. 1.2.5

Pstream nasa channel> 112/503ram. hit quit. 142/503ram. close
mplayer.360/503ram..100% cpu for about 30 seconds. Fan comes
on every time.

Puptv nasa channel> 45/503 ram. close mplayer..instant drop to
23/503 ram. instant cpu drop. fan does not come on.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 9 [126 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0790s ][ Queries: 12 (0.0055s) ][ GZIP on ]