Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Jul 2015, 04:20
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.3 Final -- bug reports and suggestions
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 21 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 19, 20, 21 Next
Author Message

Joined: 20 Mar 2009
Posts: 65
Location: dorset,uk

PostPosted: Fri 18 Sep 2009, 16:31    Post_subject:  

will give that a try before the next video,ta mate
Back to top
View user's profile Send_private_message MSNM 

Joined: 18 Sep 2009
Posts: 5

PostPosted: Fri 18 Sep 2009, 18:32    Post_subject:  


It seems if I choose to create the savefile on a hdd partition, at next boot it will copy the pup-430.sfs file from the cdrom to the same partition, for faster booting. But it will not copy the zp430305.sfs file, and won't read it from the cdrom either, so no more modules, no more network. If I copy it manually all starts working again.
Back to top
View user's profile Send_private_message 

Joined: 23 Oct 2007
Posts: 1372

PostPosted: Fri 18 Sep 2009, 19:00    Post_subject: that zp430305.sfs file  

@ guest34

From the description you give, I'm assuming you have been booting off the CD, not installing Puppy to the hard drive. That second sfs file has not been standard in recent Puppies, so it won't be copied either by the shutdown script or the universal installer.

Barry will probably do away with the separate file at some point where the issues behind this are sorted out. In the past, we had a zdrv.sfs file that went away in later versions.
Back to top
View user's profile Send_private_message 

Joined: 25 Jul 2007
Posts: 27
Location: Austria

PostPosted: Fri 18 Sep 2009, 19:27    Post_subject: Remaster Puppy live CD not working any more  


I am running puppy in frugal mode. As usual, after installing some pet-packages I tried to rebuild a new pup-430.sfs. But this time I was unable to do so. After haven chosen the ramdisk as the working area, puppy next asked for the CD/DVD drive. I have 2 drives (/dev/sr0 and /dev/sr1; both can be accessed), but only my DVD drive (/dev/sr0) showed up in the dialog box. When I clicked on the yes button the script stopped immediately.

When I've tested Puppy 4.3 beta 3, everything worked fine. I think, the remasterpup2 scripts in 4.3. beta 3 and 4.3 final are identical. So there must be another reason...

By the way, the remaster script once offered to choose between the CD drive or a directory that kept the puppy files. I miss this feature as I always have to use a CD to remaster puppy.

Back to top
View user's profile Send_private_message 

Joined: 05 Aug 2007
Posts: 1809
Location: Baltimore, Maryland USA

PostPosted: Fri 18 Sep 2009, 19:34    Post_subject: No Desktop on Boot  

k2.6.21.7 burned to usb bootable

Desktop does not appear on bootup.....need to enter xwin at prompt. In lieu of fix, what can I do to beat Puppy into submission to bring desktop up automatically.


Back to top
View user's profile Send_private_message Visit_website 

Joined: 23 Oct 2007
Posts: 1372

PostPosted: Fri 18 Sep 2009, 22:44    Post_subject: no problem with Sylpheed 2.6.0  

My previous problems with Sylpheed 2.4.7 went away after I uninstalled it using the PPM, and then downloaded and installed Sylpheed 2.6.0 pet from Puppylinux.ca pet_packages-4. I suggest making this the new standard Sylpheed. Once again, I installed by clicking on a downloaded pet and had the entry appear in the menu without problems.

@ tlchost

Your description leaves a big question about what you're trying to run 4.3 on. If there is a problem with video, that might have some relevance. I also wonder if you checked the md5sum on your ISO and got a good burn. I'm not a guru on this, but I can guess what experts will want to know.

Added: Just as I was about to report complete success with 4.3 final, the wireless network gave me trouble on a new boot. This time eth0 and eth1 were correct, but the connection did not take place automatically. I was able to go through the wizard and bring it up quickly, but it looks like it did not go through the DHCP configuration by itself. This is using the Intel 2915ABG mini-pci card (ipw2200 module).
Back to top
View user's profile Send_private_message 

Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Fri 18 Sep 2009, 23:52    Post_subject:  

panzerpuppy wrote:
@nubc: Current YouTube Flash videos use the MPEG-4 AVC (H.264) codec.
The GXine/FFmpeg combo in Puppy 4.3 can't play these videos.

What a pity Sad

H.264 and VC-1 are the most used codecs on the web

* H.264 (a.k.a. AVCHD or MPEG-4 AVC) is used for YouTube videos
* VC-1 (a.k.a. WMV9 HD) is used for downloadable videos / trailers)

I have a good collection of mpeg h264 videos downloaded from
youtube and other places.

The overall sharpness and quality of playback is excellent
playing them with Gxine in 4.3 small iso...even better than on
my 4.11 and 4.12 installs, which were quite good.

Here is a mpeg h264 movie I downloaded and also burned to
data cd. Used the 477mb medium from right column.


Most youtube video sucks anyway.
Edit (except for the Lobster Dance)


Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 
Official Crustacean

Joined: 04 May 2005
Posts: 15121
Location: Paradox Realm

PostPosted: Sat 19 Sep 2009, 00:29    Post_subject:  


Why am I dancing?
Well my configuration is now sticking between boots. Smile

What was the problem?
The HD were my save files are stored had all sorts of
files. Beta stuff. Testing stuff. Config files. Two empty tins of sardines, who knows what.
Got rid of the dead fish . . . and I can now run 4.3 (was thinking of reverting to 4.2 or beta 3 of 4.3)

. . . and now back to the dancing Laughing

Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
Official Crustacean

Joined: 04 May 2005
Posts: 15121
Location: Paradox Realm

PostPosted: Sat 19 Sep 2009, 00:59    Post_subject:  

When I started using Puppy, it was one of the only Linux that had easy comprehensive and comprehensible notes

Click on Menu / help / Release Notes for Puppy 4.3
continues that tradition Smile

Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 

Joined: 05 May 2007
Posts: 10883
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 19 Sep 2009, 04:08    Post_subject: Re: PPM and menu entries
Sub_title: clue about missing menu entries

prehistoric wrote:
I just found a clue about the missing menu entries on pet packages installed in 4.3 with the latest PPM. When I installed gimp 2.4.0rc3.pet downloaded directly from ibiblio there was no menu entry. When I clicked on a local file of the same pet there was no report it was already installed, and the menu entry appeared as expected. In the previous case, where there was no menu entry for Sylpheed, I had also downloaded from ibiblio using the PPM interface. Downloading and installing by clicking on a local pet file did solve the missing menu entry problem.

Alas, the problem of Sylpheed crashing whenever I attempt to view a message with a picture or html attachment remains.

try using claws mail, This is the last version they made with openssl, then they moved to gnutls

http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 

Joined: 11 May 2008
Posts: 84

PostPosted: Sat 19 Sep 2009, 06:39    Post_subject: New version of 4.3 and md5sum's  

Hi the prodigal drbongo here! In have been away from the kennel (AWOK?) for a while but I am very impressed with 4.4, nice looks, plenty of really useful new apps and the same lightening fast response. The only thing I am confused about is that fact that Barry said he was going to upload the new version and I don't know which one I have, given the time zone difference etc, I might have downloaded it just before or just after he uploaded it. So the question is this, have the md5sum's been updated or not? Because I just downloaded it again and the md5sum don't match - it could be that the download was corrupted or that the md5sum hasn't been changed from the first iso which I seem to remember was about 110MB, and this one is only 105MB, could someone confirm what the md5sum of the new and slightly earlier versions should be?

Back to top
View user's profile Send_private_message 

Joined: 11 Aug 2009
Posts: 1938
Location: Israel, somewhere in the beautiful desert

PostPosted: Sat 19 Sep 2009, 08:49    Post_subject: Ext4 problems?  

Unable to boot with 4.3 final, from an ext4 partition and a fat32 flash drive.
It says "unable to locate pup-430.sfs" or something similar, or shows some weird kernel panic.

I tried loglevel=7, it shows error messages that have something to do with USB, when booting from the flash drive. If I haven't mistaken, it's something with the "usbcore" module.

Beta 3 worked just fine for me ... also recognized my ext4 partition. That's weird, same kernel after all. I tried both with the extra sfs in 4.3 and without it, same result. 4.2.1's good ol' kernel .25 also works, of course, but without ext4/smp support.
I'm currently Woofing a set of custom 4.3's with .21, .25, .29and .30.5 (and other modifications) ... I gotta check this. It's easy to reproduce this so-called bug.

Clean root, clean Puppy subdir, no old saves, no old sfs's ...

I've noticed one topic with a problem booting from USB ... a kernel panic. Maybe it's something serious, and people will face this problems in the upcoming week or so, when they update to 4.3.

I use 30.5 on Arch (64 bit, matters?), in parallel to Puppy. It works perfectly.
Is it possible that my modern Core 2 Duo, 2 GB system won't work with Puppy's 30.5? Crying or Very sad

First time Puppy misbehaves like that. Grrrr.

EDIT: downloading 430-small too ... gotta try that too.

Back to top
View user's profile Send_private_message Visit_website MSNM 

Joined: 30 Aug 2007
Posts: 3614
Location: around the bend

PostPosted: Sat 19 Sep 2009, 09:00    Post_subject:  

puppy430small, the first official puppy to support wifi out of the box on eeeepc701. hallelujah Cool
unpacked iso and copied to folder, removed pmedia=cd from isolinux.cfg, grub boot with menu.lst edit as:
title puppy430small on hda2
root (hd0,1)
kernel /puppy430small/vmlinuz pfix=copy nosmp phome=puppy430small psubdir=puppy430small acpi=force pfix=fsck
initrd /puppy430small/initrd.gz

PS. i am sure BK is at least partially colour blind Sad or my screen doesn't capture the full grandeurs of the colour layout Wink it looks like my clothes after 5 years of weekly washing = rapidly approaching universal grey.
if you save your password wrong seamonkey wont overwrite updates you have to manually remove the wrong password from storage.
i miss the popup tool bar on the top of the screen from 4.2.1
ok that 5 minutes worth of looking now back to playing with
my new small puppy..
Edit : that is OPEN WIFI someone needs to test WEP before we can rejoice completely.


ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>

Back to top
View user's profile Send_private_message Visit_website 

Joined: 04 Apr 2007
Posts: 6822
Location: Chatham, Kent, UK

PostPosted: Sat 19 Sep 2009, 09:34    Post_subject:  


For some reason this version, 4.3 final, large version, liveCD, not installed, doesn't find my network card Realtek rtl8111/8168B PCI-E, which I'm now posting from UPup 466 using r8169 driver, ....
[which although it's working, I wish you could sort out what I think is a timing issue, or some sequence of events which isn't quite right, and is common to many puppies, IMHO.....
- I nearly always have to run the network wizard twice before I can get on the net & have been posting this as a 'fix' for noobies for some time....which is off-putting for some of them...]

both 4.3 & 4.3scsi same problem - no network driver, even clicking load module, does nothing Sad

in hardinfo, benchmarks don't give any results....was trying to check smp performance on this P4D dual 2.6ghz box

otherwise, 4.3 seems good, - usb drive icon appears plugging in my 16gb key, but peculiarly, my CD drive icon shows as sr0....is this a designed change? both sata hard drive and ide dvdrw show under scsi devices, in hardinfo

Suggestion: Is there any chance of adding a bluetooth wizard, as usb bluetooth devices don't seem to be usable?

Ah, just spotted, Alcor microcorp usb2 web camera shows in hardinfo, but no camera in gtkam camera manager - oops upup466, will check 4.3 and update you on this issue


Aitch Smile
Back to top
View user's profile Send_private_message 

Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sat 19 Sep 2009, 11:47    Post_subject:  

Two small things:
In all Puppies in 4.2 series, hitting the power-off button on my laptop induced a controlled shut down. Not in 4.3
In all Puppies I ever tried, the 'wifi active' lamp on my laptop works EXCEPT in 4.3, though it flashes on and off as it logs on to the network.

Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 21 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 19, 20, 21 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1020s ][ Queries: 12 (0.0063s) ][ GZIP on ]