Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 04:06
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
HowTo use partially non-aliased fonts
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 17 Dec 2005, 22:46    Post subject:  HowTo use partially non-aliased fonts  

The X-Font-Server (xfs) has a method to antialias fonts.
They look less "pixeled" then.

This is good for huge fonts, because they look "rounded".

But depending on your monitor and your eyes, such fonts can be difficult to read at small sizes.

So here is a description, how to avoid antialias at small sizes.

That picture shows the result:
http://dotpups.de/pics/puppy/antialias.jpg


I installed this Dotpup, but I am not shure you need that:
http://www.murga.org/~puppy/viewtopic.php?t=4672

Then I deleted all files in /etc/fonts (rename them!)
I added a new /etc/fonts/fonts.conf
Code:
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>

   <dir>/usr/share/fonts</dir>
   <dir>/usr/X11R6/lib/X11/fonts</dir> <dir>/opt/ttfonts</dir> <dir>/usr/share/yudit/fonts</dir>
   <dir>~/.fonts</dir>



        <match target="font">
            <test name="size" compare="less">
                <double>13</double>
            </test>
            <edit name="antialias" mode="assign">
                <bool>false</bool>
            </edit>
        </match>
        <match target="font">

            <test name="pixelsize" compare="less" qual="any">
                <double>13</double>
            </test>
            <edit mode="assign" name="antialias">
                <bool>false</bool>
            </edit>
        </match>
</fontconfig>


You can run leafpad now, to test it.
Maybe, you will not see what you expected.
You have to force Gtk2-applications like leafpad,to use a font, that looks good.

Create a file /root/.gtkrc-2.0
Code:
style "user-font" {
   font_name = "lucida 12"
}
widget_class "*" style "user-font"


You also might have to set up your windowmanager.
I use fluxbox, with the Aqua-Theme.
So I edited
/root/.fluxbox/styles/FluxAqua

I replaced the line
Code:
*font:               Andale-12


with

Code:
*font:               -adobe-helvetica-bold-r-*-*-*-120-*-*-*-*-*-*


I copied Helvetica and Verdana from my Windows-Folder to /root/.fonts , and ran the commands:
cd /root/.fonts
mkfontscale `pwd`
mkfontdir `pwd`
xset fp+ /root/.fonts


Now Mozilla:
In edit - preferences:



Mark
Ps: more info on Fonts: http://www.murga.org/~puppy/viewtopic.php?t=4001&start=30

Thanks to Barry and Bombayrockers for their tips Exclamation Razz
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0477s ][ Queries: 11 (0.0055s) ][ GZIP on ]