Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 17:34
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.3.1-Release-Candidate -- bug reports
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 7 [93 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
jakfish

Joined: 18 Jul 2008
Posts: 756

PostPosted: Mon 12 Oct 2009, 08:06    Post subject:
Subject description: Abiword Excessive CPU Usage/Barry's Workaround
 

Taking Barry's suggestion of unticking both spell-as-you-go/grammarcheck-as-you-go, then closing abiword, THEN opening a MSWord doc reduces CPU usage considerably.

Thanks, it's much more manageable,
Jake
Back to top
View user's profile Send private message 
Jens

Joined: 28 Sep 2009
Posts: 1

PostPosted: Mon 12 Oct 2009, 08:40    Post subject: Abiword
Subject description: Abiword crashes when selecting 'Format' -> 'Create and modify Styles...'
 

When you start Abiword from the console and select 'Format' -> 'Create and modify Styles...', it crashes and generates the following output:


# abiword
*** glibc detected *** abiword: free(): invalid pointer: 0x08949428 ***
======= Backtrace: =========
/lib/libc.so.6[0xb720340e]
/lib/libc.so.6(cfree+0xa9)[0xb7204bdd]
/usr/lib/libglib-2.0.so.0(g_free+0x2c)[0xb770094c]
abiword(_ZN20AP_UnixDialog_Styles14_populateCListEv+0x3a9)[0x848b5b3]
abiword(_ZN20AP_UnixDialog_Styles19_populateWindowDataEv+0x11)[0x848b5dd]
abiword(_ZN20AP_UnixDialog_Styles8runModalEP9XAP_Frame+0x28a)[0x848c41a]
abiword[0x817ffdf]
abiword(_ZN14ap_EditMethods8dlgStyleEP7AV_ViewP21EV_EditMethodCallData+0x58)[0x8187592]
abiword(_ZNK13EV_EditMethod2FnEP7AV_ViewP21EV_EditMethodCallData+0x21)[0x830a499]
abiword(_ZN7EV_Menu16invokeMenuMethodEP7AV_ViewP13EV_EditMethodRK9UT_String+0x87)[0x830e8e3]
abiword(_ZN11EV_UnixMenu9menuEventEi+0xbd)[0x8310d9d]
abiword(_ZN3_wd12s_onActivateEP10_GtkWidgetPv+0x21)[0x831362d]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x4d)[0xb778aebd]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x13c)[0xb777df3c]
/usr/lib/libgobject-2.0.so.0[0xb779257a]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x8fa)[0xb779434a]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x1e)[0xb77946be]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_activate+0x4b)[0xb7d3338b]
/usr/lib/libgtk-x11-2.0.so.0(gtk_menu_shell_activate_item+0x191)[0xb7c3e761]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c3ffaa]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c3782e]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c31a3c]
/usr/lib/libgobject-2.0.so.0[0xb777c818]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x13c)[0xb777df3c]
/usr/lib/libgobject-2.0.so.0[0xb7792a65]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x611)[0xb7794061]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x1e)[0xb77946be]
/usr/lib/libgtk-x11-2.0.so.0[0xb7d2d788]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0xdb)[0xb7c2b05b]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x2f5)[0xb7c2c395]
/usr/lib/libgdk-x11-2.0.so.0[0xb79f368a]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x17c)[0xb76f89fc]
/usr/lib/libglib-2.0.so.0[0xb76fc04f]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a8)[0xb76fc3b8]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb9)[0xb7c2c819]
abiword(_ZN10AP_UnixApp4mainEPKciPS1_+0x295)[0x8170221]
abiword(main+0x23)[0x816c88b]
/lib/libc.so.6(__libc_start_main+0x12e)[0xb71c620e]
abiword[0x816c7f1]
======= Memory map: ========
08048000-0866e000 r-xp 00000000 00:0e 8442 /usr/bin/abiword
0866e000-086cf000 rwxp 00625000 00:0e 8442 /usr/bin/abiword
086cf000-08b91000 rwxp 00000000 00:00 0 [heap]
b6b00000-b6b21000 rwxp 00000000 00:00 0
b6b21000-b6c00000 ---p 00000000 00:00 0
b6c01000-b6c75000 r-xp 00000000 00:0e 7696 /usr/share/fonts/default/TTF/DejaVuSans-Bold.ttf
b6c75000-b6cd5000 rwxs 00000000 00:08 1703944 /SYSV00000000 (deleted)
b6cd5000-b6cd8000 r-xp 00000000 00:0e 2098 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b6cd8000-b6cd9000 rwxp 00003000 00:0e 2098 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b6cda000-b6ced000 r-xp 00000000 00:0e 7717 /usr/share/fonts/default/Type1/n019043l.pfb
b6ced000-b6d08000 r-xp 00000000 00:0e 7725 /usr/share/fonts/default/Type1/n021003l.pfb
b6d08000-b6d18000 r-xp 00000000 00:0e 2025 /usr/share/icons/hicolor/icon-theme.cache
b6d18000-b6d78000 rwxs 00000000 00:08 1671175 /SYSV00000000 (deleted)
b6d78000-b6e7c000 rwxp 00000000 00:00 0
b6e7c000-b6ef7000 r-xp 00000000 00:0e 7700 /usr/share/fonts/default/TTF/DejaVuSans.ttf
b6ef7000-b6ef9000 r-xp 00000000 00:0e 4250 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b6ef9000-b6efa000 rwxp 00001000 00:0e 4250 /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
b6efa000-b6f0d000 r-xp 00000000 00:0e 7717 /usr/share/fonts/default/Type1/n019043l.pfb
b6f0d000-b6f14000 r-xp 00000000 00:0e 4029 /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so
b6f14000-b6f15000 rwxp 00006000 00:0e 4029 /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so
b6f15000-b6f19000 r-xp 00000000 00:0e 3725 /usr/lib/abiword-2.6/plugins/libAbiBMP.so
b6f19000-b6f1a000 rwxp 00003000 00:0e 3725 /usr/lib/abiword-2.6/plugins/libAbiBMP.so
b6f1a000-b6f1d000 r-xp 00000000 00:0e 3727 /usr/lib/abiword-2.6/plugins/libAbiFreeTranslation.so
b6f1d000-b6f1e000 rwxp 00002000 00:0e 3727 /usr/lib/abiword-2.6/plugins/libAbiFreeTranslation.so
b6f1e000-b6f20000 r-xp 00000000 00:0e 3729 /usr/lib/abiword-2.6/plugins/libAbiGdict.so
b6f20000-b6f21000 rwxp 00001000 00:0e 3729 /usr/lib/abiword-2.6/plugins/libAbiGdict.so
b6f21000-b6f4f000 r-xp 00000000 00:0e 3586 /usr/lib/liblink-grammar.so.4.6.1
b6f4f000-b6f50000 rwxp 0002e000 00:0e 3586 /usr/lib/liblink-grammar.so.4.6.1
b6f50000-b6f60000 rwxp 00000000 00:00 0
b6f60000-b6f66000 r-xp 00000000 00:0e 3731 /usr/lib/abiword-2.6/plugins/libAbiGrammar.so
b6f66000-b6f67000 rwxp 00005000 00:0e 3731 /usr/lib/abiword-2.6/plugins/libAbiGrammar.so
b6f67000-b6f7f000 r-xp 00000000 00:0e 3581 /usr/lib/libjpeg.so.62.0.0
b6f7f000-b6f80000 rwxp 00017000 00:0e 3581 /usr/lib/libjpeg.so.62.0.0
b6f80000-b6f83000 r-xp 00000000 00:0e 3733 /usr/lib/abiword-2.6/plugins/libAbiJPEG.so
b6f83000-b6f84000 rwxp 00002000 00:0e 3733 /usr/lib/abiword-2.6/plugins/libAbiJPEG.so
b6f84000-b6f89000 r-xp 00000000 00:0e 3735 /usr/lib/abiword-2.6/plugins/libAbiMSWrite.so
b6f89000-b6f8a000 rwxp 00005000 00:0e 3735 /usr/lib/abiword-2.6/plugins/libAbiMSWrite.so
b6f8a000-b6ffc000 r-xp 00000000 00:0e 3737 /usr/lib/abiword-2.6/plugins/libAbiOpenDocument.so
b6ffc000-b6ffe000 rwxp 00072000 00:0e 3737 /usr/lib/abiword-2.6/plugins/libAbiOpenDocument.so
b6ffe000-b701d000 r-xp 00000000 00:0e 3739 /usr/lib/abiword-2.6/plugins/libAbiOpenWriter.so
b701d000-b701e000 rwxp 0001f000 00:0e 3739 /usr/lib/abiword-2.6/plugins/libAbiOpenWriter.so
b701e000-b7021000 r-xp 00000000 00:0e 3741 /usr/lib/abiword-2.6/plugins/libAbiPDF.so
b7021000-b7022000 rwxp 00002000 00:0e 3741 /usr/lib/abiword-2.6/plugins/libAbiPDF.so
b7022000-b7051000 r-xp 00000000 00:0e 3642 /usr/lib/librsvg-2.so.2.22.3
b7051000-b7052000 rwxp 0002f000 00:0e 3642 /usr/lib/librsvg-2.so.2.22.3
b7052000-b7055000 r-xp 00000000 00:0e 3743 /usr/lib/abiword-2.6/plugins/libAbiRSVG.so
b7055000-b7056000 rwxp 00002000 00:0e 3743 /usr/lib/abiword-2.6/plugins/libAbiRSVG.so
b7056000-b7057000 r-xp 00000000 00:0e 3745 /usr/lib/abiword-2.6/plugins/libAbiXHTML.so
b7057000-b7058000 rwxp 00000000 00:0e 3745 /usr/lib/abiword-2.6/plugins/libAbiXHTML.so
b7058000-b7062000 r-xp 00000000 00:0e 3747 /usr/lib/abiword-2.6/plugins/libLoadBindings.so
b7062000-b7063000 rwxp 00009000 00:0e 3747 /usr/lib/abiword-2.6/plugins/libLoadBindings.so
b7063000-b706e000 r-xp 00000000 00:0e 3440 /usr/lib/libbz2.so.1.0.4
b706e000-b706f000 rwxp 0000b000 00:0e 3440 /usr/lib/libbz2.so.1.0.4
b706f000-b7073000 r-xp 00000000 00:0e 3749 /usr/lib/abiword-2.6/plugins/libPresentation.so
b7073000-b7074000 rwxp 00004000 00:0e 3749 /usr/lib/abiword-2.6/plugins/libPresentation.so
b7074000-b707a000 r-xp 00000000 00:0e 4056 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
b707a000-b707b000 rwxp 00005000 00:0e 4056 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so
b707b000-b707d000 r-xp 00000000 00:0e 3827 /usr/lib/gconv/CP1252.so
b707d000-b707f000 rwxp 00001000 00:0e 3827 /usr/lib/gconv/CP1252.so
b707f000-b7080000 r-xp 00000000 00:0e 3066 /usr/lib/gconv/ISO8859-1.so
b7080000-b7082000 rwxp 00000000 00:0e 3066 /usr/lib/gconv/ISO8859-1.so
b7082000-b7089000 r-xp 00000000 00:0e 2535 /lib/libnss_files-2.6.1.so
b7089000-b708b000 rwxp 00006000 00:0e 2535 /lib/libnss_files-2.6.1.so
b708b000-b70c1000 r-xp 00000000 00:0e 3051 /usr/lib/locale/de_DE/LC_CTYPE
b70c1000-b70c2000 r-xp 00000000 00:0e 3052 /usr/lib/locale/de_DE/LC_NUMERIC
b70c2000-b70c3000 r-xp 00000000 00:0e 3053 /usr/lib/locale/de_DE/LC_TIME
b70c3000-b70c8000 r-xp 00000000 00:0e 3018 /usr/lib/locale/en_US/LC_COLLATE
b70c8000-b70c9000 r-xp 00000000 00:0e 3055 /usr/lib/locale/de_DE/LC_MONETARY
b70c9000-b70ca000 r-xp 00000000 00:0e 3057 /usr/lib/locale/de_DE/LC_MESSAGES/SYS_LC_MESSAGES
b70ca000-b70cb000 r-xp 00000000 00:0e 3058 /usr/lib/locale/de_DE/LC_PAPER
b70cb000-b70cc000 r-xp 00000000 00:0e 3059 /usr/lib/locale/de_DE/LC_NAME
b70cc000-b70cd000 r-xp 00000000 00:0e 3060 /usr/lib/locale/de_DE/LC_ADDRESS
b70cd000-b70ce000 r-xp 00000000 00:0e 3061 /usr/lib/locale/de_DE/LC_TELEPHONE
b70ce000-b70cf000 r-xp 00000000 00:0e 3062 /usr/lib/locale/de_DE/LC_MEASUREMENT
b70cf000-b70d0000 r-xp 00000000 00:0e 3063 /usr/lib/locale/de_DE/LC_IDENTIFICATION
b70d0000-b70d4000 r-xs 00000000 00:0e 7855 /var/cache/fontconfig/b79f3aaa7d385a141ab53ec885cc22a8-x86.cache-2
b70d4000-b70d6000 r-xs 00000000 00:0e 7854 /var/cache/fontconfig/02ee123a0860abc6ceda00dd4ed59b79-x86.cache-2
b70d6000-b70e8000 r-xs 00000000 00:0e 7853 /var/cache/fontconfig/fde37821cbdb1159b4eac7aa64d92051-x86.cache-2
b70e8000-b70ec000 r-xs 00000000 00:0e 7745 /var/cache/fontconfig/dff97e17f0a16753982c22213791434a-x86.cache-2
b70ec000-b70ee000 r-xs 00000000 00:0e 7704 /var/cache/fontconfig/ddbd7b13a6107d9809ee2e9bda1eeb71-x86.cache-2
b70ee000-b70f1000 rwxp 00000000 00:00 0
b70f1000-b70f7000 r-xp 00000000 00:0e 3506 /usr/lib/libgailutil.so.18.0.1
b70f7000-b70f8000 rwxp 00005000 00:0e 3506 /usr/lib/libgailutil.so.18.0.1
b70f8000-b712d000 r-xp 00000000 00:0e 3624 /usr/lib/libpixman-1.so.0.12.0
b712d000-b712e000 rwxp 00035000 00:0e 3624 /usr/lib/libpixman-1.so.0.12.0
b712e000-b7148000 r-xp 00000000 00:0e 3494 /usr/lib/libexpat.so.1.5.2
b7148000-b714a000 rwxp 00019000 00:0e 3494 /usr/lib/libexpat.so.1.5.2
b714a000-b7178000 r-xp 00000000 00:0e 2018 /usr/lib/libpcre.so.0.0.1
b7178000-b7179000 rwxp 0002d000 00:0e 2018 /usr/lib/libpcre.so.0.0.1
b7179000-b717a000 rwxp 00000000 00:00 0
b717a000-b7181000 r-xp 00000000 00:0e 7264 /usr/X11R7/lib/libXcursor.so.1.0.2
b7181000-b7182000 rwxp 00006000 00:0e 7264 /usr/X11R7/lib/libXcursor.so.1.0.2
b7182000-b7187000 r-xp 00000000 00:0e 7262 /usr/X11R7/lib/libXrandr.so.2.1.0
b7187000-b7188000 rwxp 00004000 00:0e 7262 /usr/X11R7/lib/libXrandr.so.2.1.0
b7188000-b718a000 r-xp 00000000 00:0e 7260 /usr/X11R7/lib/libXinerama.so.1.0.0
b718a000-b718b000 rwxp 00001000 00:0e 7260 /usr/X11R7/lib/libXinerama.so.1.0.0
b718b000-b7196000 r-xp 00000000 00:0e 7229 /usr/X11R7/lib/libXext.so.6.4.0
b7196000-b7197000 rwxp 0000a000 00:0e 7229 /usr/X11R7/lib/libXext.so.6.4.0
b7197000-b719e000 r-xp 00000000 00:0e 7256 /usr/X11R7/lib/libXi.so.6.0.0
b719e000-b719f000 rwxp 00006000 00:0e 7256 /usr/X11R7/lib/libXi.so.6.0.0
b719f000-b71a0000 rwxp 00000000 00:00 0
b71a0000-b71a3000 r-xp 00000000 00:0e 7252 /usr/X11R7/lib/libXfixes.so.3.1.0
b71a3000-b71a4000 rwxp 00003000 00:0e 7252 /usr/X11R7/lib/libXfixes.so.3.1.0
b71a4000-b71a6000 r-xp 00000000 00:0e 1986 /lib/libdl-2.6.1.so
b71a6000-b71a8000 rwxp 00001000 00:0e 1986 /lib/libdl-2.6.1.so
b71a8000-b71ac000 r-xp 00000000 00:0e 3395 /usr/X11R7/lib/libXdmcp.so.6.0.0
b71ac000-b71ad000 rwxp 00003000 00:0e 3395 /usr/X11R7/lib/libXdmcp.so.6.0.0
b71ad000-b71af000 r-xp 00000000 00:0e 3391 /usr/X11R7/lib/libXau.so.6.0.0
b71af000-b71b0000 rwxp 00001000 00:0e 3391 /usr/X11R7/lib/libXau.so.6.0.0
b71b0000-b72a5000 r-xp 00000000 00:0e 49 /lib/libc-2.6.1.so
b72a5000-b72a6000 r-xp 000f5000 00:0e 49 /lib/libc-2.6.1.so
b72a6000-b72a8000 rwxp 000f6000 00:0e 49 /lib/libc-2.6.1.so
b72a8000-b72ac000 rwxp 00000000 00:00 0
b72ac000-b72bd000 r-xp 00000000 00:0e 2003 /lib/libpthread-2.6.1.so
b72bd000-b72bf000 rwxp 00010000 00:0e 2003 /lib/libpthread-2.6.1.so
b72bf000-b72c1000 rwxp 00000000 00:00 0
b72c1000-b72cb000 r-xp 00000000 00:0e 3509 /usr/lib/libgcc_s.so.1
b72cb000-b72cc000 rwxp 00009000 00:0e 3509 /usr/lib/libgcc_s.so.1
b72cc000-b73a8000 r-xp 00000000 00:0e 3670 /usr/lib/libstdc++.so.6.0.9
b73a8000-b73ac000 r-xp 000db000 00:0e 3670 /usr/lib/libstdc++.so.6.0.9
b73ac000-b73ad000 rwxp 000df000 00:0e 3670 /usr/lib/libstdc++.so.6.0.9
b73ad000-b73b3000 rwxp 00000000 00:00 0
b73b3000-b7494000 r-xp 00000000 00:0e 3540 /usr/lib/libgoffice-0.6.so.6.0.3
b7494000-b749c000 rwxp 000e0000 00:0e 3540 /usr/lib/libgoffice-0.6.so.6.0.3
b749c000-b749d000 rwxp 00000000 00:00 0
b749d000-b74a4000 r-xp 00000000 00:0e 2001 /lib/librt-2.6.1.so
b74a4000-b74a6000 rwxp 00006000 00:0e 2001 /lib/librt-2.6.1.so
b74a6000-b74b0000 rwxp 00000000 00:00 0
b74b0000-b74b3000 r-xp 00000000 00:0e 3555 /usr/lib/libgthread-2.0.so.0.1800.3
b74b3000-b74b4000 rwxp 00003000 00:0e 3555 /usr/lib/libgthread-2.0.so.0.1800.3
b74b4000-b74b5000 rwxp 00000000 00:00 0
b74b5000-b74bb000 r-xp 00000000 00:0e 3636 /usr/lib/libpopt.so.0.0.0
b74bb000-b74bc000 rwxp 00005000 00:0e 3636 /usr/lib/libpopt.so.0.0.0
b74bc000-b74ee000 r-xp 00000000 00:0e 3553 /usr/lib/libgsf-1.so.114.0.7
b74ee000-b74f1000 rwxp 00032000 00:0e 3553 /usr/lib/libgsf-1.so.114.0.7
b74f1000-b74f2000 rwxp 00000000 00:00 0
b74f2000-b7512000 r-xp 00000000 00:0e 2020 /lib/libm-2.6.1.so
b7512000-b7514000 rwxp 00020000 00:0e 2020 /lib/libm-2.6.1.so
b7514000-b7536000 r-xp 00000000 00:0e 2100 /usr/lib/libpng12.so.0.22.0
b7536000-b7537000 rwxp 00021000 00:0e 2100 /usr/lib/libpng12.so.0.22.0
b7537000-b757c000 r-xp 00000000 00:0e 3698 /usr/lib/libwv-1.2.so.4.0.1
b757c000-b757e000 rwxp 00045000 00:0e 3698 /usr/lib/libwv-1.2.so.4.0.1
b757e000-b75b0000 rwxp 00000000 00:00 0
b75b0000-b75bd000 r-xp 00000000 00:0e 3502 /usr/lib/libfribidi.so.0.0.0
b75bd000-b75be000 rwxp 0000c000 00:0e 3502 /usr/lib/libfribidi.so.0.0.0
b75be000-b75bf000 rwxp 00000000 00:00 0
b75bf000-b75c5000 r-xp 00000000 00:0e 3484 /usr/lib/libenchant.so.1.3.0
b75c5000-b75c6000 rwxp 00005000 00:0e 3484 /usr/lib/libenchant.so.1.3.0
b75c6000-b75db000 r-xp 00000000 00:0e 3427 /usr/lib/libart_lgpl_2.so.2.3.20
b75db000-b75dc000 rwxp 00015000 00:0e 3427 /usr/lib/libart_lgpl_2.so.2.3.20
b75dc000-b7608000 r-xp 00000000 00:0e 3531 /usr/lib/libgnomecanvas-2.so.0.2001.0
b7608000-b7609000 rwxp 0002c000 00:0e 3531 /usr/lib/libgnomecanvas-2.so.0.2001.0
b7609000-b766b000 r-xp 00000000 00:0e 3536 /usr/lib/libgnomeprint-2-2.so.0.1.0
b766b000-b766d000 rwxp 00061000 00:0e 3536 /usr/lib/libgnomeprint-2-2.so.0.1.0
b766d000-b76a6000 r-xp 00000000 00:0e 3538 /usr/lib/libgnomeprintui-2-2.so.0.1.0
b76a6000-b76a8000 rwxp 00038000 00:0e 3538 /usr/lib/libgnomeprintui-2-2.so.0.1.0
b76a8000-b76a9000 rwxp 00000000 00:00 0
b76a9000-b76ba000 r-xp 00000000 00:0e 7248 /usr/X11R7/lib/libICE.so.6.3.0
b76ba000-b76bc000 rwxp 00010000 00:0e 7248 /usr/X11R7/lib/libICE.so.6.3.0
b76bc000-b76bd000 rwxp 00000000 00:00 0
b76bd000-b76c3000 r-xp 00000000 00:0e 7250 /usr/X11R7/lib/libSM.so.6.0.0
b76c3000-b76c4000 rwxp 00005000 00:0e 7250 /usr/X11R7/lib/libSM.so.6.0.0
b76c4000-b7771000 r-xp 00000000 00:0e 2016 /usr/lib/libglib-2.0.so.0.1800.3
b7771000-b7772000 rwxp 000ad000 00:0e 2016 /usr/lib/libglib-2.0.so.0.1800.3
b7772000-b7774000 r-xp 00000000 00:0e 2014 /usr/lib/libgmodule-2.0.so.0.1800.3
b7774000-b7775000 rwxp 00002000 00:0e 2014 /usr/lib/libgmodule-2.0.so.0.1800.3
b7775000-b77ae000 r-xp 00000000 00:0e 2012 /usr/lib/libgobject-2.0.so.0.1800.3
b77ae000-b77af000 rwxp 00039000 00:0e 2012 /usr/lib/libgobject-2.0.so.0.1800.3
b77af000-b77cd000 r-xp 00000000 00:0e 7254 /usr/X11R7/lib/libfontconfig.so.1.2.0
b77cd000-b77d5000 rwxp 0001e000 00:0e 7254 /usr/X11R7/lib/libfontconfig.so.1.2.0
b77d5000-b77d6000 rwxp 00000000 00:00 0
b77d6000-b77e4000 r-xp 00000000 00:0e 2102 /lib/libz.so.1.2.3
b77e4000-b77e5000 rwxp 0000e000 00:0e 2102 /lib/libz.so.1.2.3
b77e5000-b7840000 r-xp 00000000 00:0e 3397 /usr/lib/libfreetype.so.6.3.16
b7840000-b7843000 rwxp 0005a000 00:0e 3397 /usr/lib/libfreetype.so.6.3.16
b7843000-b7880000 r-xp 00000000 00:0e 3607 /usr/lib/libpango-1.0.so.0.2203.0
b7880000-b7882000 rwxp 0003c000 00:0e 3607 /usr/lib/libpango-1.0.so.0.2203.0
b7882000-b78e9000 r-xp 00000000 00:0e 3442 /usr/lib/libcairo.so.2.10800.6
b78e9000-b78eb000 rwxp 00067000 00:0e 3442 /usr/lib/libcairo.so.2.10800.6
b78eb000-b78f4000 r-xp 00000000 00:0e 3609 /usr/lib/libpangocairo-1.0.so.0.2203.0
b78f4000-b78f5000 rwxp 00008000 00:0e 3609 /usr/lib/libpangocairo-1.0.so.0.2203.0
b78f5000-b790b000 r-xp 00000000 00:0e 2008 /usr/lib/libgdk_pixbuf-2.0.so.0.1400.7
b790b000-b790c000 rwxp 00016000 00:0e 2008 /usr/lib/libgdk_pixbuf-2.0.so.0.1400.7
b790c000-b790d000 rwxp 00000000 00:00 0
b790d000-b7935000 r-xp 00000000 00:0e 3611 /usr/lib/libpangoft2-1.0.so.0.2203.0
b7935000-b7936000 rwxp 00027000 00:0e 3611 /usr/lib/libpangoft2-1.0.so.0.2203.0
b7936000-b7994000 r-xp 00000000 00:0e 2010 /usr/lib/libgio-2.0.so.0.1800.3
b7994000-b7996000 rwxp 0005e000 00:0e 2010 /usr/lib/libgio-2.0.so.0.1800.3
b7996000-b79ad000 r-xp 00000000 00:0e 3429 /usr/lib/libatk-1.0.so.0.2409.1
b79ad000-b79af000 rwxp 00016000 00:0e 3429 /usr/lib/libatk-1.0.so.0.2409.1
b79af000-b7a30000 r-xp 00000000 00:0e 3515 /usr/lib/libgdk-x11-2.0.so.0.1400.7
b7a30000-b7a33000 rwxp 00080000 00:0e 3515 /usr/lib/libgdk-x11-2.0.so.0.1400.7
b7a33000-b7b1a000 r-xp 00000000 00:0e 3705 /usr/lib/libxml2.so.2.6.30
b7b1a000-b7b1f000 rwxp 000e6000 00:0e 3705 /usr/lib/libxml2.so.2.6.30
b7b1f000-b7b20000 rwxp 00000000 00:00 0
b7b20000-b7e6b000 r-xp 00000000 00:0e 3557 /usr/lib/libgtk-x11-2.0.so.0.1400.7
b7e6b000-b7e71000 rwxp 0034b000 00:0e 3557 /usr/lib/libgtk-x11-2.0.so.0.1400.7
b7e71000-b7e74000 rwxp 00000000 00:00 0
b7e74000-b7e86000 r-xp 00000000 00:0e 3527 /usr/lib/libglade-2.0.so.0.0.7
b7e86000-b7e87000 rwxp 00011000 00:0e 3527 /usr/lib/libglade-2.0.so.0.0.7
b7e87000-b7f54000 r-xp 00000000 00:0e 7172 /usr/X11R7/lib/libX11.so.6.2.0
b7f54000-b7f58000 rwxp 000cc000 00:0e 7172 /usr/X11R7/lib/libX11.so.6.2.0
b7f58000-b7f5e000 r-xp 00000000 00:0e 7258 /usr/X11R7/lib/libXrender.so.1.3.0
b7f5e000-b7f5f000 rwxp 00006000 00:0e 7258 /usr/X11R7/lib/libXrender.so.1.3.0
b7f5f000-b7f6d000 r-xp 00000000 00:0e 7328 /usr/X11R7/lib/libXft.so.2.1.2
b7f6d000-b7f6e000 rwxp 0000d000 00:0e 7328 /usr/X11R7/lib/libXft.so.2.1.2
b7f6e000-b7f74000 r-xp 00000000 00:0e 3615 /usr/lib/libpangoxft-1.0.so.0.2203.0
b7f74000-b7f75000 rwxp 00005000 00:0e 3615 /usr/lib/libpangoxft-1.0.so.0.2203.0
b7f75000-b7f76000 rwxp 00000000 00:00 0
b7f76000-b7f8b000 r-xp 00000000 00:0e 45 /lib/ld-2.6.1.so
b7f8b000-b7f8d000 rwxp 00014000 00:0e 45 /lib/ld-2.6.1.so
bffaf000-bffc4000 rw-p 00000000 00:00 0 [stack]
ffffe000-fffff000 r-xp 00000000 00:00 0 [vdso]
Aborted


thanks
Jens
Back to top
View user's profile Send private message 
mcalex

Joined: 23 Apr 2006
Posts: 78
Location: Perth, WA

PostPosted: Mon 12 Oct 2009, 08:43    Post subject:  
Subject description: unbug
 

... and i'm typing in the box and i keep hitting the insert key and for the life of me i just can't get the browser to crash.

woot!
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Mon 12 Oct 2009, 09:29    Post subject: Re: CD or DVD drive icons on desktop
Subject description: icons show up on top of other icons when disc is mounted
 

bigpup wrote:
When disc is loaded into drive and mounted, the drive icon is displayed on the desktop, but it is placed over other drive icons.

we know that issue occurs at some screen size.
the 4.30 japanese edition has the code to fix.

/sbin/pup_event_frontend_d at line 135-
Code:
free_coord() {
 #find a free place on desktop. v410 avoid exact overlapping icons...
 COORDSGRID="`grep -o ' x="[0-9]*" y="[0-9]*" ' /root/Choices/ROX-Filer/PuppyPin | sed 's/[0-9]"/"/g'`"
 COORD_Y=`expr $SCRN_Y - 64`
 # import from v4.20p1JP 5Jun09, 18aug09 by Masaki Shinomiya : snap on the grid
 PIN_GRID_STEP=`grep "pinboard_grid_step" $HOME/.config/rox.sourceforge.net/ROX-Filer/Options | sed -e "s/ *<[^>]*>//g"`
 if [ "$PIN_GRID_STEP" ] && [ $PIN_GRID_STEP -gt 0 ];then
    PIN_GRID_STEP2=`expr $PIN_GRID_STEP / 2`
   COORD_Y=`expr \( $COORD_Y + $PIN_GRID_STEP2 \) / $PIN_GRID_STEP '*'  $PIN_GRID_STEP`
 fi
 
 COORD_X=32
 MAX_X=`expr $SCRN_X - 96`
 xPATTERN=" x=\"${COORD_X}\" y=\"${COORD_Y}\" "
 while [ 1 ];do
  xgPATTERN="`echo -n "$xPATTERN" |  sed 's/[0-9]"/"/g'`"
  [ "`echo "$COORDSGRID" | grep "$xgPATTERN"`" = "" ] && break
  COORD_X=`expr $COORD_X + 64`
  xPATTERN=" x=\"${COORD_X}\" y=\"${COORD_Y}\" "
  [ $COORD_X -gt $MAX_X ] && break
 done
}
Back to top
View user's profile Send private message Visit poster's website 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Mon 12 Oct 2009, 09:50    Post subject: Preliminary gxine, geany, and shutdown issues  

Since Barry is speeding through all the repars, I feel I should report my early issues and spend the day getting the details. Testing on my Aptiva K6-2 400 MHz, 256 MB-RAM PC with a dubious CD writer.

1. Installs CS 4236 sound driver, but I get no sound. I am not pursuing this right now because it is the same in 430.

2. Gxine, however, behaves differently from 430, where it appears to play a CD from the "play" icon. In 431, everything I try with gxine results in an error message about something not available. Also tried BBC and CSPAN unsuccessfully.
Quote:
File > CD:
Autoplay input plugin ‘CD’ failed
Check engine output for further details

AFD changed from -2 to -1
CDROMREADTOCENTRY: Input/output error
xine-lib: error: Autoplay input plugin 'CD' failed: Check engine output for further details.
AFD changed from -2 to -1


Media > News & Talk > BBC World Service:
The xine engine failed to start.
No demuxer found - stream format not recognised.

Media > News & Talk > CSPAN Radio:
Unknown host:
unable to resolve wms-rbn-sea03.rbn.com
(and...)
The xine engine failed to start.
No input plugin was found.
Maybe the file does not exist or cannot be accessed, or there is an error in the URL.


Media > TV > NASA TV:
Gxine locked up and had to be killed. Cannot restart it because it thinks an instance is already running.
The TV lockup might be because of the 400MHZ CPU. Attempted to copy the error text, but...

3. After pasting gxine's error text into a new document in geany, when attempting to save the document, geany pops up a message about a problem related to utf-something and locks up, necessitating killing it. (I used nicoedit to collect the above.) It may be reelated to the backtick:
Quote:
An error occurred while converting the file from UTF-8 in "ISO-8859-1". The file remains unsaved.
Error message: Invalid byte sequence in conversion input
The error occurred at "‘" (line: 1, column: 22).

The text:
Autoplay input plugin ‘CD’ failed
Check engine output for further details


4. I am using the INTEL-MODEMS iso (naturally), although only a Lucent modem is installed at the moment. When I shut down, a bunch of diagnostic data scrolls on the screen. The error is a kernel NULL pointer dereference. I attach screen shots of the error messages. I have isolated the problem: No problem occurs if I reply "no" to the alsawizard's request to update modprobe.conf -- it terminates at that point. Answering "yes" triggers the problem. So it is the new innocent-looking modprobe.conf entries that upset shutdown. The call-trace attachment pins it down. But I do not know what to do about it. Here is what alsaconf inserts into modprobe.conf, including misidentifying itself as alsa 1.0.16 -- does alsaconf need to be updated for 1.0.20?
Code:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.16 ---
alias snd-card-0 snd-cs4236
alias sound-slot-0 snd-cs4236
# --- END: Generated by ALSACONF, do not edit. ---


5. While trying to get sound going, I discovered the little volume control panel from right-clicking next to blinky. I could drag all of the sliders in it except for the Master. It is all the way down and refuses to be dragged, so maybe that is what is preventing me from hearing sound.

6. More on playing a CD: On my fastest (2.4MHz) NetVista PC with sound that "just works", gxine behaves in the same way from the icon, including lock-up on some media selections. But clicking on the CD drive icon, gxine started and played automatically. However, it stopped at the end of the first track and gives no indication of how play all tracks, or even the next. pCD to the rescue! It seems to do everything right, except that its display of the playing title does not change from the title of track 1. On my 2 test CDs, the titles are simply "Track1," "Track2," etc., and the author and album fields are "unknown".

The Lucent modem and ethernet work fine.
Richard
call_trace_screen_shot.JPG
 Description   Call trace at shutdown
 Filesize   129.21 KB
 Viewed   464 Time(s)

call_trace_screen_shot.JPG

shutdown_error_screen_shot.JPG
 Description   Screen image of problem at shutdown.
 Filesize   139.09 KB
 Viewed   467 Time(s)

shutdown_error_screen_shot.JPG


Last edited by rerwin on Mon 12 Oct 2009, 16:12; edited 7 times in total
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Mon 12 Oct 2009, 11:28    Post subject:  

Yes, the grammar checker in Abiword is the problem. The spell checker seems OK. Barry, I'd change that default back if I were you. I'm far less impressed at having grammar checked without my asking for it, than that it takes 20 seconds for me to be able to move the scroll bar or do anything else.

Anyway, some folks don't need their grammar checked! Smile

Quote:
I discovered the little volume control panel from clicking next to blinky.


Huh? I don't see anything like that. Just the single slider...

I can verify that Abiword crash Jens mentions above.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1015
Location: South of Belgium

PostPosted: Mon 12 Oct 2009, 11:33    Post subject:
Subject description: abiword crash upon Format/Create Style..
 

Hi jens!
Quote:
Abiword from the console and select 'Format' -> 'Create and modify Styles...', it crashes and generates the following output:

I got the same...!
cheers
Back to top
View user's profile Send private message 
r__hughes

Joined: 13 Apr 2006
Posts: 343
Location: Canada

PostPosted: Mon 12 Oct 2009, 11:53    Post subject: geany will compile & build but NOT run a C program  

Pup431 now has all the main features I want Smile Thank you for reinstating a basic but much appreciated partview. I am using transformed OpenOffice-3.0.sfs with java & all is AOK Smile

In pup431 (like all 4.2+) geany has a problem being a C-program runtime-environment - It will compile & build but NOT run a c-program

Solution is to edit the geany preferences
edit/preferences/Tools/Terminal/ to read
Quote:
/usr/X11R7/bin/xterm -e bash -c

_________________
--- quad booting pup431, Slacko55PAE, Slacko56NPAE (with OO3/LO4, devx, Gimp) & WXP on DELL Dimension 2400 PC & DELL Latitude 630 Laptop using grub.
---USB-Flash booting same on Samsung N110 WXP Netbook and Lenovo q100 WXP netPC.
Back to top
View user's profile Send private message 
gyro

Joined: 28 Oct 2008
Posts: 479
Location: Brisbane, Australia

PostPosted: Mon 12 Oct 2009, 11:55    Post subject: wasted loop devices - suggesed fix  

Clean frugal install of files from pup-431.iso on NTFS partition.

Problem, "init" script in "initrd.gz" still has problem with loading extra sfs files.
1) If 2 sfs files differ only by one ending in ".sfs" and one ending in "-sfs4.sfs", it attempts to mount both.
2) It mounts sfs files in alphabetical order, not in order specified in BootManager.
See my second post on this subject in pup-430 topic http://www.murga-linux.com/puppy/viewtopic.php?t=46594&start=270

gyro
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Mon 12 Oct 2009, 12:13    Post subject:  

pStopWatch is pretty silly. It only starts counting 3 seconds after you hit the start button. Rolling Eyes

pTimer seems to be a kind of setup for PStopWatch, but it doesn't allow one to make pstopwatch work reasonably. I was amused by the flyover at the start button (grrr!)

I'd get rid of these or at least remove them from the menu. They are lame.

gmeasures is still a joke, extremely limited. Looks like it's been updated, but why do an update without adding more conversion factors? Oh, well, leave it in, as it's harmless.

On the XF-prot thing, you get a red window with some information. It mentions you can click the "OK" button (which is really named "okay"), or click the close box button (which doesn't exist) to abort.

I tried to run fprot, accepting all the defaults in the install script, and got an error, "Cannot detect fprot's version. Aborting..." It probably would be good to make fprot usable without too much finagling. Not sure what that entails...

Despite the nitpicking, this looks like a good solid version. Am thrilled the text now displays cleanly, that was my largest problem with 4.1.2. All the apps I often use look good.
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 12 Oct 2009, 13:52    Post subject:  

PaulBx1 wrote:
pStopWatch is pretty silly. It only starts counting 3 seconds after you hit the start button. Rolling Eyes

pTimer seems to be a kind of setup for PStopWatch, but it doesn't allow one to make pstopwatch work reasonably. I was amused by the flyover at the start button (grrr!)

I'd get rid of these. They are lame.


There's another, more serious problem with these timer apps - they use 100% CPU while there running and cause problems to other apps that are running at the same time.

I'd remove these timer apps and replace them with another (better) solution until Zigbert fixes his mess.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 12 Oct 2009, 13:59    Post subject:  

panzerpuppy wrote:
until Zigbert fixes his mess.


Ouch!

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 12 Oct 2009, 14:12    Post subject:  

There's also a very annoying issue with Pprocess:
Start Pprocess and move the window anywhere you like. Then resize the window. Instead of resizing and staying at the same place, the Pprocess window jumps to the center of the screen automatically.
Back to top
View user's profile Send private message 
ecube


Joined: 11 Jul 2008
Posts: 88
Location: Västerås, Sweden

PostPosted: Mon 12 Oct 2009, 16:06    Post subject: Partview accuracy
Subject description: Partview values seem to differ somewhat from those in Pmount
 

Some of the values shown in Partview seem to differ somewhat from those of Pmount. (More than can be attributed to if 1GB is 10**9 or 2**30 bytes.) cf. pv1.jpg and pv2.jpg.

I feel that information about mounted partitions is sufficient and have put together a small perl script which is sufficient for my needs.
Code:

#! /usr/bin/perl  -w 
# pdff.pl Partition Viewer. 2009-10-12 Ecube
# Usage pdff.pl | sh

open(FH,"df -h|") or die "cannot run command df -h\n";

$i=0;
while(<FH>) {   # process the df -h command
  if(/(sd\w+)/) {
    $part[$i]=$1; @a=split/\s+/; $size[$i]=$a[1];
    $avail[$i]=$a[3]; chop($a[4]); $usepcnt[$i]=$a[4];   
    $i++;
  }
}    close FH;

### design the gtkdialog3 script
print" #! /bin/bash
export MAIN_DIALOG='<window title=\"PartView\"><vbox>\n";

for ($i=0;$i<@part;$i++) {
  $lbl="  $part[$i] $avail[$i] Avail";
  $bar="  Size $size[$i]";
  print"
  <hbox> <text> <label>\"$lbl\"</label> </text>
    <progressbar> <label>\"$bar\"</label>
      <input>echo \"$usepcnt[$i]\"</input>
    </progressbar> </hbox>\n";
  }

print"
 </vbox></window>
'
gtkdialog3 --program=MAIN_DIALOG\n";

The output is shown in pv3.jpg.

If you want to test the script, copy the perl script to a file and call it say pdff.pl. Create a file (say pdff) containing the single line
path/pdff.pl | sh where path is the location where pdff.pl is stored. Remember to give both files execution permission (chmod +x).
Running pdff should open the window of pv3.jpg-

Enjoy
Olov
pv3.jpg
 Description   
 Filesize   14.67 KB
 Viewed   1052 Time(s)

pv3.jpg

pv2.jpg
 Description   
 Filesize   32.89 KB
 Viewed   1028 Time(s)

pv2.jpg

pv1.jpg
 Description   
 Filesize   9.52 KB
 Viewed   1022 Time(s)

pv1.jpg

Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3380
Location: Oregon

PostPosted: Mon 12 Oct 2009, 18:04    Post subject:  

This is just a small thing, but You can mount a floppy by just clicking on the floppy icon.
But....
When you right click on the floppy icon, there is no option to unmount it.
You have to open PMount and unmount it there.
I think the floppy mount/umount should be made to be consistent with
the hard drive and flash drive options on mounting and unmounting.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 7 [93 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1673s ][ Queries: 12 (0.0057s) ][ GZIP on ]