Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 20:40
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
usb alsaconf settings not saved [PARTIALLY SOLVED]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message
jpop12


Joined: 12 Nov 2007
Posts: 21
Location: nashville, tennessee, u.s.

PostPosted: Sat 24 Oct 2009, 15:30    Post_subject:  usb alsaconf settings not saved [PARTIALLY SOLVED]
Sub_title: how can i make these settings permanent?
 

update:

additionally, i tried:
setup - multiple sound card wizard.
here is what is listed:

card 0: VT82xx [HDA VIA VT82xx], device 0: VT1708 Analog [VT1708 Analog]
card 1: default [C-Media USB Audio Device], device 0: USB Audio [USB Audio]

so i choose card 1, and i have audio through my USB audio adapter, but
no control over it- it is not listed in alsa mixer or anywhere else.
a window pops up and says: reboot for changes to take effect.
so i do, and now the usb adapter is the default and is working.

if i run alsaconf again, and choose the usb option
and reboot, alsamixer is back at hda via vt82xx.

-----

Puppy community-

i have a full hard drive install of Puppy 4.3.1
running on an everex gbook laptop.
alsa does not recognize my headphone jack.
i can get around this by using a usb audio adapter
and choosing the "usb-audio override: usb sound device"
option in alsaconf.
the trouble is that when i reboot, the alsaconf
and modprobe settings are not saved.
(i tried a frugal install and encountered the same problem.)

here is what modprobe looks like after startup:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.20 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---

alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio

here is what alsamixer looks like after startup:

card: hda via vt82xx
chip: via vt1708

here is what modprobe looks like after running
"usb-audio override: usb sound device" in alsaconf:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.20 ---
alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio
# --- END: Generated by ALSACONF, do not edit. ---

here is what alsamixer looks like after running
"usb-audio override: usb sound device" in alsaconf:

card: c-media usb audio device
chip: usb mixer

i tried following the info offered by Patriot
and ended up killing alsa:
http://www.murga-linux.com/puppy/viewtopic.php?t=45326

any ideas on how to make my usb settings permanent?
many thanks.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0428s ][ Queries: 11 (0.0074s) ][ GZIP on ]