Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 22:27
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
How to enable DRI support?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Wed 04 Nov 2009, 23:19    Post subject:  How to enable DRI support?  

hi everybody and sorry 4 my bad english. first at all i used molinux zero 1.0 but hes based is puppy linux i cant give the exactly information cuz im new using it my computer is a acer aspire 5050 the os run pretty sweet is a good distribtuion and dats the only problem tha i have right , the question is how can i enable DRI support so i can play some games like open arena and urba terror....
Back to top
View user's profile Send private message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Thu 05 Nov 2009, 02:15    Post subject:  

Go to the PPM and install the xorg_full_dri pkg. then re-run xorgwizard. go to /etc/X11/xorg.conf and uncomment the Option DRI line. then restart X and you should be good to go.
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 15:33    Post subject: Delete  

im confuse should i delete this line

# This loads dri module (if present)
Load "dri"
Back to top
View user's profile Send private message 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 16:14    Post subject:  

im really confused my friend i cant get dri working
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Thu 05 Nov 2009, 17:04    Post subject:  

@ LordAllucard

Hondasid is trying to say:

Quote:

1. Go the menu, and then setup-Puppy Package Manager. Click on the button that says "PET". Scroll down the the screen that pops up and look for "xorg_full_dri pkg". Click on it and it should install.

2. Make sure all you windows and programs are closed and press ctrl, alt and backspace keys all at once. At the prompt, type:

Code:
xorgwizard


Follow the prompts answering as you see fit.

3. Go to menu-utility-rxvt, and type:

Code:
geany /etc/X11/xorg.conf


Look for this line:

Code:
# This loads dri module (if present)
    Load       "dri"


If this line:

Load "dri"

has no # in front of it, it is uncommented and you don't need to do anything. If there is a # in front of the "Load DRI line" just delete the #.

4. Press the ctrl, alt and backspace keys again and this time type "xwin" into the prompt. Then, you should be good to go. Smile



Hope it helps. I haven't actually tried this method before, but I think it's what Hondasid is suggesting.

@ Hondasid

Hope you don't mind me butting in mate Confused Smile

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 17:33    Post subject:  

i did what u say but now X doesnt start it say>
parse error on line 31 of section module in file /etc/x11/xorg.conf
"this" is not a valid keyword in this section
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Thu 05 Nov 2009, 18:53    Post subject:  

Shucks, now I've got you in trouble, I better dig you out eh? It's not serious anyway. What happened was I think you removed the # from in front of this line:

Code:

# This loads dri module (if present)


instead of this line:

Code:
    Load       "dri"


So we need to put that # back.

If you type:

Code:
mp /etc/x11/xorg.conf


The file edited should come up. Find the "This loads dri module (if present)" line and put the # back, and you should be back to normal. Type "xwin" to get back into X.

If there's something I'm not clear about, please feel free to ask.

Battleshooter Smile

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 18:57    Post subject:  

i fix the problem but i still dont have dri on

Sad
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Thu 05 Nov 2009, 19:28    Post subject:  

I usually don't have to edit xorg.conf, after full_dri installation, I just restart X
try to re-run xorgwizard, maybe it will pick it up automatically if it's installed.

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 19:41    Post subject:  

it doesnt my friend maybe i should move to another distro but i really love this one..

tell me if u get any ideas about a distro or how to get dri enable
Back to top
View user's profile Send private message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Thu 05 Nov 2009, 19:56    Post subject:  

No, scroll down to your device section. there is one for your on board card then one for your ATI. go to the ATI one and find the line

Code:
#Option     "DRI"                   # [<bool>]


take out the #
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
LordAllucard

Joined: 04 Nov 2009
Posts: 31

PostPosted: Thu 05 Nov 2009, 20:15    Post subject:  

which # first one or second one and thanks everyone now i see that is a great community thaks alot

and i cant tell u right know if it work or not cuz i dnt have electricity right now im carribean Smile
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Thu 05 Nov 2009, 22:32    Post subject:  

LordAllucard wrote:
it doesnt my friend maybe i should move to another distro but i really love this one..

tell me if u get any ideas about a distro or how to get dri enable


It would really help if you knew what graphics card you have. I don't know anyway of discovering hardware in Puppy, but I know in Windows there are programs like PCWizard that will tell you what graphics card you have once installed. I only hope everyone won't hang me for suggesting a Windows program, but I can't think of a Puppy alternative I'm familiar with.

Once you know what your card is, you can search for it in the forum and either discover how someone else solved it or the drivers.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
mcalex

Joined: 23 Apr 2006
Posts: 78
Location: Perth, WA

PostPosted: Thu 05 Nov 2009, 23:31    Post subject:  

Quote:
which # first one or second one

the first one
Back to top
View user's profile Send private message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Fri 06 Nov 2009, 00:47    Post subject:  

yes, the frist one. sorry, i should have clarified.

To find out what video card you have look in either hardinfo or pupscan on your system menu. that will tell you. or just look in your device section in xorg. it will be at the bottom of the section
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0787s ][ Queries: 11 (0.0049s) ][ GZIP on ]