Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 19:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Hassle-Free Roxapps
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Fri 11 Dec 2009, 08:54    Post subject:  

esmourguit wrote:
Bonjour à tous,
It's excellent.
On 4.31, i tried Gimp, and i had to convert sfs file from version 3 to version 4.
Are all of them in squash version 3?
Cordialement Wink



They are actually in version 3.x.... Most of them in 3.1, so they will not run in older puppies (such as 2.15)

This is what I love about Linux.... Always something new to learn. Anywho, gotta get to my job and i will be back later on to look for ways of solving these issues. Smile
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4380

PostPosted: Fri 11 Dec 2009, 09:48    Post subject:  

Here is a fairly simple way to compile other programs that makes them easily configurable as a RoxApp

run ./configure --help
you should see a list that includes --prefix= , --bindir= etc...
you will want to set all of these to /usr/local/apps/$MY_PROGRAM_NAME

here is an example:
Code:
CFLAGS=" -pipe -Os " CXXFLAGS=" -pipe -Os " LDFLAGS=" -Wl,-O2,-s " \
./configure --prefix=/usr/local/apps/abiword --bindir=/usr/local/apps/abiword \
--sysconfdir=/usr/local/apps/abiword --localstatedir=/usr/local/apps/abiword \
--libdir=/usr/local/apps/abiword ....<--more-options>
make
new2dir make install


(Then in /usr/local/apps/$MY_PROGRAM_NAME make a symlink for AppRun to the main executable and a symlink for .DirIcon to any image)

I only recommend this for programs - not libraries
If you want to include additional libraries this way I would recommend first compiling the libraries with ./configure --enable-static --disable-shared before compiling your program (that way only the necessaryparts get included - sometimes only a couple of kb of a multi-MB library)

_________________
Web Programming - Pet Packaging 100 & 101

Last edited by technosaurus on Fri 11 Dec 2009, 10:18; edited 1 time in total
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 11 Dec 2009, 09:57    Post subject:  

thank you thank you I'm downloading kdenlive..... yes yes yes happy me Very Happy Smile Surprised Cool
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 11 Dec 2009, 11:24    Post subject:  

How the heck do you run these Question Confused
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 11 Dec 2009, 11:34    Post subject:  

arr...

Code:

sh-3.00# dmesg | tail
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
e100: eth0 NIC Link is Up 100 Mbps Full Duplex
REISERFS (device sda6): found reiserfs format "3.6" with standard journal
REISERFS (device sda6): using ordered data mode
REISERFS (device sda6): journal params: device sda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
REISERFS (device sda6): checking transaction log (sda6)
REISERFS (device sda6): Using r5 hash to sort names
SQUASHFS error: Major/Minor mismatch, older Squashfs 3.1 filesystems are unsupported
SQUASHFS error: Major/Minor mismatch, older Squashfs 3.1 filesystems are unsupported
SQUASHFS error: Major/Minor mismatch, older Squashfs 3.1 filesystems are unsupported

Back to top
View user's profile Send private message Visit poster's website 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Fri 11 Dec 2009, 17:43    Post subject:  

You extract them from the .tar.gz archive, then you have an application directory. If you are using Rox filer (Puppy's default file manager) you simply click on the directory.... It is shown with the applications and other files because the AppRun script makes it an application and the .DirIcon will give it its unique icon.

The process is simple with these... just download, extract, and execute.... from anywhere. These were packaged with puppy 4.2.1 using binaries, mostly from the slackware repo and many from the ArtistX liveDVD. On puppy 4.3, I have heard the squashfs needs to be converted from version 3.1 to 4.x. On older puppies that use squash 3.0 or older, they will error out and will not run. Keep in mind, that I had these roxapps working well on an old 400 MHz computer with 320 MB RAM, but I was using a 1 GB swap partition .... I tried using GIMP on a 2.6 GHz system with 512 MB ram and it kept crashing on me until I mounted a swap partition on a USB flash drive. If you do not have a swap partition and these apps keep crashing, try making a swap either on your hard drive or a flash drive.... Even an old 256 MB or 512MB flash drive might work. I can't be sure though, as I have only used 1 GB swaps. You can even repartition the flash drive so that only part of it is reserved as a swap partition. It would work best if you frugal your distro to, say, a 4 GB flash drive with one GB reserved for swap. make a boot cd (even a business card cd will work as you do not have to have the pup_xxx.sfs file on it) with the pmedia=usbflash hardcoded on it, and you can take your computer anywhere you go..... without having to lug a laptop around.

abush, looking at your error log, it seems to me that you need to convert the squashfs to a newer version. I will ask how to do that and post a howto on this.

dingo, did you try to edit the AppRun script with the changes I showed earlier? If so, were you able to get what you wanted?
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 11 Dec 2009, 18:33    Post subject:  

thanks muchly
Back to top
View user's profile Send private message Visit poster's website 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Fri 11 Dec 2009, 18:39    Post subject:  

If anyone here is interested, I also have ProducerPup available. It contains half of the apps I listed here and more. If you are planning to download GIMP, Blender, and Kdenlive, they are all included in ProducerPup as well as Audacity, Hydrogen, LMMS, and others. ProducerPup is based on Puppy 4.2.1, so the rest of these apps will work with it. You can find more information on ProducerPup by going to:

http://www.murga-linux.com/puppy/viewtopic.php?p=371017#371017
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Fri 11 Dec 2009, 23:03    Post subject:  

Quote:
bush, looking at your error log, it seems to me that you need to convert the squashfs to a newer version. I will ask how to do that and post a howto on this.


Tried uploading and using the sfs converter in Puppy 4.3.1
Bit more than that needed as it did not work
Next trick might be to rename them .sfs?

Anyway great to see them working for older versions
and perhaps ready made versions for 4.3.1 will be possible? - good luck and many thanks Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
seaside

Joined: 11 Apr 2007
Posts: 887

PostPosted: Sat 12 Dec 2009, 12:25    Post subject:  

Here's a way to convert the old SFS files to the new ones for use in the Roxapps.

Download and extract the tar file

Right click the app icon directory and choose "look inside"

Rename the XXX.roxfs to XXX.sfs

Open Menu >Utility>Convert sfs

Drag & drop XXX.sfs into Converter

Rename resulting "sfs4" to XXX.roxfs


Also, if this doesn't work within four hours, seek immediate medical attention Very Happy

Cheers,
s
Back to top
View user's profile Send private message 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Sat 12 Dec 2009, 13:06    Post subject:  

thank you seaside, Apparently, that feature is only available in puppy 4.3. I will have to try that
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Sun 13 Dec 2009, 17:56    Post subject: Errors  

sh-3.00# ./AppRun
Qt: Locales not supported on X server
kbuildsycoca running...
Qt: Locales not supported on X server
QInputContext: no input method context available
QInputContext: no input method context available
Failed to load plugin: libswscale.so.0: cannot open shared object file: No such file or directory
KCrash: Application 'kdenlive' crashing...
Could not find 'drkonqi' executable.
KCrash cannot reach kdeinit, launching directly.
Back to top
View user's profile Send private message Visit poster's website 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Sat 19 Dec 2009, 15:27    Post subject:  

Thank you Abush... I have downloaded a copy of puppy 4.3.1 and will have to try this out to be sure of what is wrong.... Keep in mind, however that if there is any extraction of these squashfs files to a vfat partition, symlinks are not extracted and may be necessary.... I will run the program on 4.3 to check it out.
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Sat 19 Dec 2009, 16:46    Post subject:  

Lobsters idear worked btw.

Success after adding the lib it moaned about it loads Smile
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 21 Dec 2009, 19:41    Post subject:  

moans: Can't save work as a project only export. By can't save, I mean no file exists where i set it to save(and yes its not hidden). My other moan is I can't import theora video but can export. Otherwise its raver stable Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0860s ][ Queries: 11 (0.0045s) ][ GZIP on ]