Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 19 Sep 2018, 01:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Precord0.9.5 audio recorder
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 13 [184 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Author Message
wiak

Joined: 11 Dec 2007
Posts: 938
Location: not Bulgaria

PostPosted: Tue 05 Jun 2018, 08:14    Post subject: new Precord 9.0.5  

Precord version 9.0.5 released. NOTE: now depends on gtkwialog being installed per below details:

2018/06/05 (YMD): Precord now uses gtkwialog [-b] for its GUI and so can now be used on systems that use dash (e.g. Debian and Ubuntu), ash (e.g. Slitaz), or bash (e.g. Puppy Linux) as their underlying system shells'

DOWNLOAD: deb package suitable for Puppy or Dogs or these other systems is currently attached to first post of this thread here:

http://www.murga-linux.com/puppy/viewtopic.php?p=370446#370446

Current version 9.0.5, depends on gtkwialog being installed. Note that gtkwialog is a drop-in replacement for gtkdialog in that it contains full current gtkdialog functionality but has additional functionality that allows it to be used when either dash, ash, or bash are used as the system shell.

You do not therefore need both gtkwialog and legacy gtkdialog on your system but can instead simply make gtkdialog a symbolic link to newer gtkwialog (USUAL DISCLAIMERS APPLY: AT YOUR OWN RISK, but gtkwialog has proved stable in all tests thus far).

You can currently find a 32bit and 64bit downloads for gtkwialog (compiled on XenialDog but fine also for Bionic) at foot of the following post:

http://www.murga-linux.com/puppy/viewtopic.php?p=993434#993434

Being a radically new version (but same operation functionality) please let me know if you find any bugs. Thank you.

wiak
Back to top
View user's profile Send private message 
mcewanw

Joined: 16 Aug 2007
Posts: 3198

PostPosted: Sat 09 Jun 2018, 00:32    Post subject:  

Precord new releases depend on gtkwialog (which is currently under development but not yet published) so that it can also be used on systems that run dash as their underlying system shell.
Back to top
View user's profile Send private message Visit poster's website 
dancytron

Joined: 18 Jul 2012
Posts: 1123

PostPosted: Sat 09 Jun 2018, 01:52    Post subject:  

mcewanw wrote:
Precord new releases depend on gtkwialog (which is currently under development but not yet published) so that it can also be used on systems that run dash as their underlying system shell.


It got updated in Fred's Stretch repository but Fred doesn't have gtkwialog. So the upgrade fails and so does purge then reinstall.

Either gtkwailog needs to be added to Fred's repo or precord latest version of precord needs to be removed.
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 938
Location: not Bulgaria

PostPosted: Sat 09 Jun 2018, 02:25    Post subject:  

dancytron wrote:
mcewanw wrote:
Precord new releases depend on gtkwialog (which is currently under development but not yet published) so that it can also be used on systems that run dash as their underlying system shell.


It got updated in Fred's Stretch repository but Fred doesn't have gtkwialog. So the upgrade fails and so does purge then reinstall.

Either gtkwailog needs to be added to Fred's repo or precord latest version of precord needs to be removed.


Yes, I understand. Fred will see your messages dancytron and fix it as suits. I expect he will replace it with previous Precord for a while yet since only gtkwialog before is just for testing use. Alternatively he could just remove dependency info but that would be nothing to do with me; that version of Precord does require gtkwialog since it is designed to also run on dash system shell distributions. I don't want people hassling me for old versions of the source code since I'm already in the middle of modifying it all for actual release version. Prealpha was a testing-only binary, and not a distribution release, which I want to remove from old thread, but don't have access as you probably know.

cheers, wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 13 [184 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0566s ][ Queries: 12 (0.0274s) ][ GZIP on ]