Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 14:03
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
smc91c92_cs not working for Ositech Seven of Diamonds
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message
timknauf
Guest


PostPosted: Mon 02 Jan 2006, 20:46    Post_subject:  smc91c92_cs not working for Ositech Seven of Diamonds  

I'm trying to get a PCMCIA 'Ositech Seven of Diamonds' network card working on my laptop. According to the PCMCIA-CS page, I can use the smc91c92_cs driver for this card.

Now, the card works fine in Windows Me and Windows 2000, but I have been unable to get it to work in Puppy. I had the same problem when I was trying out Ubuntu recently.

cardmgr gives a low beep when it detects the card. Here is the relevant section from /var/log/messages:
Code:
Jan  3 11:55:45 (none) daemon.notice cardmgr[149]: unsupported card in socket 1
Jan  3 11:55:46 (none) daemon.info cardmgr[149]:   product info: "Ositech", "Trumpcard:7oD-II Ethernet", "400091-003", "00C0E32932A8"
Jan  3 11:55:46 (none) daemon.info cardmgr[149]:   manfid: 0x0140, 0x0025  function: 6 (network)


I can do a
Code:
modprobe smc91c92_cs
or load the driver with the cool Puppy network tool, but I still have no eth0 interface listed.

Also,
Code:
ifconfig -a
only lists "io", the loopback interface.

So it appears the card might be a second revision (7oD-II) that isn't supported by a Linux driver...? I can't find any information about this distinction (if it even exists) online, though.

I also compiled and installed ndiswrapper, just to check whether I could use Windows drivers for the card (I realise that it was a long shot). That failed as well, but maybe it's the topic for another thread anyway. I can supply details of that failure as well if anyone's interested.
Back to top
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0372s ][ Queries: 10 (0.0027s) ][ GZIP on ]