Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

  New Forum: http://forum.puppylinux.com
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 15 Aug 2020, 04:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Puppy On Laptops
Moderators: Flash, Ian, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 20 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22, 23, 24 Next
Author Message

Joined: 15 Dec 2009
Posts: 2955
Location: USA

PostPosted: Fri 30 Aug 2013, 16:23    Post subject: Re: ASUS 1015BX Soundcard does't work  

rendysatrya wrote:
I've tried the latest precise 5.7.1 on my ASUS 1015BX AMD Fusion c60 netbook, all work fine except the sound card. It detects sound card but it doesn't work. What should i do then?

I think that when I installed 5.28 on my old laptop, that the sound didn't work initially. Then I ran the sound wizard, which identified the correct driver and it worked fine (Menu => Setup).

Add swapfile
WellMinded Search
PuppyLinux.US Search
Back to top
View user's profile Send private message 

Joined: 26 Jul 2007
Posts: 986
Location: England

PostPosted: Tue 03 Sep 2013, 03:02    Post subject:  

I use Slacko 5.3.3 on my Acer Aspire One, the label says "Model Number ZG5". It is an early one, about four years old now, and does not get much use. I take it on holiday, and mainly use it to:
Browse, check news, weather forecast, webmail.
Show slideshows of grandchildren to friends/relations.
Store and get a larger view of photos downloaded from camera.

I find that I have to take a mouse, as the I find the left and right pad buttons too awkward to use.

I don't attempt things like games or photo editing, or other things better done on a desktop when I get home.

Within that requirement envelope I've never had any trouble with Slacko.

Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 3913
Location: 500 seconds from Sol

PostPosted: Tue 10 Sep 2013, 11:48    Post subject: Pups which Work with the Acer Aspire One D270
Subject description: Cedarview PowerVR poulsbo gma600_gfx Intel GMA-3600

Hi All,
The problem with the Acer Aspire One D270 is its employment of the Cedarview graphics chip, variously identified in the subheading of this post in the hope that doing so will help others find this post. Other computers have used Cedarview chips, including the gma500_gfx and the gma650_gfx. The information here may also apply to those computers.
As of September 2013, at least three versions of Puppy Linux work almost "out of the box" with respect to graphics, wireless and sound on the D270: that is, setting the Pups up is something anyone can do with only a little more effort than setting up any Pup on any other computer. These Pups will boot directly to desktop and automatically initiate the First Run settings wizard. To obtain proper graphics during “First Run” check the video radio box on the right and click OK. Xorgwizard will run. Select “modsetting,” then follow the instructions. Sound works, but very quietly. Select “Retrovol sound mixer” on the Multimedia submenu and maximize the appropriate sliders. Sound will be discernible, but not loud. [However, see below]. To obtain wireless internet access, click the Internet Connection Wizard on the Setup subMenu. Click Wired or Wireless Lan. Select the “Frisbee” tool. Wait patiently while it scans for available networks. Click your network to highlight it and then click “connect.” Follow the instructions. Wait patiently. Scanning and connecting are slow, but work. (Tip: the strength of a router's wireless signal diminishes with distance. Be close to the router the first time you attempt to connect to a network).
Currently, the three Puppy's which work with the Acer Aspire One D270 are:

Pemasu's Upup raring-, available from the first post of this thread: http://www.murga-linux.com/puppy/viewtopic.php?t=87374

Pemasu's Upup precise, available from the first post of this thread:

Barry K's Precise Puppy 5.7.1, available from the first post of this thread:
but read thru the thread as I recall there being a faster repository than ibiblio.

Regarding the following: I haven't tested everything. My silence regarding anything should not be interpreted as an indication that it hadn't or wouldn't work. Both raring and precise 5.7.1 will suspend (hibernate?) when the lid is closed, and re-establish wifi connections when the lid is re-opened. I have not, as yet, completely tested any other “special features” the D270 may have. But I would note that under raring, two of those special features work: holding down the Fn key and pressing the function key with the “monitor” icon toggles the monitor on and off. More importantly, holding down the Fn key and pressing the function key with the “volume” icon initiates a slider. Tapping the “direction arrows” increases and decreases volume. The output of sound, using that method, was increased to very satisfactory levels.

Note: Functional as used in this post does NOT mean providing accelerated graphics.

Edit 9/10: Following the npierce's suggestion below that re-examine the touchpad, substantial revisions are necessary regarding PhatSlacko and Slacko 5.6 Final. For now it is sufficient to state that boot run the D270 satisfactorily. I've deleted my previously misleading information and will post my experience tomorrow.

Edit: 3/02/15: Also fully functional on the D270 are TahrPup and the LxPups based on Precise, Slacko and Tahr. Probably functional are the X-Pups based on them as well (untested). Partially functional is Carolina-1.3 Vanguard and, perhaps, Carolina-1.3 (untested). Vanguard will boot to desktop. However, dimensions are limited to 640 x 460? pixels. I could find no way to obtain a higher resolution.

Edit: 6/16/2015: Lupumini-5.28.7 is also functional. If I understand the versions of Lucid rerwin has published, all versions of 5.28.7 except Lupu3HD and the lupusupers use the kernel and should similarly work. See http://www.murga-linux.com/puppy/viewtopic.php?p=739518#739518 regarding versions.

If I were to guess, my guess is that at sometime during his revitalization of Lupu/Lucid, rerwin included the drivers created by Tempestuous. That may have been during his work on the 5.28.6 series. But unless you have a particular reason for using the 5.28.6 series, I see no reason to test them.

I consider the ability to run Lupu/Lucid on netbooks important. Many netbooks shipped with decent processors, but only 1 Gb of RAM. Lupu uses older graphics libraries which, in turn, use less RAM. With, by now, about 5 years of software development, there are applications to meet almost everyone's needs. The exception are recent google-chrome/chromium/SWIron, which require those newer graphics libraries. For those concerned about security, it should be noted that one of rerwin's objectives was to provide in each build patches to any discovered vulnerability. Ergo, my preference for his "7" rather than "6" series.

For what it's worth, although rerwin's Lupu revitalized 5.8.7 do not provide accelerated graphics, glxgears show they currently handle graphics about 50% faster than the other Pup's I've tried.


Last edited by mikeslr on Wed 01 Jul 2015, 12:17; edited 6 times in total
Back to top
View user's profile Send private message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Tue 10 Sep 2013, 13:14    Post subject:  

mikeslr wrote:
For controlling the mouse, the D270 has a simple touchpad, not even adorned by the two buttons below the touchpad to which I've been accustomed by Thinkpads.

It seems like you may have a "ClickPad". When you press down on the lower edge of the touchpad do you get a mechanical click? If so, does that cause the results you would normally get from a left-click? (I'm talking about actually pressing on the pad as you would on a button, not just a light tap.)
Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 3913
Location: 500 seconds from Sol

PostPosted: Tue 10 Sep 2013, 21:34    Post subject: The Acer Aspire One D270 -- further info  

Thanks npierce,

I'll try that. I'll also retry Slacko 5.6 Final and Phatslacko, having just re-installed them to a USB-key. Will post what such trials uncover.

For those interested in why I acquired the D270 in the first place, and which netbooks are currently recommended, see my post @http://murga-linux.com/puppy/viewtopic.php?p=725005#725005

Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 3913
Location: 500 seconds from Sol

PostPosted: Wed 11 Sep 2013, 12:23    Post subject: Slackos which work the Acer Aspire One D270
Subject description: Hopes for Future Pups

Hi All,

Thanks to npierces' suggestion, I re-examined the D270's touchpad and thus discovered how to work with Slacko Pups.
Although pressing the edges of the touchpad did nothing, it occurred to me while doing so that perhaps the solid black plastic strip just below the touchpad might be more than a design element for aesthetic purposes. Pressing the black strip with the light pressure which would send an alpha-numeric key value to a target also accomplished nothing. But by exerting considerable pressure to the ends of the black strip I discovered that it concealed both left and right mouse buttons. Using a mouse is still considerably easier. But it's nice to know that right-and-left click mouse routines are available from a naked D270.

With that discovery I was encouraged to try running the D270 under Phatslacko and Slacko 5.6 Final again.

PHATslacko, http://murga-linux.com/puppy/viewtopic.php?p=691017&sid=135bca7e8d02ddcd18f6332bdaa3d563#691017 ,
Slacko 5.6 Final, http://www.murga-linux.com/puppy/viewtopic.php?t=87210

Unlike upup raring and the precises I discussed in the post above, the Slackos do not initially boot to desktop. Rather, during the initial boot you are required to type “xorgwizard”, initiating that wizard. By now I knew to select “modsetting.” The Slackos will then boot to desktop, providing 1024 x 600 resolution, the default under Windows 7.
Setting up wireless and sound were as with upup raring and the precises, except that the Slackos use an app named generic to adjust volume settings. I'm uncertain whether pressing the Fn Key + either Up or Down keys adjusts sound. No slider appeared, and I couldn't discern a difference. But that could just be me.
Unlike upup raring and the precises, tapping the touchpad has no effect. But the Slackos do respond to the Left and Right “Buttons” below the touchpad, as explained above.
While the above might suggest limitations using Slackos on the D270, such limitations are "bells and whistles", not the absence of essential functions. There are very good reasons to at least try Slackos. After all, they're free. Many users of Slacko Pups claim that their display or sound quality is better than Pups built from Ubuntu binaries. But the main reason is that 01micko, himself, and the other devs who work with him, often develop applications using slackware binaries where equivalent applications based on Ubuntu binaries are unavailable. And pets and SFSes based built from Slackware binaries frequently won't run under "Ubuntu" based Pups.
My repartitioning of the C: drive has given me an over 100 Gbs partition on the D270. Pups rarely need more than 2 Gbs. And an application in SFS form can be loaded into any number of Pups. Consequently, I have more than sufficient hard-drive space to enjoy the benefits of both Ubuntu based Pups and Slacko based Pups.
I did not try Thinslacko. During my search for solutions, I ran across a post which suggested that any Pups developed since February 2013 by pemasu or 01micko are capable of properly handling the Cedarview chip. Thinslacko is an 01micko creation.
Both pemasu and 01micko create pups using the "woof" application. Of course, so does Barry K, the creator of both Puppy Linux and the "woof" application. As noted in the above post, one of the precises which runs satisfactorily on the D270 is Barry K's Precise Puppy 5.7.1. From the foregoing, I would conclude that the capability of generating a Pup able to handle the D270's Cedar Trail processor and CedarView graphics chip is built into the "woof" application. If so, future Pups based on future kernels should be able to do so, as long as the kernels have that capacity and the creators include it in their builds.
I understand that Barry K is presently working on a Saucy Pup, which will utilize Ubuntu Saucy binaries. So I look forward, hopefully, to a Saucy Pup running on my D270 sometime in the future.


PS. 9/12: After posting the above I got to wondering if rg66's new x-precise-2.1.1, --one of my favorite Pup flavors--would work. I does, bringing to those burdened by the CedarTrail/CedarView chips the Xfce window manager out of the box. [I'll also note that the installation of vicmz' OpenboxPlus 1.5.3 with Lxpanel http://murga-linux.com/puppy/viewtopic.php?p=703730&sid=9240889a86f395332e13a679cf148213#703730 can be safely installed into Slacko 5.6 Final].
x-precise is based on precise 5.7.1. Rather than unnecessarily clog the Forum's bandwidth, I'm going to assume that future Slackos, Precises, and rarings with the PAE-enabled kernel will also function properly. So I won't report successes. But I will test non-pae (retro) kernels because the D270 with only 1 Gb RAM (maximum 2 Gb) receives no benefit from Pae-enabled kernels; they may unnecessarily consume resources.
x-precise can be obtained here: http://murga-linux.com/puppy/viewtopic.php?p=715924#715924
P.S. 9/14/2013: I had forgotten that upup raring discussed in my previous post had been built by pemasu using a non-pae-enabled kernel. It's also worth noting that installation of vicmz's Openbox Plus 1.5.3 (I selected lxpanel during installation) went without a hitch. The result was a modern, highly configurable operating system running on the D270.
Back to top
View user's profile Send private message 

Joined: 18 Oct 2011
Posts: 69

PostPosted: Thu 26 Sep 2013, 23:50    Post subject: Asus Eeepc 1001PX
Subject description: Saluki, Slacko5.6, Precise5.7.1, Lucid5.2.8 Frugal install

Saluki, Slacko5.6, Precise5.7.1, Lucid5.2.8 Frugal install

Saluki is my day to day OS and I have been using it the last 2 years on this laptop. Internet-connection(Wifi), audio(speakers, headphones and mic), video, suspending, mounting (internal hdd, usb, SD card), touchpad everything is working well. The only issue, which I have is that I cannot mount my android phone via USB in v023, but could in 017.

Tested and working out of the box in Slacko5.6:
Internet-connection(wifi), mounting,(hdd), audio (speakers, headphones and mic) and video

Tested and working out of the box in Precise5.7.1
Internet-connection(wifi), mounting,(hdd), audio(speakers, headphones and mic) and video

Tested and working out of the box in Lucid5.2.8
Internet-connection(wifi), mounting,(hdd) and video

--not working in Lucid: audio(speakers, headphones and mic) , but I haven't tried to configure anything, will run the sound setup wizard next time I have a look at it

After running the sound set up wizard speakers are working, but not headphone/mic. I think it is this problem.
Back to top
View user's profile Send private message 

Joined: 20 Jan 2009
Posts: 2288

PostPosted: Mon 07 Oct 2013, 14:34    Post subject:  


System:    Host: puppypc15741 Kernel: 2.6.39 i686 (32 bit, gcc: 4.4.5)
           Desktop: Openbox 3.5.0 Distro: Guy Dog Linux Linux 2.6.39 [ arch]
Machine:   System: Acer (portable) product: Aspire 5534 version: V1.10
           Mobo: Acer model: Aspire 5534 version: V1.10 Bios: Acer version: V1.10 date: 08/26/2009
CPU:       Dual core AMD Athlon X2 L310 (-MCP-) cache: 1024 KB flags: (lm nx pae sse sse2 sse3 svm) bmips: 4788.62
           Clock Speeds: 1: 1197.159 MHz 2: 1197.159 MHz
Graphics:  Card: ATI RS780M/RS780MN [Radeon HD 3200 Graphics] bus-ID: 01:05.0
           X.org: 1.7.7 driver: radeon tty size: 80x24 Advanced Data: N/A for root
Audio:     Card: ATI SBx00 Azalia (Intel HDA) driver: HDA Intel bus-ID: 00:14.2 Sound: ALSA ver: 1.0.24
Network:   Card-1: Atheros AR928X Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 08:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 250.2GB (20.3% used) 1: id: /dev/sda model: TOSHIBA_MK2555GS size: 250.1GB
           2: id: /dev/sdb model: Multi size: 0.1GB
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 79 Uptime: 24 min Memory: 265.5/3546.9MB Runlevel: 5 Gcc sys: N/A Client: Shell (sh) inxi: 1.9.16

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          15      120456    b  W95 FAT32

Translation. Guydog 5.01 running on 128MB SD Flash card on a Acer Aspire 5534. Sound, Flash, anything else I install in this 90MB Puppy
version with Debian compatibility works just fine on this Acer. Saving changes on 2 gig personal save file on 250gig NTFS drive.
 Filesize   32.56 KB
 Viewed   7579 Time(s)


Back to top
View user's profile Send private message 

Joined: 15 Oct 2013
Posts: 2

PostPosted: Wed 16 Oct 2013, 01:02    Post subject:  Toshiba C855
Subject description: LUPU-528 Works

Toshiba Satellite C855-S5206
4x Intel(R) Core(TM) i3-2370M CPU @ 2.40GHz
2757MB Memory (333MB used)
Puppy Linux LUPU-528.005 dual boot with Grub
Windows 7

This install is working fine, but that is nothing new for me. I've had great results with Puppy from the first try with an old IBM 770 something like 8 years ago. Puppy also worked on an IBM T42, T23, A31, R51, and a HP tower. I would just installed the current version of Puppy that was available at the time, to a Linux partition, and use grub to dual-boot if there was a working Windows install. They all just worked. The only problem I recall was sound did not work on the 770. In that case, I did not need sound, so it was essentially a non-issue for me.
Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 3913
Location: 500 seconds from Sol

PostPosted: Sun 23 Feb 2014, 12:48    Post subject: Dell Latitude E6400 -- nice machine
Subject description: FatDog64, Upup's Raring and Precise

Hi All,

I had to replace my Thinkpad T42 which ran all 32-bit Puppies very well. Having acquired the light-weight Acer Aspire mentioned above for traveling, the Thinkpad had been relegated to providing quick access to the internet while I watched TV in the den. It was kept next to my chair on a small table by a window. Newton's Third Law and my cat conspired to alter its location. Sturdy bugger that she was, she survived the change, but became mute. Testing revealed a motherboard problem: more costly to fix than replace.
Thought I might as well upgrade. Looked for a Thinkpad T61 on ebay and Amazon Marketplace, but didn't want to spend that much. Figured I'd settle for a Dell Latitude D630, almost as highly rated, but a little cheaper. Then, as I was about to "Buy Now" via ebay I glanced down to "what others are looking at" and saw a listing for a seller refurbished Dell Latitude E6400, Ibm Core 2 Duo, 3 Gb RAM, 160 Gb Sata, Good Battery from a Top Rated Seller for $149, free shipping. Searching suggested it to be superior to the D630 and that it played well with Linux.
It came with XP Professional installed, which I'll keep primarily so that I can use Dragon Naturally Speaking. I plan to resize the hard-drive to create Linux partitions for Puppies and, perhaps, Zorin. As of now, I've successfully run from a USB-key Raring, Upup precise, and FatDog64. All were fast. Overall, it seems like a rather nice machine.

Back to top
View user's profile Send private message 

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sun 23 Feb 2014, 13:23    Post subject:  

What happened to the muted Aspire?

BTW -- both my parents are from Bergen County NJ, about a half hour from you by Google Maps. Small world Very Happy


Back to top
View user's profile Send private message 

Joined: 29 Jun 2008
Posts: 10548
Location: SwedenEurope

PostPosted: Thu 27 Feb 2014, 18:00    Post subject:  

I could resist if I really wanted it but I got curious
so I bought the cheepest laptop I could find today

2800SEK which is a Close to 530USD we are paying
a bit more than in US?

Why did I bought it? To find out if the UEFI would alllow me
to bypass UEFI in BIOS so I need to go the the thread
describing succeses. So if you know the best way to
install on Pachard Bell EASY NOTE maybe it has a modell number

But I am too tired just now. Local time now is 23.20 time to sleep. Smile

I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 

Joined: 18 Mar 2014
Posts: 66

PostPosted: Wed 18 Jun 2014, 13:24    Post subject:  

Slacko 5.6 & 5.7 have worked for me pretty well on:
hp dv1227us
hp probook 4530s, and
hp elitebook 8530p

Last edited by stray_dog on Sun 10 Aug 2014, 08:40; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 26 Sep 2010
Posts: 233
Location: In front of my computer

PostPosted: Fri 20 Jun 2014, 21:19    Post subject:  

I have a Compaq Presario 2195us laptop that is 10 years old. I bought it refurbished off the HP website at that time. I had been using XP Pro on it, but as there is no more XP support, I decided to run Puppy off a CD. It runs reasonably well for websurfing with Firefox. Everything worked out without any tweaking (sound, headphones, (haven't checked mic)) except wireless. This came with a Broadcom BCM1506 card. I didn't try Frisbee wireless manager. I know that there is probably some pet, ndiswrapper or something I can do to get the Broadcom card working, as supposedly, they don't do too well with Linux. I even tried installing an Intel WM2200ABG card, but didn't have much sucess. I just said F it, and am using a USB wireless dongle that works out of the box with Lucid. The only small niggle is that after booting to the home page, it takes a couple minutes for the wireless to connect.

When I was using another Windows box with Slacko, Lucid 5.2.8 frugally installed with the same wireless dongle, I got a very quick connection within seconds.

HP Pavilion Mini Pentium 1.7 GHz Dual Core 12 GB RAM 120 GB SSD Linux Lite 3.8 64-bit w/ Kensington Slimblade Trackball
Bionic8.0 Xenial64 Tahr64 USB frugal install
Samsung Chromebook Plus
LG V20 LG Xpression Plus Huawei Ascend XT2

Last edited by dk60902 on Sat 21 Jun 2014, 08:39; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 15 Apr 2014
Posts: 80
Location: Scotland

PostPosted: Sat 21 Jun 2014, 05:43    Post subject:  

PB EasyNote E6307 - approximately 10 years old.


AMD 1.8GHz Sempron 3000+ CPU

40 GB HD

VGA compatible controller: VIA Technologies, Inc. K8M800/K8N800/K8N800A [S3 UniChrome Pro] (rev 01)

I have Precise 5.7.1 frugal install, dual boot with Kubunutu 12,04, and also use Lucid in ''live'' mode with a savefile on USB (which I have set so that there is no automatic save). This laptop doesn't boot from USB, so to use Lucid I boot from CD.

I had some trouble finding a ''large'' up-to-date(ish) Linux OS that this laptop would boot from, as most of them had issues with the graphics; then I eventually discovered Kubuntu 12.04 just yesterday, and I am delighted with it so far.

On the contrary with Puppy which I've now been using for a few months, it took me a while to find one that didn't work on this laptop, and that one (Tahr) is still in its developmental stage.

Precise, Lucid and Slacko 5.7 all work fine, although the latter runs the CPU slightly hotter, and I gather it's primarily designed for more modern hardware. Lucid is the one I have been using the most up until now, and I just installed Precise on the hard drive for fun after deleting Windows, and plan to install more Pups on the same partition.

I was slightly apprehensive at first about formatting the hard drive because of the infamous ''tattoo,'' but found installing Kubuntu (and Puppy) just as straightforward as installing an OS on my desktop pc.

Using GParted on my Lucid installation on USB, I deleted the former sole partition on the HD and created a small primary partition just for boot files, then created an extended partition on the remainder of the HD and divided it into four logical partitions for Puppy, swap, Kubuntu, and files such as photos and videos etc. It's much more fun that way! Smile

Even though this was an XP machine, getting rid of Windows completely was the best thing that ever happened to it. Kubuntu is faster and smoother than XP, and of course Puppy is faster still.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 20 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22, 23, 24 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0815s ][ Queries: 12 (0.0069s) ][ GZIP on ]