Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:01
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Quirky 005 Feedback
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 6 Posts_count   Goto page: 1, 2, 3, 4, 5, 6 Next
Author Message
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 19 Jan 2010, 11:58    Post_subject:  Quirky 005 Feedback
Sub_title: Quirky 005 experiences
 

Luxury - it recognised the ATI Radeon 3450 video card out of the box with normal 2D acceleration.

PupTelly works with MPlayer but it's supposed to go fullscreen when you press F. A full screen frame does appear if you press F, but the view content itself does not expand to full screen.

Have only just started to play with it so I'll report back after I eat.

Will also have a go with both the Classmate PC and the Asus eeepc 901

Looking great though.

_________________
Life is too short to spend it in front of a computer

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website AIM 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 19 Jan 2010, 12:20    Post_subject:  

Had to change to the internal sound card using the ALSA sound wizard (I also have a PCI sound card that I am not connected to)

Clicked on BBC news that plays OK in browser
ASF - no
mp4 - no full screen, no sound, small pics looks good
wmv - small image, no sound, no full screen
vob - small image, no sound no full screen

Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 19 Jan 2010, 13:13    Post_subject:  

An impressive multi-media Quirky! Pizzasgood's Retrovol tray volume control and sound mixer is superb. On the limited tests I've done so far things look pretty good. There are a few snags though:

(1) Realmedia .ram files cause browser crash in Seamonkey and Firefox. In Opera player immediately crashes out but Opera survives. This is not too much of a problem as this format is used infrequently now.

(2) I can play streaming QuickTime video in Seamonkey and Firefox but not Opera. Try www.apple.com/trailers/ .
Back to top
View user's profile Send_private_message Visit_website 
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 19 Jan 2010, 14:04    Post_subject:  

Mplayer works for me when started via Puptelly, but standalone MPlayer will not start from menu item. It simply shows 2 blank application windows, freezes X completely and therefore requiring X to be restarted.

This problem only started to appear after Puppy was installed as frugal with pupsave and running as live CD.

In the dim and distant past, I seem to remember that in order to start MPlayer you had to start it via a terminal command with some sort of command-line parameter. Memory fails me here. Does anyone else remember this?

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send_private_message Visit_website AIM 
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 19 Jan 2010, 14:29    Post_subject:  

Just noticed MPlayer starts OK from the desktop "play" icon.

No startup parameters seem to be needed at all - but even if the JWM .jwmrc file is edited to point directly to /usr/local/bin/defaultmediaplayer the same crash occurs.

Will play with it some more and see what gives.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send_private_message Visit_website AIM 
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 19 Jan 2010, 14:41    Post_subject:  

OK here's a temporary work-around for MPlayer that won't start from the JWM menu.

Open /root/.jwmrc and replace the MPlayer XML executable entry with:

Quote:
<Program label="MPlayer media player" icon="mplayer.xpm">urxvt -e mplayershell</Program>




Then restart JWM and you're good to go

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send_private_message Visit_website AIM 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 19 Jan 2010, 14:55    Post_subject:  

Does this mean that q5 is better than both q3 and q4?

Pardon if I am very naive asking such question.

I have tested Q3 and that one worked rather well.
so if Q5 is better then that is very interesting.

are Q5 better than Puppeee 4.3.1? I have that one in frugal install on my vista Compaq and are very satisfied with it. Very fast responses and play youtube without crashing and video streams from out local TV stations. What I longed for 2008 when I started with Puppy as the one I want to use.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Tue 19 Jan 2010, 16:25    Post_subject:  

Is there a MESA (OpenGL) .PET package for Quirky-005?
I can't continue testing Quirky without this package.

_________________
Turbopup Tech Support
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Tue 19 Jan 2010, 16:38    Post_subject:  

Here are some bugs I found in this new build of Quirky:

- alsamixer crashes to commandline if you press F1 (for help) or F2 (for system info)
These options are very important for viewing the capabilities and outputs of your sound card and seeing the shortcuts and modifiers you can use in AlsaMixer.
This worked before in Quirky 002 / 003 but not anymore in 004 / 005.

- pmount quickly closes the optical drive tray after ejecting a CD / DVD. This is annoying and *DANGEROUS*.
There's no such problem when ejecting the CD via ROX-Filer.
This is a long-standing bug of Puppy and must be fixed ASAP.

_________________
Turbopup Tech Support
Back to top
View user's profile Send_private_message 
Artie


Joined: 04 Oct 2005
Posts: 446
Location: Norway

PostPosted: Tue 19 Jan 2010, 17:21    Post_subject:  

Network Wizard forgets settings between boots so I have to do eth0 and AutoDHCP after every boot. Boots from cd with files on HD.

Artie
Back to top
View user's profile Send_private_message Visit_website YIM MSNM 
ICQ 
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 19 Jan 2010, 17:42    Post_subject:  

nooby wrote:

Quote:
Does this mean that q5 is better than both q3 and q4?


If only computing life was that simple.

Any operating system evolves over time and in theory should therefore improve in an incremental fashion.

Different hardware combinations behave differently with different OS's, so this muddies the water as far as trying to assign a capability index to successive versions of operating systems.

I can only speak from my own experience with my own hardware. The current stable version of Puppy 4.3.1 has been extremely satisfactory across all the hardware that I have tried it on. The Quirky series (compiled under T2) is if anything even faster and more stable. This latest Quirky 5 is indeed looking very interesting due to the upgraded multimedia software. There are some minor issues perhaps, but they're not show-stoppers.

Puppy as a project is in the best state it has ever been in since it was started. back in 2003. On my hardware here, even the latest experimental Quirkys are doing better than the latest supposedly stable Ubuntu (the No 1 distro in Distrowatch).

Puppians have never had such a good choice of versions. Just use the latest one that works for you.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send_private_message Visit_website AIM 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Tue 19 Jan 2010, 20:03    Post_subject:  

- mplayer lacks the much needed gl2 output. Users with ATI cards (using the proprietary ATI driver) will suffer from washed out colors and tearing if they use Xv. The gl2 output works perfectly for them.

- mplayer doesn't have repeat / loop playback.

- Is there any way to prevent Ogle from taking over the place of MPlayer as the defaultmediaplayer when a normal DATA DVD disc is inserted in /mnt/sr0 ?

If I have a DVD with HD (.mp4/.mkv) movie clips and click on the 'PLAY' icon on the desktop, Quirky should start MPlayer, not Ogle.

Edited_time_total
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Tue 19 Jan 2010, 20:05    Post_subject:  

tronkel,
Would you mind changing the title of this thread to "Quirky 005 feedback" or "Quirky 0.0.5 feedback". We are not at version 5 just yet!

Re running mplayer from the menu. Yes, when I was setting that up there was something nagging at my memory about that. I'm not sure, I think that someone posted that an entry in .jwmrc like this works:

exec mplayershell &

...anyway, I'll sort that out.

Lobster,
every video file that I have tested plays properly, including sound. Can you please post URLs of those for which you are not getting sound?

All of these play ok for me:

http://puppylinux.com/test/media-test-video/

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Tue 19 Jan 2010, 20:24    Post_subject:  

- All HD videos I've tested so far work in Quirky005 / MPlayer:

* 720p WMV3 - working
* 720p,1080p H.264 / AVC (L4.0, L4.1, L5.0) - working
* 720p, 1080p VC-1 - working

_________________
Turbopup Tech Support
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Tue 19 Jan 2010, 20:42    Post_subject:  

Ok, I have fixed the problem of running Mplayer from the menu. As reported, just got two black windows and Xorg hung. That's a very old problem, some kind of conflict with JWM.

No need to change anything in /root/.jwmrc.

Grab this 'mplayershell' script and place at /usr/bin. Make sure it is set as executable.
mplayershell.gz
Description 
gz

 Download 
Filename  mplayershell.gz 
Filesize  638 Bytes 
Downloaded  435 Time(s) 

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 6 Posts_count   Goto page: 1, 2, 3, 4, 5, 6 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0788s ][ Queries: 12 (0.0046s) ][ GZIP on ]