Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 06:43
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
[SOLVED] Boot - ACPI issue on Dell Inspiron 2650
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
Max2

Joined: 10 Feb 2010
Posts: 5

PostPosted: Thu 11 Feb 2010, 12:16    Post subject:  [SOLVED] Boot - ACPI issue on Dell Inspiron 2650  

Hi everybody,

First of all, thanks a lot for the great job. Puppy is so fast, it's amazing! After testing the regular Puppy Linux, I've chosen to full-install the puplet Browser Linux 360 (based on Puppy Linux 4.3.1 / kernel 2.6.30.5 with Firefox 3.6.0) since I'm using my laptop for Internet/streaming/online work only. I love it!

My issue is that Puppy doesn't boot; after GRUB, the computer stucks at the first step ("Starting up..."). I've tested other Linux distros in the past (Ubuntu, Xubuntu, Fedora, TinyMe, Slax, Tiny Core, Sabayon), and from what I remember, the problem pertains to the ACPI layer. I looked up on the Forum and tried different things. I am a newbie so most of these might not be related to my problem at all (I gave it a try when the issue looked similar Wink ):
- noapic
- nolapic
- modprobe apm in the rc.local file
- nopcmcia
- acpi=force
- acpi=strict
None of them worked. I used "debug" to get more details, and here is what I get:

several
system 00:04: ioport range ... has been reserved
two
system 00:04: iomem range ... has been reserved
then
pci 0000:00:01.0: PCI bridge, secondary bus 0000:01
pci 0000:00:01.0: IO window: disabled
pci 0000:00:01.0: MEM window: ...
pci 0000:00:01.0: PREFETCH window: ...
pci 0000:02:04.0: CardBus bridge, secondary bus 0000:03
pci 0000:02:04.0: IO window: ...
pci 0000:02:04.0: IO window: ...
pci 0000:02:04.0: PREFETCH window: ...
pci 0000:02:04.0: MEM window: ...
pci 0000:00:1e.0: PCI bridge, secondary bus 0000:02
pci 0000:00:1e.0: IO window: ...
pci 0000:00:1e.0: MEM window: ...
pci 0000:00:1e.0: PREFETCH window: ...
pci 0000:00:1e.0: setting latency timer to 64
Switched to high resolution mode on CPU 0

and it's stuck there. When using acpi=off, it boots fine but I must manually switch off the computer (shutdown process finishes at "System halted", then I need to press the switch button).

My laptop is a Dell Inspiron 2650:
Pentium IV 1.8GHz, 512 Mo RAM, nVidia Geforce 2GO (32 Mo dedicated), 16 Go hard drive.
The hard drive has two partitions: Puppy on ext4, and swap (about 256Mo). Puppy is the only OS on the laptop.

Thanks in advance!

Last edited by Max2 on Sun 14 Feb 2010, 10:16; edited 2 times in total
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 11 Feb 2010, 12:41    Post subject:  

To avoid the system halted problem; go to /boot/grub/menu.lst.
At the end of the 'kernel' line, add "acpi=force" (no quotes).

Hopefully that will help startup also.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Max2

Joined: 10 Feb 2010
Posts: 5

PostPosted: Thu 11 Feb 2010, 13:06    Post subject: Re: [boot] ACPI issue on Dell Inspiron 2650  

Thank you for the quick answer Smile
I was probably not very clear, but I already tried acpi=force. After a search on the Forum, I tried the following boot options, and they didn't help:
- noapic
- nolapic
- modprobe apm in the rc.local file
- nopcmcia
- acpi=force
- acpi=strict

In all of these cases, the computer doesn't boot and stops at "Starting up...". I hope the "debug" option can give you more details on where it actually stops (see my first message). The only way I manage to boot is using acpi=off, but then I have the "system halted" thing. Any idea?
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 11 Feb 2010, 13:31    Post subject:  

1. You can boot to the desktop by using acpi=off?

2. That is when you open /boot/grub/menu.lst and modify the
kernel line.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Max2

Joined: 10 Feb 2010
Posts: 5

PostPosted: Thu 11 Feb 2010, 18:21    Post subject:  

rjbrewer wrote:
1. You can boot to the desktop by using acpi=off?
2. That is when you open /boot/grub/menu.lst and modify the
kernel line.

Yep, we're on the same wavelength Wink
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 11 Feb 2010, 18:37    Post subject:  

Max2 wrote:
rjbrewer wrote:
1. You can boot to the desktop by using acpi=off?
2. That is when you open /boot/grub/menu.lst and modify the
kernel line.

Yep, we're on the same wavelength Wink


Let me know if it helps at all.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Max2

Joined: 10 Feb 2010
Posts: 5

PostPosted: Thu 11 Feb 2010, 19:50    Post subject:  

rjbrewer wrote:
Max2 wrote:
Yep, we're on the same wavelength Wink
Let me know if it helps at all.

OK, so maybe we weren't exactly on the same Laughing
Yes, I am currently booting all the way to the desktop using acpi=off.

I have this option in the menu.lst file so I don't have to edit the boot command every time I start up my computer, but there is no difference in having the option written in the menu.lst or editing the boot command manually in GRUB at start up. I tried the 5 different options above in the boot command, each by itself (without acpi=off), and none of them managed to boot. I also tried noapic nolapic together -- same (absence of) result, and the "modprobe apm" in rc.local, idem.

Maybe some sort of combination will work, but which one? Or something completely different? I don't know which part of the ACPI is not working properly. If I could identify it, it might be possible to load the rest of the ACPI except the problematic part -- but I don't know how to do that. Or if somebody knows how to load just the small part that allows the system to shutdown (and let the rest of the ACPI R.I.P.), that will solve the issue too Very Happy
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 11 Feb 2010, 20:14    Post subject:  

I would try an earlier puppy, 4.1.2 would be good; and not one
of the puplets or derivatives.
With your system you won't notice any difference in speed
between the stripped down version you have now and a larger
one anyway.

Try these instructions if you're doing a full install.

http://www.murga-linux.com/puppy/viewtopic.php?p=201565&search_id=1358540782#201565

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 607
Location: Chatswood, NSW

PostPosted: Thu 11 Feb 2010, 21:56    Post subject:  

G'day max2,

I had your problem but the fix in the link has worked on my acpi=off booting desktop in every new Pup and Puplet

http://www.murga-linux.com/puppy/viewtopic.php?t=46934

The line number in rc.sysinit is slowly increasing - it's about line 250 now.

This situation is just a bit annoying that I have to add the power_off=1 in every new Puplet, so I assume it's a Linux kernel problem?

David S.
Back to top
View user's profile Send private message 
Max2

Joined: 10 Feb 2010
Posts: 5

PostPosted: Sun 14 Feb 2010, 10:12    Post subject:  

I haven't been able to access the forum for few days, and in the meantime I've found a solution:

Boot with pci=noacpi option.

That's not the same than acpi=off/noacpi/nolapic; the computer boots fine, ACPI is partially loaded, and the system switches off completely. David45, I might try your solution too, but I'm hesitant to fix something that's working (for now)... Confused I don't know if my solution would work on another computer, so it's good to have several options for the same problem (which seems to originate from hardware variously compatible with the ACPI layer of the Linux kernel).

Anyway, thanks again for the answers Wink
Back to top
View user's profile Send private message 
jon_sable

Joined: 14 Apr 2010
Posts: 1

PostPosted: Wed 14 Apr 2010, 23:45    Post subject: [SOLVED] Boot - ACPI issue on Dell Inspiron 2650  

Hey, just wanted to say Thanks! to Max2

Just edited the file with pci=noacpi option, i could boot via cd with the acpi=off, and reenter everything, like xorg config each time...

Your post worked. edited /boot/grub/menu.lst with ^no pci=noacpi!

The notebook, Dell Inspiron 2650 128ram, is my 80 year old father's, so i didn't want him to have to boot via cd.

Now my slight gripe is at the grub prompt i have to hit enter, to boot off hd.

Anyway thanks again Max2


----
Max2 Posted: Sun 14 Feb 2010, 10:12 Post subject:

I haven't been able to access the forum for few days, and in the meantime I've found a solution:

Boot with pci=noacpi option.

That's not the same than acpi=off/noacpi/nolapic; the computer boots fine, ACPI is partially loaded, and the system switches off completely. David45, I might try your solution too, but I'm hesitant to fix something that's working (for now)... I don't know if my solution would work on another computer, so it's good to have several options for the same problem (which seems to originate from hardware variously compatible with the ACPI layer of the Linux kernel).

Anyway, thanks again for the answers
Back to top
View user's profile Send private message 
looseSCREWorTWO

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Thu 15 Apr 2010, 03:33    Post subject:  

jon_sable wrote:
Quote:
Now my slight gripe is at the grub prompt i have to hit enter, to boot off hd.


The answer to your slight gripe is to edit menu.lst in /mnt/home/boot/grub and change this line:
#timeout 30

to this:

timeout 0

Then add this line underneath it:

default 0

This will boot up your PC (without the Grub menu appearing) into whatever is your first menu item. To go straight into your second menu item you'd say

default 1
Back to top
View user's profile Send private message 
Jeeco

Joined: 07 Mar 2014
Posts: 1

PostPosted: Fri 07 Mar 2014, 07:23    Post subject: Puppy Precise 5.7.1
Subject description: Start-up/shut-down problem with Dell Inspiron 2650
 

Hi folks, I´m really a newcomer on Linux and even less an expert and swell I know that the issue is solved but it might be interesting to some other people like me.
I had a little hard time for a couple of days.
At first I had this start-problem from cd.
When the first Puppy-picture comes there is the choice to select F2 or F3.
After some reading and a couple of trials I typed Puppy pci=noacpi which is not in the list under F2 and I got it running from cd.
The I installed it on HD and it kept hanging on start up.
So I prolonged the kernel-line in mnt/sda.../boot/grub/menu.1st like
...sda2 pmedia=atahd pci=noacpi and WOW! it started.
Then I had this well-known shut-down problem.
Again a lot of reading and again I tried to prolong the mentioned kernel-line like
...sda2 pmedia=atahd pci=noacpi acpi=force and it´s shutting down perfectly.
Apart all that it´s a nice OS which boots in less than 45secs and runs fast like a rabbit, not like me former XP.
Thanks to You all! Jeeco
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0705s ][ Queries: 11 (0.0032s) ][ GZIP on ]