Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 18:37
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
No backlight variation on Acer laptop
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Fri 12 Feb 2010, 05:22    Post_subject:  No backlight variation on Acer laptop  

Hi everybody,
Acer Aspire 5310, intel gma950, puppies 4.31,kernel 2.6.30.5 (wow, how synthetic I am Smile )....problem as subject, there is no way to change backlight intensity...with old 2.6.25 kernel it used to work, now dmesg reports "ACPI: failed to switch brightness, must be controlled by generic driver" (maybe the words are not correct, as I'm not on that laptop at the moment, but that's the sense...).
Any idea?
Back to top
View user's profile Send_private_message 
itzme

Joined: 28 Jan 2010
Posts: 15

PostPosted: Thu 04 Mar 2010, 05:56    Post_subject:  

eden6000,

I have the same problem with 4.31 NOP, but form time to time it does actually work, I find that Fn+F6 works turning the light off and on ok, though I do have a problem with booting with low intensity even in the bios, googling came up with this as a fault with the lcd backlight inverter, if that is the case their around $40-$50 mark for a replacement unit.
Back to top
View user's profile Send_private_message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Thu 04 Mar 2010, 07:46    Post_subject:  

Hi itzme, I don't think it's a hardware problem, ubuntu on the same machine is able to change brightness level....
As for your problem, sometimes I've happened to boot and the screen was totally dark, in that case I had to turn the laptop off removing also the battery, then it worked again.
Back to top
View user's profile Send_private_message 
jairomacon

Joined: 21 Apr 2010
Posts: 3

PostPosted: Fri 23 Apr 2010, 14:12    Post_subject:  

I think the kext is responsible for this.. as long as the kext is not loaded to the brightness It can be changed using the function keys.In intel gma950 ,you know that the function keys change the value of the register but somehow it gets ignored.. this is my best guess that the gma950 driver overrides the value or it has a trap on register and manually changes it back to max. try to change the kext.
_________________
Where there is will there is way.
Back to top
View user's profile Send_private_message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Mon 26 Apr 2010, 08:25    Post_subject:  

Thanks for your reply jairomacon...at the moment I have removed puppy from that laptop (I still have it on the desktop, btw Wink ), so I cannot try what you suggest...anyway, what is kext??
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0426s ][ Queries: 11 (0.0039s) ][ GZIP on ]