Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 14:53
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
XnView MP 0.39 and XnConvert MP 1.1 combo sfs
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 08:20    Post subject:  

Hello,
Great! Thank you a lot for your kind attention!
(I uploaded files from the official site, edited the sfs file and tried to add "language" directory inside, reboot... but this didn't work Crying or Very sad. In the Settings box/Language, just English (en) appears, nothing else...)

Cordialement!

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 14 May 2011, 08:29    Post subject:  

Argolance. I did the same, lol. I thought it was the only needed action. Now I tested with same results.

Sorry for being too hasty to upload. I will investigate the locales problem more.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 08:33    Post subject:  

Hello,
Sorry Embarassed, but I have the same problem (described above!) with the locales sfs! Languages files probably have to be copied somewhere else...
I have to go just now and will try on my side later.

Regards!

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 14 May 2011, 08:38    Post subject:  

Problem with locales solved. You need to run the xnview.sh script.

I think that sfs does not handle pinstall.sh scripts so you need to do that manually. Script is attached. Rename the phony .gz to .sh
xnview.gz
Description 
gz

 Download 
Filename  xnview.gz 
Filesize  152 Bytes 
Downloaded  406 Time(s) 
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 09:49    Post subject:  

Hello,
Thank you.
This attached script "xnview.sh" (as well as "xnconvert.sh)" are already present in /usr/bin directory! I don't know if the *.desktop files should not be modified and run these *.sh files, instead of xnview and xnconvert? Anyway, this doesn't work for me... Did I forget something?

Regards.

_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 10:03    Post subject:  

Hello,
Something else: Isn't it very strange, after sfs file has been mounted, xnview directories (AddOn, language, plugins, UI ...) to be located directly at the root of /usr/directory and not in any dedicated directory?

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 14 May 2011, 10:13    Post subject:  

Well, yes. I should for example create /usr/local/xnview and place all subfolders there. Good point. I will modify the sfs.

About. Locale. I got them shown in settings > language or how it was in the submenu.

I will reupload the sfs to have better location xnview folders.

Thank you of your feedback !!!
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 10:41    Post subject:  

hello,
Quote:
About. Locale. I got them shown in settings > language or how it was in the submenu.
It doesn't work for me: nothing in the submenu and the application is always in English Evil or Very Mad ! I forgot something?

Regards.

_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 14 May 2011, 10:54    Post subject:  

Hello,
Quote:
I think that sfs does not handle pinstall.sh scripts so you need to do that manually. Script is attached. Rename the phony .gz to .sh
I noticed that the original *.desktop file I downloaded from the official site runs xnview.sh and not xnview. You probably should modify yours this way (no pinstall.sh and script specified in the first post needed!)

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 14 May 2011, 12:06    Post subject:  

Argolance. You are absolutely right. I rebuild the package. Thank you of your evaluation and problem solving.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 14 May 2011, 12:50    Post subject:  

Xnview and Xnconvert with locales sfs has been reuploaded.
I dont seem to get languages activated again. I managed to do that once when experimenting with locales. But I dont know atm what is the clue for that.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 15 May 2011, 04:57    Post subject:  

Hello,
Quote:
I dont seem to get languages activated again. I managed to do that once when experimenting with locales. But I dont know atm what is the clue for that.
I saw on a thread that locales don't work yet on LINUX releases of xnview, but work only with Windows releases. We have just now to wait for the final releases...

Regards.

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 15 May 2011, 08:23    Post subject:  

Argolance. Thank you of the information. I have followed the xnview development....but it is so slow that nowadays I check the xnview forum about 3 months intervals. If someone finds before me that there is update, you can announce it here or pm me. I will make sfs of new version immediately. The forum notification works sometimes.

Otherwise I like the xnview already.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 15 May 2011, 14:00    Post subject:  

Hello,
Quote:
I saw on a thread that locales don't work yet on LINUX releases of xnview, but work only with Windows releases. We have just now to wait for the final releases...
I was wrong!
The solution was given by M�dor in the French Forum: copy/move the /usr/local/xnview/language directory into /usr/bin or create a symlink from /usr/local/xnview/language to /usr/bin.

Regards.

_________________

Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 15 May 2011, 14:51    Post subject:  

Argolance. Thank you of your efforts and time used for problem solving. I will test it and upload the sfs if it works.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0746s ][ Queries: 12 (0.0105s) ][ GZIP on ]