Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 13:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Wine
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 30 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 28, 29, 30 Next
Author Message
green_dome

Joined: 05 Jan 2009
Posts: 204

PostPosted: Tue 06 Jul 2010, 18:16    Post_subject: Wine 1.2-rc6  

my attempt at compiling wine 1.2-rc6

wine-1.2-rc6-i486.pet (release 1) - [link 1]
wine_DEV-1.2-rc6-i486.pet (release 1) (development package) - [link 1]
wine_DOC-1.2-rc6-i486.pet (release 1) (documentation package) - [link 1]
wine-1.2-rc6-i486-sfs3.sfs (release 1) - [link 1]
wine-1.2-rc6-i486-sfs4.sfs (release 1) - [link 1]

-------------------------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
I specifically used the files:
puppies-431.1-main-Xserver.iso
devx_430.sfs

puppies-431.1-main-Xserver.iso - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

devx_430.sfs - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

-------------------------------

Files located at <http://puppylinux.asia/> require a login.
(Username=puppy) (Password=linux)

I installed these packages before compiling:

esound-0.2.41-i486.pet
<http://puppylinux.asia/members/T/486_pet/esound-0.2.41-i486.pet>

esound_DEV-0.2.41-i486.pet
<http://puppylinux.asia/members/T/486_pet/esound_DEV-0.2.41-i486.pet>

fontconfig-2.7.1-i486-pup4.pet
<http://petstore.puppyspace.org/s4/system/fontconfig-2.7.1-i486-pup4.pet>

fontconfig_DEV-2.7.1-i486-pup4.pet
<http://petstore.puppyspace.org/s4/system/fontconfig_DEV-2.7.1-i486-pup4.pet>

gnutls+deps-2.6.6-i486.pet
<http://puppylinux.asia/members/T/444/gnutls+deps-2.6.6-i486.pet>

gnutls+deps_DEV-2.6.6-i486.pet
<http://puppylinux.asia/members/T/444/gnutls+deps_DEV-2.6.6-i486.pet>

jack-audio-connection-kit-0.116.1-i486.pet
<http://puppylinux.asia/members/T/444/jack-audio-connection-kit-0.116.1-i486.pet>

jack-audio-connection-kit_DEV-0.116.1-i486.pet
<http://puppylinux.asia/members/T/444/jack-audio-connection-kit_DEV-0.116.1-i486.pet>

openldap-2.4.13-i486.pet
<http://puppylinux.asia/members/T/444/openldap-2.4.13-i486.pet>

openldap_DEV-2.4.13-i486.pet
<http://puppylinux.asia/members/T/444/openldap_DEV-2.4.13-i486.pet>

xorg_xorg_full_dri-7.3.pet
<ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri-7.3.pet>

xorg_xorg_full_dri_DEV-7.3.pet
<ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri_DEV-7.3.pet>

-------------------------------

When compiling, I used
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'. The only changes I made to the contents of that file were to delete the file 'Wine_regedit.desktop'. That appears to be a duplicate file. I also deleted the file 'winetricks' and replaced it with the updated one.

For help with Gecko, look here

I use the console to install packages from winetricks. For help with this I use
Code:
winetricks -h
[source]

my graphics card is a Nvidia GeForce 8400GS, so I install the 'NVIDIA-190.42-k2.6.30.5-1.pet' from this post.
Back to top
View user's profile Send_private_message Visit_website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Wed 07 Jul 2010, 12:45    Post_subject:  

Dear green_dome,

Just so you know, your latest (rc6) installed fine in 3.x and 4.x. Again a big thank you.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
Flapdoodle

Joined: 03 Jul 2008
Posts: 32

PostPosted: Thu 08 Jul 2010, 16:44    Post_subject:  

Works great with Turbopup Extreme 1.0
Thanks!
Back to top
View user's profile Send_private_message 
Nooblet0218

Joined: 21 May 2010
Posts: 103

PostPosted: Thu 08 Jul 2010, 16:54    Post_subject:  

sweet, works very well in lupu thank you!!!
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sat 10 Jul 2010, 17:55    Post_subject:  

Dear green_dome,

RC7 is out now, but you might want to wait for 1.2 final, which is just around the corner.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
green_dome

Joined: 05 Jan 2009
Posts: 204

PostPosted: Tue 13 Jul 2010, 01:47    Post_subject: Wine 1.2-rc7  

my attempt at compiling wine 1.2-rc7

wine-1.2-rc7-i486.pet (release 1) - (mirror 1)
wine_DEV-1.2-rc7-i486.pet (release 1) (development package) - (mirror 1)
wine_DOC-1.2-rc7-i486.pet (release 1) (documentation package) - (mirror 1)
wine-1.2-rc7-i486-sfs3.sfs (release 1) - (mirror 1)
wine-1.2-rc7-i486-sfs4.sfs (release 1) - (mirror 1)

-------------------------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
I specifically used the files:
puppies-431.1-main-Xserver.iso
devx_430.sfs

puppies-431.1-main-Xserver.iso - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

devx_430.sfs - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

-------------------------------

Files located at <http://puppylinux.asia/> require a login.
(Username=puppy) (Password=linux)

I installed these packages before compiling:

esound-0.2.41-i486.pet
<http://puppylinux.asia/members/T/486_pet/esound-0.2.41-i486.pet>

esound_DEV-0.2.41-i486.pet
<http://puppylinux.asia/members/T/486_pet/esound_DEV-0.2.41-i486.pet>

fontconfig-2.7.1-i486-pup4.pet
<http://petstore.puppyspace.org/s4/system/fontconfig-2.7.1-i486-pup4.pet>

fontconfig_DEV-2.7.1-i486-pup4.pet
<http://petstore.puppyspace.org/s4/system/fontconfig_DEV-2.7.1-i486-pup4.pet>

gnutls+deps-2.6.6-i486.pet
<http://puppylinux.asia/members/T/444/gnutls+deps-2.6.6-i486.pet>

gnutls+deps_DEV-2.6.6-i486.pet
<http://puppylinux.asia/members/T/444/gnutls+deps_DEV-2.6.6-i486.pet>

jack-audio-connection-kit-0.116.1-i486.pet
<http://puppylinux.asia/members/T/444/jack-audio-connection-kit-0.116.1-i486.pet>

jack-audio-connection-kit_DEV-0.116.1-i486.pet
<http://puppylinux.asia/members/T/444/jack-audio-connection-kit_DEV-0.116.1-i486.pet>

openldap-2.4.13-i486.pet
<http://puppylinux.asia/members/T/444/openldap-2.4.13-i486.pet>

openldap_DEV-2.4.13-i486.pet
<http://puppylinux.asia/members/T/444/openldap_DEV-2.4.13-i486.pet>

xorg_xorg_full_dri-7.3.pet
<ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri-7.3.pet>

xorg_xorg_full_dri_DEV-7.3.pet
<ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri_DEV-7.3.pet>

-------------------------------

When compiling, I used
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'. The only changes I made to the contents of that file were to delete the file 'Wine_regedit.desktop'. That appears to be a duplicate file. I also deleted the file 'winetricks' and replaced it with the updated one.

For help with Gecko, look here

I use the console to install packages from winetricks. For help with this I use
Code:
winetricks -h
[source]

my graphics card is a Nvidia GeForce 8400GS, so I install the 'NVIDIA-190.42-k2.6.30.5-1.pet' from this post.
Back to top
View user's profile Send_private_message Visit_website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Tue 13 Jul 2010, 16:33    Post_subject:  

Dear green_dome,

Works well, as expected, in 3.x and 4.x - so I am very happy.

I think 1.2 final will be out soon.

Thanks.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
looseSCREWorTWO

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Thu 15 Jul 2010, 05:37    Post_subject:  

Thank you guys, once again.

I know if Wine has been compiled by green_dome and tested by vovchik, it will almost certainly work OK on my Puppy 431 Retro.

_________________
Steve
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 15 Jul 2010, 05:57    Post_subject:  

I will test to use it on puppeee and report back.

sorry it says

NOTICE: This is an older version 3.x squashfs file, not usable.
All Linux kernels 2.6.29 or later require version 4.x squashfs files.
Note, there is an SFS-version-converter in the Utility menu, run that first.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
green_dome

Joined: 05 Jan 2009
Posts: 204

PostPosted: Thu 15 Jul 2010, 16:59    Post_subject:  

There is are two sfs files available, one for sfs3 and one for sfs4.
Yes, the 'SFSconvert version converter' application is quite useful.
Back to top
View user's profile Send_private_message Visit_website 
green_dome

Joined: 05 Jan 2009
Posts: 204

PostPosted: Sat 17 Jul 2010, 00:23    Post_subject: Wine 1.2  

my attempt at compiling wine 1.2

wine-1.2-i486.pet (release 1) - (mirror 1)
wine_DEV-1.2-i486.pet (release 1) (development package) - (mirror 1)
wine_DOC-1.2-i486.pet (release 1) (documentation package) - (mirror 1)
wine-1.2-i486-sfs3.sfs (release 1) - (mirror 1)
wine-1.2-i486-sfs4.sfs (release 1) - (mirror 1)

-----------------------------------------------------------------------------------------------------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
I specifically used the files:
puppies-431.1-main-Xserver.iso
devx_430.sfs

puppies-431.1-main-Xserver.iso - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

devx_430.sfs - [forum post] [mirror 1] username:puppy | password:linux (you will have to type it twice) [mirror 2] [mirror 3]

-----------------------------------------------------------------------------------------------------------

Files located at (http://puppylinux.asia/) require a login.
(Username=puppy) (Password=linux)

I installed these packages before compiling:

esound-0.2.41-i486.pet
(http://puppylinux.asia/members/T/486_pet/esound-0.2.41-i486.pet)

esound_DEV-0.2.41-i486.pet
(http://puppylinux.asia/members/T/486_pet/esound_DEV-0.2.41-i486.pet)

fontconfig-2.7.1-i486-pup4.pet
(http://petstore.puppyspace.org/s4/system/fontconfig-2.7.1-i486-pup4.pet)

fontconfig_DEV-2.7.1-i486-pup4.pet
(http://petstore.puppyspace.org/s4/system/fontconfig_DEV-2.7.1-i486-pup4.pet)

gnutls+deps-2.6.6-i486.pet
(http://puppylinux.asia/members/T/444/gnutls+deps-2.6.6-i486.pet)

gnutls+deps_DEV-2.6.6-i486.pet
(http://puppylinux.asia/members/T/444/gnutls+deps_DEV-2.6.6-i486.pet)

jack-audio-connection-kit-0.116.1-i486.pet
(http://puppylinux.asia/members/T/444/jack-audio-connection-kit-0.116.1-i486.pet)

jack-audio-connection-kit_DEV-0.116.1-i486.pet
(http://puppylinux.asia/members/T/444/jack-audio-connection-kit_DEV-0.116.1-i486.pet)

libgphoto2-2.4.6-pup4.pet
(http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/libgphoto2-2.4.6-pup4.pet)

libgphoto2_DEV-2.4.6-pup4.pet
(http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/libgphoto2_DEV-2.4.6-pup4.pet)

openldap-2.4.13-i486.pet
(http://puppylinux.asia/members/T/444/openldap-2.4.13-i486.pet)

openldap_DEV-2.4.13-i486.pet
(http://puppylinux.asia/members/T/444/openldap_DEV-2.4.13-i486.pet)

xorg_xorg_full_dri-7.3.pet
(ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri-7.3.pet)

xorg_xorg_full_dri_DEV-7.3.pet
(ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_full_dri_DEV-7.3.pet)

-----------------------------------------------------------------------------------------------------------

When compiling, I used
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'. The only changes I made to the contents of that file were to delete the file 'Wine_regedit.desktop'. That appears to be a duplicate file. I also deleted the file 'winetricks' and replaced it with the updated one.

For help with Gecko, look here

I use the console to install packages from winetricks. For help with this I use
Code:
winetricks -h
[source]

my graphics card is a Nvidia GeForce 8400GS, so I install the 'NVIDIA-190.42-k2.6.30.5-1.pet' from this post.
Back to top
View user's profile Send_private_message Visit_website 
Jasper


Joined: 25 Apr 2010
Posts: 1145
Location: England

PostPosted: Sat 17 Jul 2010, 11:42    Post_subject:
Sub_title: 1.2 Final
 

Hi green-dome

Thank for your 1.2 update today which I installed in Lucid Puppy 5.0.0

My regards
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sat 17 Jul 2010, 12:44    Post_subject:  

Dear green_dome,

Wine is getting better and better. Thanks for this compile. Works nicely in 3.x and 4.x, as is usual for your versions.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1145
Location: England

PostPosted: Sun 18 Jul 2010, 08:19    Post_subject:
Sub_title: Wine 1.0.1
 

Hi again green_dome

I have two Windows programs - which work perfectly using Wine 1.0.1 from Xubuntu, but one, Kalender (a calendar/reminder/to-do program), does not work at all using Wine 1.2 and the other works imperfectly.

So I would like to try Wine 1.0.1 from Lucid Puppy 5.0.0 and I wonder if you could direct me to a suitable installation download, but, if that is not already available, please do not write a special program just for me.

My regards

_________________
Desktop (1998 with 2002 Motherboard replacement) @ 2.0 GHz with 640 MB (SDRAM).
Precise 5.6 with Multi-session-Live-CD/DVD + W98SE solely for rare printing needs.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 18 Jul 2010, 09:35    Post_subject:  

I am now on Acer Netbook and use Puppeee and Quirky 1.0 both with

Wine 1.1.40 Rc7 and you guys talk about Wine 1.2.

How does the newest differ from the older?

What would be better?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 5 of 30 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 28, 29, 30 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1041s ][ Queries: 12 (0.0063s) ][ GZIP on ]