Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 05:08
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Quirky 018 feedback
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 14 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Author Message
Hesse James


Joined: 08 Feb 2010
Posts: 44

PostPosted: Thu 15 Apr 2010, 01:30    Post_subject: Nvidia Closed Source drivers for Quirky  

Good morning Barry
Sorry for the late response. Generally I am interested in having the Closed Source Nvidia graphic drivers on board (or at least installable).
Reason is: I owe a HTPC with Soundgraph Imon VFD/RC and a Nvidia Chipset 9300. My intention is to build finally an alternative for my XP operation system which is too slow at the moment for HDTV despite CUDA-accelerated H.264 codec. I expect that VDPAU ist necessary to keep the used CPU resources as low as possible. VDPAU acceleration is only possible with the original NVIDIA drivers, patched mplayer, additional VDPAU packages available for Ubuntu and others...
My experience so far:
gray's PETs and the NVIDIA istaller work on 4.31 or earlier.
WOOF based Puplets: Nearly all newer WOOF based Puplets have problems with the NVIDIA-installer because of a gcc version mismatch the kernel was compiled with and the development system is equiped with. Quirky and LUPU6 refuse the installation because of that. UPUP and DPUP allow a continuation of the installation but crash if switching to 24 bit graphics (16bit works). All PET installations fail because of an interference with my Imon. USB/HID driver missing message despite installed...
So far only the attempt of Iguleder worked for me.
Kernel recompilation sometimes fail so that I didn't follow that because of lack of time.
Latest version so far is NVIDIA-Linux-x86-195.36.15-pkg1.run
Christian
Back to top
View user's profile Send_private_message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Thu 15 Apr 2010, 11:25    Post_subject: Booting quirky-018 from an IDE drive on the Edubook  

Barry, I tested the RDC IDE driver for the Edubook that you actuated in the kernel.

I bought a short ribbon cable and had no problem booting quirky-018 from a Toshiba 1GB CF card in a CF-to-IDE adapter mounted in the Edubook.

Note however that in order to fit the bottom plate, I had to cut away the plastic lock from the ribbon cable's standard IDC connector (on the motherboard end), otherwise it was too high! Figures... Rolling Eyes

Anyway, the IDE interface seems to work perfectly.

The output of 'cat /proc/scsi/scsi':
Code:
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: SA04G     RDC SD Rev: 0100
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: TOSHIBA THNCF1G0 Rev: 3.00
  Type:   Direct-Access                    ANSI  SCSI revision: 05

Also, I didn't have to choose the boot order - it booted directly from the CF card, ignoring the inserted (bootable) SD card.

_________________
Testing Puppy since v0.9.2 - my desktop OS since v1.0.7
Running SlaxerPup-4.12 - Puppy with a Slackware 12.2 heart Cool
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Thu 15 Apr 2010, 11:53    Post_subject: Patch needed to kernel 2.6.33.2 source code
Sub_title: aufs needs this to compile
 

Overnight I've been compiling an rt version of the Puppy 2.6.33.2 kernel (still going), and have found an error in the aufs source code.

In file fs/aufs/file.h, line 102, aufs_release_nondir is defined, but in the two sourcefiles which include file.h and use aufs_release_nondir (fs/aufs/f_op.c and f_op_sp.c) aufs_release_nondir is redefined.

This stops the make. By commenting-out line 102 of file.h, i.e. making the snippet look like
Code:
/* f_op.c */
extern const struct file_operations aufs_file_fop;
int aufs_flush(struct file *file, fl_owner_t id);
int au_do_open_nondir(struct file *file, int flags);
/* int aufs_release_nondir(struct inode *inode __maybe_unused, struct file *file); */
the make proceeds.

I will report back in a few hours on whether Quirky-018 with this corrected aufs will frugal-boot or not. It might require rebuilding the initrd.gz by hand as well, we'll see.

Edited_time_total
Back to top
View user's profile Send_private_message 
fyujj

Joined: 04 Apr 2009
Posts: 103

PostPosted: Fri 16 Apr 2010, 09:25    Post_subject:
Sub_title: Brazilian keyboard layout.
 

I don't know if these were reported (one of the two must have been).
First issue is with the Brazilian keyboard layout set-up in Puppy 5 series (Quirky 018, Lupu 004).
First, at the keyboard configuration page there are some odd options: br-abnt, br-abnt2, br-latin1-abnt2(?) and br-latin1-us(?). I'm no expert but as far as I know abnt2 is a layout, not a model. Usually the options would be (from the earliest to the most recent): br-latin1, br-abnt and br-abnt2 (default keyboard layout in Brazil for years now).
Up to Puppy 4.2, there was only br-latin1 and br-abnt options and one would have to open keyboard setup and choose abnt2 layout to setup this (most common) keyboard. This was fixed in Puppy 4.3.
*Important* Now any of the offered setups even work with the abnt2 keyboard (not even br-abnt2). It must be set through Setup > Change the mouse and keyboard and even this tool must be fixed in this respect: first there's apparently a major and general bug (this one that most probably was reported already) when one changes the keyboard from Choose keyboard layout for your country... option. This goes to a blue and gray screen of death, that one can get out with C+A+Bsp but then X wont load anymore (needs a reboot for an ignorant like me, even running Xorgwizard doesn't solve it). The other bug, this related to the BR keyboard setup, is that if one opens Advanced Xorg keyboard configuration... > Layouts and chooses br it doesn't work (this should enable by default the br-abnt2 layout). For it to work properly one must open Keyboard Model and choose Brazilian abnt2.

Regards and thank you.
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 16 Apr 2010, 11:21    Post_subject: This "bones+woof" thing-y is fabulous...  

Cool Cool Cool

This bones + woof buildsystem, once you figure out 0setup and the DISTRO_PKGS_SPECS-{distro}-{version} syntax, and get the hang of turning .deb packages into .pets, is a fabulous work of absolute genius...

One rt-smp 2.6.33.2 version of Lucid, based on April 15 Bones and Woof, coming up soon...presently on "cups" in 2createpackages...

Edited_time_total
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 16 Apr 2010, 12:55    Post_subject: *** APPLAUSE *** ***WILD CHEERS***  

Quote:
processing faad_2.7-4_i386.deb
processing libfaad-dev_2.7-4_i386.deb
Processing libfaad0
(error message about the correct libfaad .pet not being present in packages-pet)

Wow. 2createpackages even discovered that I had made a .pet package of libfaad0, when the version specified in DISTRO-PKGS_SPECS-ubuntu-lucid is libfaad2...

...and then, after I control-c'ed out of 2createpackages and corrected the libfaad (faad) entry in DISTRO-PKGS_SPECS-ubuntu-lucid,... with bated breath I tried starting 1download again, and it actually went out and *just* downloaded the single missing libfaad2_2.7-4_i386.deb package!...

Exclamation Shocked Very Happy !!! I am IMPRESSED !!! Very Happy Shocked Exclamation

Hoo man-o-man this thing is built like a brick ...table lamp, isn't it!!!

Edited_times_total
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 16 Apr 2010, 12:59    Post_subject: A suggestion for 0setup
Sub_title: Have it do the same syntax-check as 2createpackages
 

Suggestion:

Have 0setup do the same syntax-check of PKGS_SPECS_TABLE that 2createpackages does near its beginning.

This would have saved me quite a bit of eyestrain late last night, when I neglected to place a '|' after the yes in the entry for the libxtrap .pet I made, and thus kept getting the

Quote:
FAIL: exe
FAIL: dev
FAIL: doc
FAIL: nls

mystery sequence in 0setup.

The string 'yeslibxtrap' is very hard to distinguish among a long list of similars from 'yes|libxtrap'...whereas the syntax check, if it were placed prior to commencement of the check for nonexistent packages, would have spared me having to closely examine the entirety of PKGS_SPECS_TABLE...

Edited_time_total
Back to top
View user's profile Send_private_message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Fri 16 Apr 2010, 13:39    Post_subject:  

Hello Barryk,

Wary19: Touchpad tapping/ double tap works from the get go however there is no touchpad scrolling, i've tried some different xorg.conf configurations but no joy yet . If i remember right Quirky13 double tap /scrolling worked ok .

p.s great wary wallpaper choice Smile

cheers.
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 16 Apr 2010, 14:58    Post_subject: Suggestion for 2createpackages
Sub_title: Give the user the option to resume where broken off
 

Another suggestion:

For cases like in my second post above, where 2createpackages errors-out due to incorrect library version specified in DISTRO_PKGS_SPECS-ubuntu-lucid (e.g. libfaad0 where libfaad2 is specified in Packages-ubuntu-lucid-universe/multiverse/main) and so the user goes back into DISTRO_PKGS_SPECS and corrects the libfaad(n) entry to match the Packages-ubuntu-lucid-universe/mulltiverse/main specified version...

...it would be nice if 2createpackages were to give the user the option to resume from where left off, rather than waste half an hour to three hours starting from the top and doing the whole creation process over again, or having to go back after finished and rebuild singly the error'ed-out packages.

I know, I know, some people want instant gratification...

But when you're this close to perfection, it's hard not to ask for it...
Back to top
View user's profile Send_private_message 
JustGreg

Joined: 24 May 2005
Posts: 666
Location: Connecticut USA

PostPosted: Fri 16 Apr 2010, 19:57    Post_subject:
Sub_title: Wary 019 and MMS
 

I did a frugal Wary 019 install to my VFAT USB hard drive. It started and work well on my Acer Aspire Revo. We still need the Nvidia video driver. Hopefully Gray can do an update for the new kernel. Thanks in advance for any help on this one.

I also checked PupRadio. KNIK, which is a MMS station works now. It did not work in Quirky 018. However, the Gulch receiver still does not work. It appears that CFGP is no longer available. I get a failure to connect on that URL. The Gulch URL connects, but no audio output even though data is being receiver. I tried changing the cache size and mixer selection (oss or alsa) without any luck.

I would like to try the present 4.3.1 Gxine pet in Wary with the Gulch URL. But, I am not sure if the pet will work properly with the new kernel version.

It and Quirky work well with my Acer Aspire One net book.

_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send_private_message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Fri 16 Apr 2010, 20:45    Post_subject:  

Here is a "Gulch" stream I found in my bookmarks.
Works fine regular stream or win-amp stream using
gxine on my 4.1.2 install.

http://shortwavepirate.info/pw/wordpress/the-gulch/

Cfgp.........doesn't need a player.

http://radiotime.com/station/s_7608/Rock_977.aspx

I tried to install vlc or gxine to quirky; couldn't get it to work.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 
LoneRifle

Joined: 16 Jan 2010
Posts: 9

PostPosted: Sat 17 Apr 2010, 06:23    Post_subject: Seems like Xorg vesa driver has a problem...  

Wary 019: Xorg vesa driver seems to be problematic, see quote. Also unable to power off automatically. Again, this is tested on my non-Norhtec Edubook, so other Edubook users may have different results..

Quote:
X: symbol lookup error: /usr/X11R7/lib/xorg/modules/drivers//vesa_drv.so: undefined symbol: xf86GTFMode
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sat 17 Apr 2010, 09:32    Post_subject:  

[url]
http://radiotime.com/station/s_7608/Rock_977.aspx[/url]
That one and others at radiotime works for me using q18 but I have installed mplayer 3.85 something so that maybe take care of such?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Sat 17 Apr 2010, 11:14    Post_subject:  

nooby wrote:
[url]
http://radiotime.com/station/s_7608/Rock_977.aspx[/url]
That one and others at radiotime works for me using q18 but I have installed mplayer 3.85 something so that maybe take care of such?


Installed Muppymplayer and it will do that http stream from the link,
but not from pup-radio-telly.
Still not possible to enable mms.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send_private_message 
upnorth


Joined: 11 Jan 2010
Posts: 262
Location: Wisconsin UTC-6 (-5 DST)

PostPosted: Sat 17 Apr 2010, 12:08    Post_subject: desktop mirror effect in a webpage - seamonkey
Sub_title: wary seamonkey2.04
 

The website's picture was replaced with a thumbnail image of the desktop that updates, but the tab preview thumbnail image shows the sites intended picture.:
Smile
I had noscript activated too and privoxy on full choke so I don't think it was a script doing it.

This seamonkey is mozilla's build, and I've only seen this happen on one site.

from about:buildconfig
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c307a617e5a5

Solved: After killing conky(1.7.2) and restarting conky the problem is gone. Probably the pseudo transparency data getting mixed up with seamonkey somehow.

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 14 of 17 Posts_count   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1079s ][ Queries: 12 (0.0098s) ][ GZIP on ]