Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 07:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Eye Candy
Icewm menu icons
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Wed 14 Apr 2010, 13:35    Post_subject:  Icewm menu icons  

I cannot get Icewm's menu icons to show. Only icons with a full path in the .desktop files show. I think I have the IconPath set correctly, but still no icons.

Any ideas?

Thanks
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 14 Apr 2010, 13:48    Post_subject:  

Create a file /usr/share/icewm/prefoverride and add the following contents:
Code:
#  Icon search path (colon separated)
IconPath="/usr/local/share/icewm/icons:/usr/local/lib/X11/mini-icons:/usr/local/lib/X11/pixmaps:/usr/share/icons:/opt/kde/share/icons/default.kde/16x16/apps:/opt/kde3/share/icons/hicolor/16x16/apps:/usr/share/pixmaps"

Back to top
View user's profile Send_private_message Visit_website 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Thu 15 Apr 2010, 18:02    Post_subject:  

Thanks... but I already have that in both my preferences file and my prefoveride file.

I am not sure if it makes any difference for this (it has for other things) but I am running Puppy Lupu.

Thanks.
Back to top
View user's profile Send_private_message 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Sat 17 Apr 2010, 18:31    Post_subject:  

bump
Back to top
View user's profile Send_private_message 
walter90


Joined: 25 Aug 2009
Posts: 278
Location: Pennsylvania, USA

PostPosted: Tue 20 Apr 2010, 08:21    Post_subject:  

toomuchcomputertime wrote:
Thanks... but I already have that in both my preferences file and my prefoveride file.

I am not sure if it makes any difference for this (it has for other things) but I am running Puppy Lupu.

Thanks.


Did you make a folder called icewm in .etc? You need to copy your preferences file into that folder when you edit it.
Back to top
View user's profile Send_private_message 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Tue 20 Apr 2010, 11:28    Post_subject:  

Thanks,
I just made /etc/icewm and copied all the preference files from /root/.icewm to that folder, ran fixmenus and restarted icewm. Still no icons. Did I do something wrong?

Thanks.
Back to top
View user's profile Send_private_message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 21 Apr 2010, 04:23    Post_subject:  

toomuchcomputertime wrote:
Still no icons. Did I do something wrong?

Ok, let's get back to the basics. What format are the icons you want to use? Where are they located? How big are they (e.g. 48x48, 32x32)? Are you using the icon extension when it isn't .xpm?

The answers to these questions will help us to see what may be happening for you.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Wed 21 Apr 2010, 05:13    Post_subject:  

Why can't toomuchcomputertime just install Jemimah's icewm pet? It fixes the icons problem and has a shutdown menu. I'll bet toomuchcomputertime
is using 4.3x cause it seems to be showing the usual symptoms....

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Thu 22 Apr 2010, 09:43    Post_subject:  

Thanks, yes I am using puppy lucid. I tried Icewm 1.3.2 and it would not give me icons, and icewm 1.3.5 did all sorts of weird stuff (italisized text in menus, doubled text...) but had icons. I found it was the file 'icewm' that made the difference. Yesterday I compiled 1.3.6 but it didn't give me icons either. Jeremiah's icewm (you just linked to) gives me all icons but the icons on the root menu (when you click the 'puppy button'), I can just put full paths in to fix that though. 1.3.2 showed icons when I put in the full path so I know it can support the icons I was using, it just was not using them for some reason, maybe because I am using Lucid.

Thanks everyone for your help, Jeremiah's pet is the fix I think. Laughing

Wow, Icons are nice!!!
Back to top
View user's profile Send_private_message 
walter90


Joined: 25 Aug 2009
Posts: 278
Location: Pennsylvania, USA

PostPosted: Thu 22 Apr 2010, 15:32    Post_subject:  

toomuchcomputertime wrote:
Thanks, yes I am using puppy lucid. I tried Icewm 1.3.2 and it would not give me icons, and icewm 1.3.5 did all sorts of weird stuff (italisized text in menus, doubled text...) but had icons. I found it was the file 'icewm' that made the difference. Yesterday I compiled 1.3.6 but it didn't give me icons either. Jeremiah's icewm (you just linked to) gives me all icons but the icons on the root menu (when you click the 'puppy button'), I can just put full paths in to fix that though. 1.3.2 showed icons when I put in the full path so I know it can support the icons I was using, it just was not using them for some reason, maybe because I am using Lucid.

Thanks everyone for your help, Jeremiah's pet is the fix I think. Laughing

Wow, Icons are nice!!!


Glad you got it worked out! Very Happy
Back to top
View user's profile Send_private_message 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Fri 23 Apr 2010, 08:26    Post_subject:  

Ok, I have another question, the icewm panel is using different sizes for the bar than for the minimize icons. I have been trying to edit the config files, but can't get it fixed. I have attached a picture. What do I need to change?

Thanks.
icewmpanel.png
Description 
png

 Download 
Filename  icewmpanel.png 
Filesize  118.91 KB 
Downloaded  668 Time(s) 
Back to top
View user's profile Send_private_message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Fri 23 Apr 2010, 17:28    Post_subject:  

toomuchcomputertime wrote:
Ok, I have another question, the icewm panel is using different sizes for the bar than for the minimize icons. I have been trying to edit the config files, but can't get it fixed. I have attached a picture. What do I need to change?

They're not different sizes. The source images for the ones that appear smaller have a light line at the bottom that isn't in the buttons, etc. which is giving that illusion.

You need to modify the source images using GIMP or similar to fix the issue.

Hope that helps

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send_private_message 
toomuchcomputertime


Joined: 18 Apr 2008
Posts: 171
Location: /usr/local/lib/X11/pixmaps/Cleveland\ OH\ USA.png

PostPosted: Mon 26 Apr 2010, 19:56    Post_subject:  

Ok, Thanks, I tried using a different theme and it works. The interesting thing is that it worked with a different version of icewm, maybe it reinstalled the theme with a older version of the theme?

Thanks
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Eye Candy
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0738s ][ Queries: 12 (0.0082s) ][ GZIP on ]