Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 03:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Quake 1 repackaged
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Thu 15 Apr 2010, 18:48    Post subject:  Quake 1 repackaged
Subject description: With newest engine version
 

This is Quake 1 pet with newest SDL darkplaces engine from 08.04.2010.
It's a precompiled i686 binary build from official site.
I took quake data files from Quake1.pup.
You can run game from menu or type "quake" in terminal
quake is a script but there's also darkplaces-linux-686-sdl binary in path if you want to run other supported games with it.
I removed all unnecessary subdirs, data, run scripts and other engines from .pup so I basically just took quake data files and added new version of engine.
Keeping puppy fat free, even with games Wink

Who wants engine server binary or glx binary or sources or whatever just grab the full archive from official site:
http://icculus.org/twilight/darkplaces/download.html

Who wants extra levels, maps etc I guess you can go here:
http://quake.phoenixlabs.org/maps/id1/maps/
http://ftp.unsix.net/pub/games/quake/id1/maps/
EDIT: Seems that links for maps no longer work

Put maps in /usr/share/quake/id1/maps/

ADDITIONAL LIBS REQUIRED:

FOR DPUP:
SDL-1.2.13-i386.pet
libgl1-mesa-dri

FOR QUIRKY 018:
SDL-1.2.13-i386.pet
mesa-7.6-q1.pet
Edit /etc/X11/xorg.conf - change "Disable glx" to "Load glx"
I also uncomment "Option DRI"

FOR PUPPY 4.3.1:

SDL-1.2.9.pet
xorg_xorg_full_dri-7.3.pet
Older engine pet attached below

AAAAND, HERE'S THE PET:
Quake1-i686-sdl.pet about 10 MB
MD5SUM should be: 1b44107b61ad44edf514e0950f680532 Quake1-i686-sdl.pet

Thanks to id software and Lord Havoc for his enhanced engine
Enjoy playing! Wink
darkplaces-engine-old.pet
Description 
pet

 Download 
Filename  darkplaces-engine-old.pet 
Filesize  453.75 KB 
Downloaded  508 Time(s) 

_________________



Last edited by dejan555 on Sun 12 Feb 2012, 08:31; edited 4 times in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Fri 16 Apr 2010, 12:02    Post subject:  

Thanks, dejan555!

Unfortunately, Boxpup 4.31 (CLI) complains:
Code:
# quake
# darkplaces-linux-686-sdl: /lib/libc.so.6: version `GLIBC_2.7' not found (required by darkplaces-linux-686-sdl)


So it won't run from the menu entry or the terminal. Installing the SDL pet did not help in my case (libc.so.6 is not included). Searching....

-Roy
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Fri 16 Apr 2010, 12:43    Post subject:  

Hmm, well you do have libc lib already in system, probably incompatible glibc or something. I didn't test this in 4.3.* though in dpup runs fine. I'm gonna try it in 4.3.1 later and quirky.
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Fri 16 Apr 2010, 13:02    Post subject:  

dejan555,

Now that you mention it, you are right. I see a symlink named libc.so.6 in /lib/. Unfortunately, that does not stop the terminal's complaint. As I am running Thunar and Openbox, I cannot see where the symlink points to... maybe /lib/libc-2.6.1.so? Just guessing on my end.

-Roy
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Fri 16 Apr 2010, 13:39    Post subject:  

Roy, I attached engine that was originally in .pup, install pet and it will work. Seems that current build is still too new for current puppy, I assumed it will run since it runs in dpup.

P.S. You will also need xorg dri installed.

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Fri 16 Apr 2010, 14:32    Post subject:  

Well, that happens when you don't properly test your pet on clean boot with pfix=ram, shoulda done that in the first place, I edited first post with more details about requirements on specific puppies, it works on both dpup and quirky with newest engine, it's only 4.3.1 that still has older glibc (quirky 018 has 2.10 and dpup 2.10.2)

Darn, too much puppies to test now Sad

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Sat 17 Apr 2010, 03:12    Post subject:  

Thanks, dejan555.

I'm not skilled at playing computer games like these, but can tell you that running "quake" in Boxpup4.31's terminal brings up the game with the old engine you just posted.

Thank you!

-Roy
Back to top
View user's profile Send private message 
walter90


Joined: 25 Aug 2009
Posts: 278
Location: Pennsylvania, USA

PostPosted: Fri 30 Apr 2010, 16:43    Post subject:  

This game is fun! I had to use the older engine on 4.3 but aside from being a little laggy in places it plays just fine.

A little tip if you're like me and can't get any new maps to load but you still want to play: Edit your save file to make yourself stronger, apponents stronger or weaker and so on.

This plays as a demo for me and only the first episode is playable. I'm working on a solution.
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Fri 30 Apr 2010, 17:50    Post subject:  

Needs original pak files from quake cd I guess for further episodes.
Files for other playable games as Nehahra can be found on net for download
http://www.quaddicted.com/reviews/nehahra.html

Also you can download quake maps and put them in maps folder then load from drop down console in quake (type tilde ~ than "map nameofmap") There's also command to list all maps available see help for all commands.

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
walter90


Joined: 25 Aug 2009
Posts: 278
Location: Pennsylvania, USA

PostPosted: Sat 01 May 2010, 16:05    Post subject:  

dejan555 wrote:
Needs original pak files from quake cd I guess for further episodes.
Files for other playable games as Nehahra can be found on net for download
http://www.quaddicted.com/reviews/nehahra.html

Also you can download quake maps and put them in maps folder then load from drop down console in quake (type tilde ~ than "map nameofmap") There's also command to list all maps available see help for all commands.


Thanks dejan555! Very Happy
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 01 May 2010, 17:25    Post subject:  

see also here:
http://www.murga-linux.com/puppy/viewtopic.php?p=43746

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Sat 01 May 2010, 18:27    Post subject:  

Welcome back Mark Smile
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
DukeDomo

Joined: 16 Dec 2011
Posts: 7
Location: Croatia

PostPosted: Fri 16 Dec 2011, 06:41    Post subject: Need help  

I have installed the pet package and it works, but this is completely unplayable.
Am I missing something?

I am running Wary 5.2.2. on Duron 800mhz/256ddr/RivaTNT2 32MB

Made frugal install with basic save on SCSI drive and got 3GB swap file.

Cause i really love this game and in Windows with this machine it would run like a kitten, please help if any to be had?
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2647
Location: Montenegro

PostPosted: Fri 16 Dec 2011, 16:59    Post subject:  

Hi DukeDomo, I've never ran it on Wary or machine with those specs so I'm not sure but you'd need to install aditional libs I mentioned and DRI acceleration/opengl libs for your card, also did you try older version of engine that is attached in post?
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
DukeDomo

Joined: 16 Dec 2011
Posts: 7
Location: Croatia

PostPosted: Sun 18 Dec 2011, 12:21    Post subject:  

older Darkforces engine was worse... sound broken unplayable.

Okay got SDL 1.2.14 for Wary5 installed both pet packages, I updated to Xorg7.6 right after frugal install.

DRI acceleration/opengl libs for your card?
What would that be for above specified graphic card?

Cause I tried installing nvidia74.xxx driver and required kd file but nothing happens better, only my media player lost ability to fullscreen movies, ie when switched to fullscreen video size stays same.

Any help or should i give up on playing Quake on Puppy? Sad
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0771s ][ Queries: 12 (0.0057s) ][ GZIP on ]