Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 12:39
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Lupu- Localising Quickpet
Moderators: Lobster, MU, raffy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 8 of 10 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10 Next
Author Message
mave

Joined: 02 Apr 2009
Posts: 130
Location: Germany

PostPosted: Mon 15 Nov 2010, 18:28    Post_subject:  

german Smile
de_DE-400.tar.gz
Description 
gz

 Download 
Filename  de_DE-400.tar.gz 
Filesize  5.74 KB 
Downloaded  538 Time(s) 
Back to top
View user's profile Send_private_message 
GustavoYz


Joined: 07 Jul 2010
Posts: 896
Location: .ar

PostPosted: Wed 17 Nov 2010, 01:05    Post_subject:  

Spanish local for v4beta5 400...
Using the base of previous Droope work + some corrections (usé una traducción más formal para que sea entendible por todos los hispanos, no sólo por los rioplatenses -como yo-) + translation on the newest parts...

Still can't probe it on LuPu 501...
When I overwrite the 'es_ES:spanish' file for this -attached-new version, it returns to english..
Am I doing something wrong with the test? Embarassed

Usuarios y traductores hispanos: Siéntanse libres de corregir y criticar... Cool

Cheers.
es_ES-400.tar.gz
Description  Local, archivo llamado "es_ES:spanish"... Para Quickpetv4beta5 (400).
gz

 Download 
Filename  es_ES-400.tar.gz 
Filesize  5.23 KB 
Downloaded  511 Time(s) 

_________________

Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Wed 17 Nov 2010, 03:30    Post_subject:  

Thanks mave and GustavoYz,

They are added for the next version, just awaiting some code from Barry to update the Quickpet back end.

Cheers Very Happy

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
himajin


Joined: 08 Jul 2008
Posts: 54
Location: JAPAN

PostPosted: Wed 17 Nov 2010, 03:54    Post_subject:  

Japanese local for v4beta5 400
ja_JP-400.tar.gz
Description 
gz

 Download 
Filename  ja_JP-400.tar.gz 
Filesize  5.8 KB 
Downloaded  519 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Wed 17 Nov 2010, 04:41    Post_subject:  

GustavoYz wrote:

Still can't probe it on LuPu 501...
When I overwrite the 'es_ES:spanish' file for this -attached-new version, it returns to english..
Am I doing something wrong with the test? Embarassed

Hola GustavoYz,

I wonder what would happen if you change your locale (menu > desktop > country settings) from es_AR to es_ES, just for testing? If that would give you the Spanish Quickpet, it would mean a link between es_AR and es_ES is missing or broken.
buena suerte!

_________________


Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Fri 19 Nov 2010, 21:46    Post_subject:  

new version

Quickpet 4beta7

*Added all translations, new and updated.

*some backend tweaking of sfs handling

Cheers Very Happy

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sun 21 Nov 2010, 21:22    Post_subject:  

New version with some bugfixing and added functionality for Barry's new 'download_file', when it is incorporated.. next woof.

Quickpet 4rc2 (rc1 didn't last long Laughing )

See main post

Cheers!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Mon 22 Nov 2010, 05:36    Post_subject:  

Hi Mick,

I see the new quickpet_lupu-4rc2.pet, but the language file is still the old english.gz, right?

So no need to translate at this moment?
Sfs-grab...;wonderful. Thank you!

,

_________________


Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Mon 22 Nov 2010, 06:03    Post_subject:  

No translation needed..

I should have said that Embarassed

Cheers!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 22 Nov 2010, 11:05    Post_subject: Re: Lupu- Localising Quickpet
Sub_title: We need translators
 

01micko wrote:
NOTE: Now 4rc2.. sfs bugfix for full installs added, functionality for Barry's new 'download_file' script, frontend for wget, AND a new tiny gui for sfs_grab if you have a local sfs or for a remote sfs not in quickpet
This is a great new feature since most of us probably already have downloaded sfs files that we want to install.

Unfortunately, the "Sfs_grabber" feature doesn't work on a new full hd installation of luci-238. My installation is on sdb7 and I have tried to drag several sfs files from sdb3 to install them. The dialogue box goes away when OK is selected, however nothing happens. The files I tried are the OOO file shown and luci_devx_238.sfs.

Note the output when I tried to install a sfs with a console. I had used "Sfs get" to install Bibletime before trying to use the new "Sfs_grabber" feature. This may be a clue to the problem.
Code:
# sfs_installation.sh  /mnt/sdb3/luci_devx_238.sfs       
http://ftp.cc.uoc.gr/mirrors/linux/puppylinux/pet-packages-lucid/Bibletime_lucid-2.7.2a.sfs
Bibletime_lucid-2.7.2a.sfs
Bibletime_lucid-2.7.2a
# killall: Xdialog: no process killed
It did work fine on a fresh frugal installation of luci-238.

Cheers,
Jim
desktop.png
Description 
png

 Download 
Filename  desktop.png 
Filesize  530.81 KB 
Downloaded  559 Time(s) 
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Mon 22 Nov 2010, 16:25    Post_subject:  

Thanks for testing Jim

I'll look into it pronto.

Cheers

____________________________________________
later...

Ok, Jim did a fresh full of luci-238 in a spare ext3 I had just for this purpose Wink

I downloaded Bible Time from the aarnet mirror by copy/pasting the link in the sfs_grabber gui. It worked flawlessly.

I dragged the devx from sda7 to the sfs_grabber gui. It worked flawlessly.

I'll try from a prompt something else..
Code:
# sfs_installation.sh /mnt/sda5/Acrobat_Reader-9.3.3-Lucid.sfs
/mnt/sda5/Acrobat_Reader-9.3.3-Lucid.sfs
Acrobat_Reader-9.3.3-Lucid.sfs
ok
Acrobat_Reader-9.3.3-Lucid
Parallel unsquashfs: Using 2 processors
335 inodes (1416 blocks) to write

[=============================================================-] 1416/1416 100%
created 309 files
created 92 directories
created 26 symlinks
created 0 devices
created 0 fifos
/usr/sbin/sfs_installation.sh: line 19: 13205 Terminated              gtkdialog-splash -icon gtk-dialog-info -bg thistle -text "Please wait while ${THESFSMNT} is processed..."  (wd: ~)
EXIT="Exit on timeout"
EXIT="OK"
Generating /root/.icewm/menu...
Generating /root/.jwmrc...
Generating /root/.fbpanel/default...
killall: blinky_tray: no process killed
killall: traytemp: no process killed
killall: vattery: no process killed
killall: powerapplet_tray: no process killed
Generating /root/.config/openbox/menu.xml...
EXIT="Exit on timeout"
#

Ok, that worked for a local file ... I'm a bit worried here Confused .. why does it fail for you?

Thanks again for testing.

Cheers



___________________________________________

Some things to look for....

open /tmp in rox

*the sfs goes to /tmp
*it gets converted to a directory, you should see that in /tmp
*that directory gets tarred up, you should see that happen in /tmp
*that tarball is converted to a pet.

EDIT!
Thanks for your clue!!!! the /file generated by quickpet isn't removed!!!!!
tmp_and_pet_created.png
 Description   note previously downloaded nvidia and firefox through quickpet, also bible time through sfs_grabber
 Filesize   101.51 KB
 Viewed   1305 Time(s)

tmp_and_pet_created.png

devx_local.png
 Description   
 Filesize   45.96 KB
 Viewed   1314 Time(s)

devx_local.png

devx_success.png
 Description   
 Filesize   43.46 KB
 Viewed   1312 Time(s)

devx_success.png


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 22 Nov 2010, 17:47    Post_subject:  

01micko wrote:

Ok, Jim did a fresh full of luci-238 in a spare ext3 I had just for this purpose Wink

Ok, that worked for a local file ... I'm a bit worried here Confused .. why does it fail for you?

Thanks again for testing.

Cheers
After receiving your message, I rebooted and tried again, it worked perfectly, installing these applications: luci_devx_238, LibreOffice_3.3.0beta2_sfs4, and java_jre-6u22-Lucid-sfs4. I had just done a fresh full hd installation of Luci-238 to test your Sfs_grabber and had not rebooted the installation. Apparently, it has to be rebooted to save some files.

Thank you for the updated Quickpet. With that capability, I may make more use of full hd installations. The handling of sfs files, to me, is the largest advantage of a frugal installation. Now you've eliminated that problem.

Cheers,
Jim

Edited_times_total
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Mon 22 Nov 2010, 17:50    Post_subject:  

Jim, there was a bug, thanks for bringing it to my attention, by rebooting you flushed /tmp. There was a stale file in /tmp that sfs_installation.sh uses. That is now eliminated as soon as sfs_installation.sh has the data it needs.

I just tested with vlc from the quickpet gui, then installed the kernel source which I had locally, working properly now. It would have been an apparent bug in all forms of installation too, maybe with different, even worse consequences!

New Quickpet 4rc3 is in the main post.

No translation changes.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 22 Nov 2010, 18:33    Post_subject:  

01micko wrote:
I just tested with vlc from the quickpet gui, then installed the kernel source which I had locally, working properly now.
Installed amarok-1-4-lucid.sfs using Quickpet v4rc3. It's an older version of amarok, but still works great.
Thanks,
Jim
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Wed 01 Dec 2010, 05:51    Post_subject:  

Quickpet 4rc4 is out!

see main post

-some improvements to graphics detection
-some Lobster proofing Wink
-there are some translation additions, you will see, not many

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 8 of 10 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0946s ][ Queries: 12 (0.0083s) ][ GZIP on ]