Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 15 Dec 2017, 21:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
MiniDLNA media server
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 6 [79 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Sun 10 Jan 2016, 17:56    Post subject:  

Greengeek: Answers...

I can see son's Windows laptop as his machine name in Sources menu on the tv, and can play photos from my Galaxy S2 by choosing it from Sources once I activate DLNA on it. Son won't let me near his laptop for fear of what I might discover! All this implies that the tv is alive and well and the server isn't.

The phone can be searched for video, photo, or music from the tv and once a choice has been made, open folders. It is definitely recursive then?

If I do / / minildna -restart I don't get the hyphen options! Curious... wonder where they came in then. Ah yes. Typed just minidlna and they appear.

A question then would be how do we know if it is running? The lack of error messages in terminal?

Trapster: Added the /Photos to the /mnt/sdb1 line, saved and did -restart in terminal. sdb1 is being mounted by PCManFM but is that only for itself and not the whole system? Does MiniDLNA need to mount it? And the fundamental question still remains: Why doesn't the tv see the server (yet)?

Cheers guys.
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2098
Location: Maine, USA

PostPosted: Sun 10 Jan 2016, 19:42    Post subject:  

Most important is to see if it's actually running.
To check to see if it's running, type in a terminal:
Code:
top

or
Code:
htop


I do not think the hyphen "-" works with minidlna -restart

I believe the proper command is:
Code:
/etc/init.d/minidlna restart


I use
Code:
minidlna &

in my /etc/rc.d/rc.local to have it start when booting.

what messages do you get in the terminal when you type
Code:
minidlna -restart

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Slacko
Currently using full install: DebianDog
Back to top
View user's profile Send private message Visit poster's website 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Sun 10 Jan 2016, 23:14    Post subject:  

Trapster: htop shows no sign at all of MiniDLNA as a running item.
If I type the restart with a hyphen, or without, there is equally no response.

Interestingly, my phone shows on the tv as an Allshare device and is completely searchable.

I'm not the sharpest knife in the drawer, but i believe MiniDLNA isn't loading at all and won't tell me why.

Rufwoof: you might just have something there!

Thanks for your time, guys.
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4748
Location: Republic of Novo Zelande

PostPosted: Mon 11 Jan 2016, 03:26    Post subject:  

Hi BJF - does your Dell have a CD drive? Could you temporarily boot from a Slacko 5.6 CD and try again? I feel you need to try a Puppy that is proven to work and then go back to your current Puppy. (you wont need to set up any of the usual network shares etc - just boot from CD, load the 2 pets and configure the conf file and it should work)
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Mon 11 Jan 2016, 10:40    Post subject:  

I know this thread discusses use of @Shinobar's PET for serving media to DLNA devices, but, @ETP has produced this PET.

His concept is that one can have a FULL USB dedicating to booting and serving DLNA protocol media files on the home LAN.

One needs to have a blank USB handy and if you follow these instructions, you are completed with a operational server ready for your use. Once booted it is reasonably simple to use. It has sample media files setup in the folders for DLNA. In this case, the user need do NOTHING and all is operational upon booting.

There should be no problem as a 5 yr/old PC is a 64bit PC.

I seem to remember another PUP offering containing DLNA built-in but my memory fails.

Hope this is helpful

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Tue 12 Jan 2016, 02:57    Post subject:  

THIS IS OFF-TOPIC.

g.c.martin: Thank you for your advice. It may well be of use were I to ultimately abandon my MiniDLNA quest without success in LXPrecise.

Many thanks,
John (BJF)
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Tue 12 Jan 2016, 03:40    Post subject:  

Hi John.
BJF wrote:
...my MiniDLNA quest without success in LXPrecise. ...
I understand how frustrating these subsystem can be. What I suggest in no way is meant for you to abandon your goal. It was merely meant to provide you a 2nd manner to check DLNA use on your LAN from a Linux platform.

There is another platform that may also be useful. It is the DLNA TahrPUP distro floating around somewhere which also, has it working OOTB. Thus, this WOOFCE generated distro may help you to your pathway. IIRC, it can be run directly from a CD/DVD boot. If so, adding LXDE to either suggestion may shorten the frustration by giving you manners to test a particular PC in DLNA streaming.

Just trying to offer something helpful in your miniDLNA quest.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4748
Location: Republic of Novo Zelande

PostPosted: Tue 12 Jan 2016, 05:09    Post subject:  

Hi BJF
- what method are you using to turn off your firewall?
- Is it possible for you to post the terminal messages that you see when you start the minidlna server.
- Also - any chance you could post the contents of /tmp/minidlna/minidlna.log after starting the server?

cheers!
Back to top
View user's profile Send private message 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Wed 13 Jan 2016, 00:10    Post subject:  

greengeek: The firewall has never deliberately been turned 'on' on this install, and if I go to the Firewall Wizard thingy (technical term) in the Utilities>PupControl panel it offers options to set it up. Is there a terminal command to definitively turn it off that I should know? In addition none of our laptop machinery has a problem talking to its printer or Samba-ing its files when I started down that track.

The reaction when I start MiniDLNA in terminal? Absolutely nothing!

And as to /tmp/minidlna/minidlna.log.... There isn't one! /tmp contains no minidlna reference at all.

What do you make of that, Watson?
Back to top
View user's profile Send private message 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Wed 13 Jan 2016, 01:20    Post subject:  

greengeek: Correction, this:

Code:
# minidlna start
Unknown option: start
Usage:
   minidlna [-d] [-f config_file]
      [-a listening_ip] [-p port]
      [-s serial] [-m model_number]
      [-t notify_interval] [-P pid_filename]
      [-w url] [-R] [-V] [-h]

Notes:
   Notify interval is in seconds. Default is 895 seconds.
   Default pid file is /var/run/minidlna.pid.
   With -d minidlna will run in debug mode (not daemonize).
   -w sets the presentation url. Default is http address on port 80
   -h displays this text
   -R forces a full rescan
   -V print the version number
#



But a restart produces no result.
Code:
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4748
Location: Republic of Novo Zelande

PostPosted: Wed 13 Jan 2016, 02:49    Post subject:  

OK, reboot and try again using exactly this syntax:

/etc/init.d/minidlna restart

Please post the terminal output for that syntax and we'll see where we're at.
(then have another look for the log file that was missing before)

If that doesn't work then I think you should look at hiding your savefile (or savefolder) and trying that same syntax on a fresh boot without savefile (in case it is contaminated somehow or just incompatible with the original pet).



EDIT : If the use of the syntax above does not help then I would like you to try the following:

- make a backup copy of your savefile.

- Download (and save somewhere) this pet that I have made for you: minidlna autostart sdb1 pet for BJF only !!
(It is set up for sdb1 and is fully automatic so you don't even have to make any changes to the config file).

- Hide your savefile (or savefolder) so that you can boot into a fresh version of your usual Puppy

- Boot without savefile,

- Load the pet and read/follow the onscreen instructions. (This will load the minidlna server, start it, and access the media files on sdb1).
(When you shutdown say no to creating a new savefile - just go back to your original one for the next boot. If the pet has worked successfully then we can talk about how to graft it into that original savefile)

I'm hoping you won't need to resort to the pet, and that the syntax correction mentioned earlier will be enough.

Note: I think your problem has been this: - using the syntax of "minidlna restart" does not work even though it appears to be accepted, when it should probably say "command not found" because you are not referencing the actual location of minidlna. I believe that when you use the /etc/init.d/minidlna restart syntax it should work providing the pet has loaded correctly in the first place.

Here is a comparison of the bad syntax followed by the correct one on my system:
.
minidlna_syntax_compare.jpg
 Description   
 Filesize   23.02 KB
 Viewed   334 Time(s)

minidlna_syntax_compare.jpg

Back to top
View user's profile Send private message 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Wed 13 Jan 2016, 15:56    Post subject:  

greengeek: Did Reboot and typed /etc/init.d/minidlna restart to terminal.
Again, no response, and no .log file created.

Thank you for your work on the .pet, but I fear that there is a complication: the server is a Full install. I just thought a Full was all I needed on something dedicated like that server and haven't fully embraced the Frugal concept. I need a mind-set change to read the options as Normal and Full installs perhaps!

With a Full install, how do we go about this then. Uninstall MiniDLNA, and use your .pet? That would be my choice unadvised, but I am only the pupil here.

Cheers,
BJ.
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2001
Location: In The Way

PostPosted: Wed 13 Jan 2016, 16:21    Post subject:  

BJ

try
Code:
chmod 755 /etc/init.d/minidlna
/etc/init.d/minidlna start


worked for me
Back to top
View user's profile Send private message MSN Messenger 
greengeek


Joined: 20 Jul 2010
Posts: 4748
Location: Republic of Novo Zelande

PostPosted: Wed 13 Jan 2016, 16:23    Post subject:  

BJF wrote:
Did Reboot and typed /etc/init.d/minidlna restart to terminal.
Again, no response,
If you can post the terminal output that is helpful in triggering the thought process for troubleshooting. What I have seen is that the minidlna sometimes gives different forms of "no response" - if I can compare what your terminal says with what I have seen on mine it might suggest to me what is happening. (sometimes no response indicates the server is already running. Sometimes it means it never started - depends on the exact message or non message that is returned to terminal)

Quote:
With a Full install, how do we go about this then. Uninstall MiniDLNA, and use your .pet?
No - lets not touch the full install at all. What I think is best is this - make a CD containing the default iso image (specifically "image" - not "file") of your current pup LXPup-Precise-Retro 14.10 (you probably already have this on disk from when you downloaded it originally). Then boot your Dell from that CD. Enter the following at the boot: prompt:

puppy pfix=ram

This boots the puppy into RAM only, ignoring any previous files, savefiles etc.

Once booted use a terminal to enter the following:

ifconfig

This will probably indicate that the network is already active (because you are connected via wired eth0). If not already connected run the network setup wizard to get hooked up to your router.

Then click on the pet I made for you. It will prompt you to check that the firewall is off (this will be the default anyway i guess), tell you to mount sdb1, and make sure your media files are already available on sdb1.

Just read the onscreen message box and when you are ready close it and the minidlna server should automatically start. You won't see anything onscreen to tell you it's running but you should at this point be able to see the dlna upnp connection in the TV sources list. It should let you browse to the location of the media files.

If this just doesn't work for you then I think it is possible that LXPup-Precise-Retro 14.10 has some incompatibility with this pet. The purpose of doing the RAM boot from CD is that it clears out the possibility of any minidlna fragments that might be in your saved files (as part of the full install).

As an alternative to doing the CD test with LXPup-Precise-Retro 14.10 it may be better to try it with Slacko 5.6 as I know the minidlna pet works with that.

Sorry to be so verbose - just trying to be clear.
Back to top
View user's profile Send private message 
BJF

Joined: 24 Mar 2008
Posts: 244
Location: Lower Hutt, New Zealand

PostPosted: Thu 14 Jan 2016, 01:45    Post subject:  

greengeek: Verbose is good. I subscribe to the theorum that silly questions are better than silly excuses. And verbose results in fewer silly questions!

When I do /etc/init.d/minidlna restart the cursor drops to the next line and waits as long as I do. There is simply nothing going on. Nothing to post.

I'll fish out the install cd and run that live as you direct, and see what happens. Wait one.......

ATB,
BJ.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 6 [79 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0701s ][ Queries: 14 (0.0098s) ][ GZIP on ]